Jump to content

Whats the most annoying bug you encountered?


Recommended Posts

7 minutes ago, SackMaggie said:

Cool/Hot pipe

Don't even go there, Thankfully it has never happened in my live bases but i was running a test on a part of one and suddenly it cooked everything.

Also my current/most hated bug is steam passing through a disabled generator randomly. Sometimes it passes, other times it doesnt.

Link to comment
Share on other sites

11 minutes ago, landromat said:

Steam turbine eats steam if you have something besides steam in the chamber

In the bug I reported it just lets it pass through very randomly. If there is no gas on the opposite side nothing passes through though like you said. but as soon as there is any gas on the opposite side it just starts going through it, as if it is made of airflow tiles. Regardless of whether it is toggled off, un-powered, switched off by automation etc. Its meant to be a solid tile and let gas through at 3kgs once it is running (I assume it is still 3kg/s of steam)

Link to comment
Share on other sites

2 minutes ago, BlueLance said:

In the bug I reported it just lets it pass through very randomly. If there is no gas on the opposite side nothing passes through though like you said. but as soon as there is any gas on the opposite side it just starts going through it, as if it is made of airflow tiles. Regardless of whether it is toggled off, un-powered, switched off by automation etc. Its meant to be a solid tile and let gas through at 3kgs once it is running (I assume it is still 3kg/s of steam)

i have to use automation and constantly add water bacause it magically disappears from 40kg/m to 5kg/m

Link to comment
Share on other sites

I don't know if this is an actual bug or just really crappy luck, but starting a new seed with 0 shine bugs in the starting biome stresses me out a bit.  I'm a heavy rancher and omelette maker type of player.

Link to comment
Share on other sites

25 minutes ago, landromat said:

i have to use automation and constantly add water bacause it magically disappears from 40kg/m to 5kg/m

I am not sure if mines eats steam, I plan to run it intermittently so it will just store steam and use it as needed. Since the system has never run through a full cycle of steam I am unsure of how much it consumes, I could shrink it etc but that makes cooling it harder. and it has a collection tank of about 22 tiles so the system could hold at least that much before it backs up. I was going to use automation so that as long as the collection tank has water or is pumping etc no new water would come into the system.

Current Problem excluding the weirdness is if I put in too much water the steam eventually gets too hot to cool effectively or it melts the generators

17 minutes ago, Albryant said:

I don't know if this is an actual bug or just really crappy luck, but starting a new seed with 0 shine bugs in the starting biome stresses me out a bit.  I'm a heavy rancher and omelette maker type of player.

Crappy luck. Hopefully you have one of the ruins with lots in it.

Link to comment
Share on other sites

The duplicant suffocation dance bug. Duplicant constantly switches back and forth between two pockets of oxygen and eventually suffocates even though there’s lots of oxygen available.

If that’s not technically a bug then the fact slicksters get caught (submerged) on open oil is also annoying.

Link to comment
Share on other sites

 

4 minutes ago, yoakenashi said:

The duplicant suffocation dance bug. Duplicant constantly switches back and forth between two pockets of oxygen and eventually suffocates even though there’s lots of oxygen available.

If that’s not technically a bug then the fact slicksters get caught (submerged) on open oil is also annoying.

Slide to the left, Slide to the right, Criss Cross, Criss Cross, Cha cha real *Collapses*

Link to comment
Share on other sites

There's still no way to activate the in game menu without using a keyboard which is technically not a bug, more of a bug bear.

I think after so long this is a real oversight in regards to accessibility.

 

Link to comment
Share on other sites

Building something and crash. Its the most annoying thing, because the game shuts down, and you dont know exactly what caused it.

 

And sure, the game is in development. It has to be buggy, because otherwise it would be released.

People complaining about that, while in early access can go to hell. They have not bought a finished product. 

Link to comment
Share on other sites

I just ran into an odd one.  Built a series of hydroponic tiles to hold pepper plants.  After they were finished,  I then setup a pipe running through them.  When the dupes started building the pipe segment,  the tile immediately broke with a "pressure damage" warning.  The dupe just sits there and never finishes building it either (plus it's, you know,  broken).  Pressure in the area was only 1200g of gas. 

Link to comment
Share on other sites

8 minutes ago, Soulwind said:

I just ran into an odd one.  Built a series of hydroponic tiles to hold pepper plants.  After they were finished,  I then setup a pipe running through them.  When the dupes started building the pipe segment,  the tile immediately broke with a "pressure damage" warning.  The dupe just sits there and never finishes building it either (plus it's, you know,  broken).  Pressure in the area was only 1200g of gas. 

That happens when there are a lot of build areas apparently, I have never had it happen, but a streamer I watch has it happen whne he has multiple builds going on in or near a single tile. I think he actually lost a good few sections due to it

Link to comment
Share on other sites

I got this bug all the way back in the Thermal Upgrade. I call it the invisible sand glitch. When sand fell, I would send my dupes to break it. They do so, but it is still there, just invisible. They would climb over it and everything just like a normal sand. When I send them to dig it, they actually dig it and cracks would appear as well. But, this is resolved now.

Link to comment
Share on other sites

4 hours ago, SharraShimada said:

Building something and crash. Its the most annoying thing, because the game shuts down, and you dont know exactly what caused it.

 

And sure, the game is in development. It has to be buggy, because otherwise it would be released.

People complaining about that, while in early access can go to hell. They have not bought a finished product. 

Post the dump files to klei

Its in :

C:\Program Files\Steam\SteamApps\common\OxygenNotIncluded\

Or 

~SteamLibrary\SteamApps\common\OxygenNotIncluded\

Its usually a SimDLL access violation crash and unfortunately you can't report it via game and it won't appear in output log/dxdiag

 

// Access violation might have something to do with preview branch's listener 

 

Link to comment
Share on other sites

I really hate the change in temperature inside a vacuume happening in the preview branch:

Transit tube crossings heat/cool down inside a vaccume or neutronium chamber. (No heat transfer, just deleting/adding heat)

=> In a normal game each transit tube crossing act´s as a temperature stabilizer (Nice to abuse but horrible gameplay-wise)

Link to comment
Share on other sites

39 minutes ago, DyingCrow said:

All of the above.

Yeah my opinion ;)

and nothing of the stuff below:

13 minutes ago, Kabrute said:

Ice/pice melting out in drips and dribbles so that my dupes get wet feet in cold biomes when I just finished mopping

Sure it´s annoying but a good solution for how stuff melts. (Or could you suggest a "better" solution ?)

2 minutes ago, Olimar said:

The most annoying bug I've encountered is that darn ceiling light.  Just "fix it" so it's called light,  and everyone can be happy being able to place it anywhere they like.   ;) 

Why should we have gravity-free floating stuff ? I think it´s reasonable that buildings need a mounting point

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...