Recommended Posts

harmonium    67
1 hour ago, Nightinggale said:

I suspect this could be done by adding a postfix to SpiceVineConfig.CreatePrefab, use the return value (a GameObject instance) to read TemperatureVulnerable. That one has some public floats, which looks like they are the temperature thresholds.

The question is how the state machine will respond if it happens to be set up and then the numbers are altered. There is only one way to find out: find somebody who will spend the time trying to implement this and see what happens.

The ideal mod would be a config file, which contains all thresholds for all plants.

I have not understand everything but if someone can help that would be cool

Share this post


Link to post
Share on other sites
Cairath    857

I do not make mods that remove difficulty by principle. I do not like them, I do not use them -- so you have to ask someone else, sorry.

 

@FenrirZeroZero yes, I'll upload it. Been very busy lately and forgot about a couple D:

  • Like 1

Share this post


Link to post
Share on other sites
harmonium    67

Cairath maybe you can create Something to make more heat, and balance it to make it balanced.

Share this post


Link to post
Share on other sites
Nightinggale    967
1 minute ago, harmonium said:

Cairath maybe you can create Something to make more heat, and balance it to make it balanced.

What's wrong with the vanilla space heater?

Share this post


Link to post
Share on other sites
harmonium    67
Just now, Nightinggale said:

What's wrong with the vanilla space heater?

He Don't work very well, and take lot of place 

Share this post


Link to post
Share on other sites
Cairath    857
On 27/06/2019 at 10:57 PM, Cairath said:

I do not make mods that remove difficulty by principle.

If you want mods to make the game easier, you're in a wrong thread. 

  • Haha 1

Share this post


Link to post
Share on other sites
Slvrsrfr    72
On 2/2/2019 at 4:24 AM, Cairath said:

Also, released a mod I finished last night: Eerie Colors. 

I've longingly looked at the old, dark screenshots and wanted to have something like that in game. 

What this mod does:

- uses one background for the entire map - by default it is background of the unused crystal biome (can be turned off or changed to background of another biome)

- removes color tints on elements and buildings in the world applied per biome and uses one color for the entire world instead (can be turned off, configurable color)

Please do not take the .dll out of the folder. Keep it together with the Config.json file.

A couple of screens:538e87470b.jpg

 

995885174f.jpg

 

And so, Colorful Shinebugs are so much doper now:

f74233ae5a.jpg

this lighting is amazing! that second shot is incredible, it nails that old look/feel for me. Great job! :)

Is that a mod to have starter mesh tiles?

  • Like 1

Share this post


Link to post
Share on other sites
Cairath    857
2 hours ago, Slvrsrfr said:

this lighting is amazing! that second shot is incredible, it nails that old look/feel for me. Great job! :)

Is that a mod to have starter mesh tiles?

Noooo, I was just replacing tiles to test stuff :)

Share this post


Link to post
Share on other sites

Cairath i have (another) request. :)

A storage compactor with liquid input & output to cool the content.

And an high capacity storage compactor from steel. (like 100x the normal storage) with thermal seal (not temp exchange with Environment)

It's not about easier but to reduce lag and thermal interaction. 

Share this post


Link to post
Share on other sites

Question on the Conveyor Filter - I posted on steam, but decided to hunt you down here too.  I'm working on a conveyor mod for sandbox builds, and I'm running into issues with the filters, as well as creation code, and would love some input from you.  Also, with the launch update, the conveyor filter no longer works.  Any word on a possible update there?

I get your point on not making the game easier, and the mods I'm working on are to easily test some automation setups in sandbox mode without having to make an auto miner and fill in areas with specific materials to test them.  They aren't anything I'd end up using in actual gameplay.

Share this post


Link to post
Share on other sites
lee37683    1

your conveyor rail filter is broken for me. only mod that doesn't work since the launch. keep getting message that I'm not authorized to write to a mod/steam sub folder. then resets all my mods, and requests a restart. 

Share this post


Link to post
Share on other sites
Nightinggale    967
5 minutes ago, lee37683 said:

your conveyor rail filter is broken for me. only mod that doesn't work since the launch. keep getting message that I'm not authorized to write to a mod/steam sub folder. then resets all my mods, and requests a restart. 

I'm not sure the mod is to blame for that. Windows 10 is known to screw up regarding permission to write to mods and ONI itself isn't that great at avoiding issues of this kind either.

Try quitting the game. Unsubscribe, start the game, quit, subscribe and start up again. Now you can enable, restart and with a bit of luck your problem will be gone.

Share this post


Link to post
Share on other sites
Cairath    857
20 minutes ago, lee37683 said:

your conveyor rail filter is broken for me. only mod that doesn't work since the launch. keep getting message that I'm not authorized to write to a mod/steam sub folder. then resets all my mods, and requests a restart. 

To start with, it hasn't been updated yet. Don't even bother :p All mods that were updated have a "nicer" thumbnail with a name and I commented on them that they are ready. I will continue uploading updates after I am done with work for today.

But the unauthorized access is another issue which is not related to a specific mod, just to your system permissions in the game folder.

Share this post


Link to post
Share on other sites
lee37683    1
1 hour ago, Nightinggale said:

I'm not sure the mod is to blame for that. Windows 10 is known to screw up regarding permission to write to mods and ONI itself isn't that great at avoiding issues of this kind either.

Try quitting the game. Unsubscribe, start the game, quit, subscribe and start up again. Now you can enable, restart and with a bit of luck your problem will be gone.

yeah... don't blame the mod either.. just something I can't figure out and it popped up in relation to the mod not working. 

been doing that all day yesterday. quit, unsub, resub, restart... mix and repeat. trying to get mods to work. i'm done with that aspect for now.

1 hour ago, Cairath said:

To start with, it hasn't been updated yet. Don't even bother :p All mods that were updated have a "nicer" thumbnail with a name and I commented on them that they are ready. I will continue uploading updates after I am done with work for today.

But the unauthorized access is another issue which is not related to a specific mod, just to your system permissions in the game folder.

lol well that explains why the mod isn't working! no worries about the mod. haven't actually used it yet. can't seem to get that far lately in the game before I restart. only picked it up recently too. 

 

now if can just figure out why I can't reload a game without all the dupes dying. or they fix it soon.

Share this post


Link to post
Share on other sites
Guinaro    31
Posted (edited)

I also had the permissions issue with the conveyor filter mod. And finally it fixed itself somehow. Either the steam server I was downloading the mod from hadn't synced properly to the new version or the following helped my case.
The following pattern is what fixed it for ME. I hope it helps you too.
I unsubscribed from all mods. Restart at least twice. Check your mods.json file that it is empty between the [ and ], and also make sure your mods/steam folder is empty. For me it was so, but if not remove everything between [ and ] aswell as delete any folder remaining in mods/steam and restart ONI once. Close ONI.

Restart your computer.
I resubbed to 2 mods. The Better Mod Load Logs mod (you probably should try another mod, see warning post of Cairath below this one!!!) and the Conveyor Filter Mod.
Restart ONI twice, without enabling the mods. Then enable first the Better Mod Load logs mod, restart, now enable this mod. If success, you did it already. If not like me. Restart after the crash, now click on the mods button, and then on the manage subscription of the Better Mod Load Logs mod. KEEP THE GAME OPEN! Alt tab to the steam app. Now go to your ONI Mod subscriptions and unsub from the Better Mod Load Logs mod. Alt Tab back into ONI. Now I got a message of Conveyor Filter Mod has been updated. Press Restart button. Now enable the Conveyor Filter Mod and hopefully your problem has been fixed aswell. I resubbed all my 60 other mods and reenabled them all without issues afterwards.

The trick I believe is: keeping ONI running while unsubbing from your mods which forces ONI into different checking behavior/database updating for the remaining subbed mods.

Edited by Guinaro
Added the warning from Cairath for the Better Load Logs mod!

Share this post


Link to post
Share on other sites
Cairath    857

@Guinaro

Better Mod Load Logs<--- this mod should NEVER be used unless you are developing a mod. This is not a mod for players, it overrides loading behavior and I'm sure as hell it is not up to date.

Share this post


Link to post
Share on other sites
Guinaro    31
Posted (edited)

OK, thanks for the warning! I'm not using it in normal game play, but tried it to get better info. Doesn't help much in that regard, except that it did provide me with the error message of the permissions issue. Otherwise I would have had nothing to report except an error.

Which is still the case btw for your decor lights mod. Always crashes upon enabling. And I assume it has to do with steam not syncing all servers hosting the mods properly, and I'm getting an older version somehow.
But Decor Lights is a nice to have mod and not an "essential for me" mod. So I'm going to try out the virusscanner blocking it somehow (doubt it, but still a useful tip), and otherwise wait for you to have your Github page updated, after you finished updating all the mods on the steamworkshop.

Update: Somehow the issue once again solved itself. Subbed while ONI was active. When enabling mod. this time i pressed continue instead of restart. Closed ONI manually. Started ONI, and look and behold. Decor Lights now works too. Even without disabling Anti Virus.

On behalf of myself and my fellow mod using ONI players: Thank you for all the time and effort you put into enhancing this game. It is much appreciated.

Edited by Guinaro
Decor Lights started working too now. Yeah!

Share this post


Link to post
Share on other sites
Cairath    857
Posted (edited)

I have finally finished uploading all mods to steam! (....they were all ready on the release day, but boy, the thumbnail work actually takes time)

Some short summary of what has been improved:

  • Deprecated Water Sieve Dynamic Output -- rest in pieces, my first mod! You've served us well.
  • Deprecated Medicine Threshold, Less Needy Critters
  • Wireless Automation, Ranching Sensors, Algae Grower: customized art assets - recolors. Nothing major but makes them a bit more distinguishable than just reusing the same asset over and over.
  • Fervine Plant and Palmera Tree: modified existing assets to fix missing "place" animation, Fervine now uses its own seed art instead of borrowed from another plant. Palmera actually made it to steam for the first time :p
  • Replaced mod which lowered decor penalty for Heavi-Watt Conductive Watt Wire with one to make its capacity bigger
  • Wounded Go To Med Bed has returned!
  • Actually uploaded Piped Algae Terrarium, Faster Jetpacks, Palmera Tree to steam
  • Flow Splitters are now 4 buildings instead of 2 - more placement options. Removed "temp" from the UI icon
  • Buildable POI Props has new buildings
  • Fixed issue with Steel Ladder not being correctly replaceable with other ladders
  • Ranching Rebalanced is currently being.... rebalanced - not sure what to do with it yet.

My repository's master branch has been updated to the newest update. Since all mods are now distributed via steam I no longer upload compiled dlls on GitHub - people would often not check for updates and complain about fixed issues.

You can find full list of mods with their descriptions and steam links here.

And as usual I'm working on new stuff.. so stay tuned :D

Edited by Cairath
  • Thanks 2

Share this post


Link to post
Share on other sites
Slvrsrfr    72
Posted (edited)

I am going to try and use the map thingy~ [Tool] - Tools Not Included - Automated Map Sharing . I have a habit of flipping through seeds frequently, as I look for specific things. I'd like to help expand the collection.

I think i got 1 uploaded before i caused an error in the mod... sry! :) I break all software, immediately. It's a talent.

Also, is it only making randoms of the terra type? Doesn't seem to change type.

And I broke it again, it didn't spawn a printer or dupes? Does that happen? I think i got 4 to upload, sigh....

Edited by Slvrsrfr

Share this post


Link to post
Share on other sites
Cairath    857

@Slvrsrfr correct, it doesn't spawn dupes 

It randomly chooses asteroid types. There is a big memory leak with world gen so if your game is crashing it might be related to your ram. I will be adding a mod with auto restarting, more about that in TNI's thread :)

Share this post


Link to post
Share on other sites
Guinaro    31

Would it be possible to still for now upload the DLLs/Mods to your Github until Klei fixes the mod issues?
I cannot use the Algae Grower, nor the Buildable Props. Always crashing the game, probably due to being served older files by steam.
Once the issues are over, you could remove the DLLs again.

Thank you for your consideration.

Share this post


Link to post
Share on other sites
Cairath    857
Posted (edited)

Alright. Temporarily I've uploaded everything here: https://static.toolsnotincluded.net/Mods.zip

DO NOT USE OLD MODLOADER. The mod folders should be placed in C:\Users\<user>\Documents\Klei\OxygenNotIncluded\mods\local

 

Please switch to steam versions once the mod manager stops acting up -- I ignore complaints with old mod versions :p

Edited by Cairath

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now