Jump to content

Dangerous space


Recommended Posts

9 minutes ago, Oni Noob said:

My other Rocket is not doing so well, it still in space but other parts decided to come home earlier. 
image.thumb.png.facd8b78659a5072182a611530b8e431.png

On a serious note should I be worried if my rocket return it cant land and be bugged forever?

I am not sure about your definition of "forever". Means that, till the sun burned out, or till you start a fresh game?

Link to comment
Share on other sites

From what I've heard, you cannot reload a save file while a rocket is in space and guarantee there will be no glitches.

The solution is simple: don't save/load/quit while a rocket is in transit. Save before it launches, and don't quit the game until it returns or you'll lose chunks of it.

Link to comment
Share on other sites

1 hour ago, crypticorb said:

From what I've heard, you cannot reload a save file while a rocket is in space and guarantee there will be no glitches.

The solution is simple: don't save/load/quit while a rocket is in transit. Save before it launches, and don't quit the game until it returns or you'll lose chunks of it.

That is kinda hard because of the latest version is so unstable, I always get random game crash

Link to comment
Share on other sites

Quote

That is kinda hard because of the latest version is so unstable, I always get random game crash

The rocket part causes most of the crashes, except to save before launch and save after to be safe you don't have another option until now. Believe me I tried almost everything.

Link to comment
Share on other sites

The normal case:

Had the same problems. I send two expensive Hydrogen Rockets to farm a GAS Planet with two GAS cargo's. After 33 Cycles they came back... U know what coming ? GRRRRRRRRR :D

Annoying case:

I have just another problem. Sometimes, at the bottom of the engine in my silo, they are little debris they cannot be destroyed. The Robo miners works as its best 2x120W unlimited Power drawn..., but the debris seems to be out of neutronium. It isn't. That is really annoying. I must use the Devmode Tool => "Destroy" to remove it. Every time i do it, the rocket on the way came back without the engine. ARGHHH.

Another point is that the ramps of the rockets every time a rocket lands, will be destroyed and u must repairing it. The start works as expected. But in my opinion, the signal should turns red, if the rocket is landed!

Currently, the rocketmodule has 2 signals. An input and an output.

Case:

The rocket is in the silo:

RED signal (No Destination chosen)

If u send the rocket, the signal turns green. That's fine.

So, the rocket came back and what happens ? The rocket change directly the signal to red, but the rocket is still on the way! That's the issue of the current game. They should turn the signal to red, if they are landed and not on the way to land! That's a great issue. In this combination u could easily setup a door opening mechanic, that doesn't blast your bunker doors or the ramps each time.

Link to comment
Share on other sites

1 minute ago, DustFireSky said:

I have just another problem. Sometimes, at the bottom of the engine in my silo, they are little debris they cannot be destroyed. The Robo miners works as its best 2x120W unlimited Power drawn..., but the debris seems to be out of neutronium. It isn't. That is really annoying. I must use the Devmode Tool => "Destroy" to remove it. Every time i do it, the rocket on the way came back without the engine. ARGHHH.

I encountered the same problem, I have no choice but reload my game just to destroy the debris :(

Link to comment
Share on other sites

5 hours ago, DustFireSky said:

I have just another problem. Sometimes, at the bottom of the engine in my silo, they are little debris they cannot be destroyed.

Wpon`t the returning rocket just smash the debris? I just ignore those as they don`t do anything.

5 hours ago, DustFireSky said:

Another point is that the ramps of the rockets every time a rocket lands, will be destroyed and u must repairing it. The start works as expected. But in my opinion, the signal should turns red, if the rocket is landed!

At the moment i do the automation manually. When the rocket is ready i turn it on. It opens the doors and retracts the gantries. When the rocket lands the gantries are retracted so they don`t take damage and more importantly the astronaut doesn`t instantly board the rocket so i can unassign him before he does that.

The signal produced by the rocket is pretty weird. It`s green when the rocket is ready to launch but remains green as long as it has enough fuel for the entire trip. So somewhere in the middle of space the signal turns red. That`s not really helpful in terms of automating the doors or gantries. It should turn red when the rocket launches as it`s literally disconnected.

Link to comment
Share on other sites

1 hour ago, Sasza22 said:

Wpon`t the returning rocket just smash the debris? I just ignore those as they don`t do anything.

The normal debris sure, but i mean special debris, they can't be destroyed...

1 hour ago, Sasza22 said:

The signal produced by the rocket is pretty weird. It`s green when the rocket is ready to launch but remains green as long as it has enough fuel for the entire trip. So somewhere in the middle of space the signal turns red. That`s not really helpful in terms of automating the doors or gantries. It should turn red when the rocket launches as it`s literally disconnected.

The signal turns green if the rocket starts or want to start. If u chose no destination and don't do anything (Rocket is ready), the signal is still red.

All my send rockets sends always a green signal and this turns red, when the rocket lands. I had never the situation, that the rocket turns red on the way to a planet. U had maybe a broken automation wire.  Sometimes the automation wires breaks at the start and that is the reason, why the signal turns red.

The automation part of the rockets need some work. Normally they should noticed these problems by themselves. hmm

 

Link to comment
Share on other sites

1 hour ago, DustFireSky said:

All my send rockets sends always a green signal and this turns red, when the rocket lands. I had never the situation, that the rocket turns red on the way to a planet. U had maybe a broken automation wire.  Sometimes the automation wires breaks at the start and that is the reason, why the signal turns red.

The rocket sends a green signal when it has all the required stuff to launch. Astronaut, exosuit, destination, empty storage. It doesn`t check the fuel but checks if the destination is in range (otherwise it`s unselctable). Now when you launch the rocket it remains green but along the way it burns fuel. When the fuel runs low enough so that it couldn`t be launched if it was on the ground the destination becomes unselected and the signal turns red (while it`s in space). I had this happen consistently. I`m not sure if the latest patches changed something about it. Was happening mostly to my steam rockets.

Link to comment
Share on other sites

I'd like to add to this phenomenon that if you complete the checklist in the command module and then save your game, from that point onward that launch will cause a crash upon landing. At least that's how it works with my save. So I save my game before fueling the rocket to make sure I don't save it with a complete checklist.

Also, a scheme for automation I use is to hook the gantries up through a not-gate and a filter gate that delays the deployment of the gantries until the rocket has touched down. In my game the signal turns green when the checklist is complete and stays green until the rocket comes in for a landing.

Link to comment
Share on other sites

When I was preparing my rocketry debug test, I save the game with all rockets loaded and ready. However when I loaded it next day, all rockets, but those with 2700 Kg LOX inside, started filling it again like if they not recieved any. Even more, I had to manually click on all 20 LOX tanks and only then it deopped bottle and started actually adding the LOX to internal storage.

Also from the checklist disappeared "Astronaut" entry and I had to reasign them again.

Link to comment
Share on other sites

On 10/30/2018 at 11:51 AM, Sasza22 said:

The signal produced by the rocket is pretty weird. It`s green when the rocket is ready to launch but remains green as long as it has enough fuel for the entire trip. So somewhere in the middle of space the signal turns red. That`s not really helpful in terms of automating the doors or gantries. It should turn red when the rocket launches as it`s literally disconnected.

I use this "bug" to solve the problem with bunker doors automation. I've written it in another thread.

If you use a NOT gate, the bunker doors start opening when the rocket is almost done with its trip. When it starts landing the doors start to close, but since they're slow as hell, the rocket manages to land with no issues.

Actually it's the best bet to avoid using the water clock (which needs a manual check for the season anyway).

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...