Jump to content

Cargo rocket launches causes very low framerate (until game is restarted)


Recommended Posts

Any time I launch a rocket with cargo modules, my game drops from 20-30 fps to about 5 fps, and stays like that long after the rocket is gone. I have to reload the game for playable performance.

At least I think it's related to cargo modules. I've launched research-only rockets, and it didn't seem to have such an effect on performance.

Anything I can do to fix this? What could be causing the slowdown?

Link to comment
Share on other sites

For me, all rockets negatively affect my FPS. It is actually most noticeable with steam research rockets. It would take off and my FPS would plummet and the game would stutter like crazy until I reloaded. I think the heat transfer calculation is also affecting the performance of the game in general; it doesn't run nearly as well as it did during QoL Mk3. 

Link to comment
Share on other sites

11 hours ago, selereth said:

it doesn't run nearly as well as it did during QoL Mk3.

They didn't mention any changes to the heat calculations from OoL Mk3 to LU. However, they did change the gas computation (especially when gasses interact with vacuum), and EVERY rocket launch deals with vacuum tiles and gas. 

I wonder if the matter conversion "fix" is to blame.

Link to comment
Share on other sites

2 minutes ago, mathmanican said:

They didn't mention any changes to the heat calculations from OoL Mk3 to LU. However, they did change the gas computation (especially when gasses interact with vacuum), and EVERY rocket launch deals with vacuum tiles and gas. 

I wonder if the matter conversion "fix" is to blame.

That's definitely a possibility, however, opening the temperature overlay drops FPS by about 10 frames or so. I don't think this was the case before launch and the beta, although my memory fails to recall how the temp overlay performed beforehand. Why would the temp overlay be so taxing on frames? All it's doing is painting the map with the various colours of each temp range?

Link to comment
Share on other sites

2 minutes ago, selereth said:

opening the temperature overlay drops FPS by about 10 frames or so.

Do any of the other overlays do this, or just temp? A month ago, lots of people commented on frame rates dropping drastically when any menu/overlay/whatever is open. 

Link to comment
Share on other sites

1 minute ago, mathmanican said:

Do any of the other overlays do this, or just temp? A month ago, lots of people commented on frame rates dropping drastically when any menu/overlay/whatever is open. 

Looks like the materials overlay has a similar negative effect on performance. Still, the lag caused by opening menus was supposedly fixed in a patch during the beta. Either way, could be related. If I only I could check the date for the patch that fixed the matter conversion bug, as I don't know if I launched a rocket beforehand and therefore don't know if the performance issues do indeed stem from the issue you describe. They don't seem to have logged that patch in the dev tracker. 

Link to comment
Share on other sites

I got the rocket performance issue happening to me as well.

After trying a variety of things, I found that it comes down to messing with automation on the Command Capsule that causes the performance issues.  When I removed all automation connections from them, both launch and return don't seem to cause any kind of permanent, game-restart-needing performance impact.

Let me know if anyone gets similar results.

Link to comment
Share on other sites

6 hours ago, mathmanican said:

Do any of the other overlays do this, or just temp? A month ago, lots of people commented on frame rates dropping drastically when any menu/overlay/whatever is open. 

Yes. Any storage locker / item / overview has big negative impact on FPS, when whatever is open.

Link to comment
Share on other sites

5 hours ago, Oozinator said:

Yes. Any storage locker / item / overview has big negative impact on FPS, when whatever is open.

That's been the case for as long as I can remember though, I don't know if the issue you're describing is necessarily related to the rocket issue, although it is no doubt another problem that falls under the umbrella of performance. 

Link to comment
Share on other sites

25 minutes ago, TLW said:

One other question: how large of an exhaust plume tunnel are you using? And is it Dewar-insulated? Normal insulated? Or just normal tiles?

I have noticed I get less lag when using a hydrogen rocket vs a petroleum rocket.

Link to comment
Share on other sites

3 hours ago, selereth said:

That's been the case for as long as I can remember though, I don't know if the issue you're describing is necessarily related to the rocket issue, although it is no doubt another problem that falls under the umbrella of performance. 

Mhh i have that since release. before that, i had it with food storages only.

Link to comment
Share on other sites

9 hours ago, Oozinator said:

Yes. Any storage locker / item / overview has big negative impact on FPS, when whatever is open.

Might be an early-game thing, but these overlays have a drop of about 10 FPS, whereas before the patch they'd drop my FPS from 55-60 down to 20 or less, so that at least has gotten loads better (but dunno if it gets worse towards late game again? Or are you just talking about the 10FPS drop?)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...