V2C

Dedicated Server Quick Setup Guide - Windows

Recommended Posts

tsuna87    9
15 hours ago, vosdbk said:

Which place can i put "steam_group_id"?

For what I could figure out, you place that in the cluster.ini :

[STEAM]
steam_group_id = ID
steam_group_only = true

 

  • Like 1

Share this post


Link to post
Share on other sites
n0xxx    1
8 hours ago, Xaviien said:

I have mine installed on another partition as well.

Since we've both done the same thing differently, it would be safe to assume that this is the reason we are having the same issue.

The instructions in the OP should be updated, since the instructions in the linked page for installing steamcmd only give an example of where you CAN install, but we're expected to install it there no matter what.

Someone please help us with this problem...

 

I've tried copying and pasting ALL OF THE FILES (including dontstarve_dedicated_server_nullrenderer.exe) from

D:\Program Files\Steam\steamapps\common\Don't Starve Together Dedicated Server\bin

into

C:\Users\User\Documents\Klei (where the .bat file seems to be looking for that program)

and it seems to work, but only up to a point, it starts up both servers (master and cave, im assuming) but then quickly closes them both as quickly as it starts up. I've also tried editing the .bat file into the following, with the exact same results. PLEASE HELP!

edit1.png

edit2.png

Share this post


Link to post
Share on other sites

I have been fighting with this mess for hours , and I can not get my cluster_token.txt to be recognized

[200] Account Failed (6): "E_INVALID_TOKEN"
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!! Your Server Will Not Start !!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
No auth token could be found.


I have the token where this guide said , as well an in the server folder and I got nothing working .    I am frankly sick of trying to fight with it, am rather pissed off about how this all was done.

Share this post


Link to post
Share on other sites
Crysos    1

I'e had the same problem as you, move the steam and steamcmd folders into your c: drive, for some reason it resolved my problem ( change back your .bat file into what it was supposed to be at first )

 

Btw anyone can give me a quick screen of your modoverrite.lua files in both caves/master ? ( as well as showing me how it's organised in the folders ) because i'm totaly lost on how to start adding every of the mods i want into the server ! (got everything else solved so far, just need that to finaly be able to play ^^)

Share this post


Link to post
Share on other sites
n0xxx    1
3 minutes ago, Crysos said:

I'e had the same problem as you, move the steam and steamcmd folders into your c: drive, for some reason it resolved my problem ( change back your .bat file into what it was supposed to be at first )

are you talking to me? if so, you moved your whole Steam folder into C:? i have a bunch of games installed on steam... does that mean the rest of them will be messed up? Or do i have to uninstall everything, and reinstall into C:? That seems like a heck of a lot of trouble, there's gotta be an easier way....

 

7 minutes ago, KittenCanaveral said:

I have been fighting with this mess for hours , and I can not get my cluster_token.txt to be recognized

[200] Account Failed (6): "E_INVALID_TOKEN"
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!! Your Server Will Not Start !!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
No auth token could be found.


I have the token where this guide said , as well an in the server folder and I got nothing working .    I am frankly sick of trying to fight with it, am rather pissed off about how this all was done.

Kitten, did you open the server from the .bat file? (i.e. doubleclicking the .bat file), i get that same error when i try to open mine via the Steam tools for the dedicated server.

Share this post


Link to post
Share on other sites
SrJardel    146

I don't understand anything, am I still able to launch the Pre-Configured server?

I tried and its not working, I just wanted to know if should I wait or something, or if I need to follow this guide in order to run a dedicated server to play on my local LAN.

Share this post


Link to post
Share on other sites
by4udilo    0

Try it

1.run client (GAME)

2.Create world,with all settings,where you create character exit game

3.Open ***\Documents\Klei\DoNotStarveTogether\Cluster_1 ,copy all files in ***\Documents\Klei\DoNotStarveTogether\MyDediServer

4.Open server folder with .exe and create .bat file with:

start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Master
start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Caves

Try run

PS Sory for errors, I edit it =)

Edited by by4udilo

Share this post


Link to post
Share on other sites
Crysos    1
22 minutes ago, n0xxx said:

Someone please help us with this problem...

 

I've tried copying and pasting ALL OF THE FILES (including dontstarve_dedicated_server_nullrenderer.exe) from

D:\Program Files\Steam\steamapps\common\Don't Starve Together Dedicated Server\bin

into

C:\Users\User\Documents\Klei (where the .bat file seems to be looking for that program)

and it seems to work, but only up to a point, it starts up both servers (master and cave, im assuming) but then quickly closes them both as quickly as it starts up. I've also tried editing the .bat file into the following, with the exact same results. PLEASE HELP!

edit1.png

edit2.png



I don't think it will be a problem for your other game ( try moving them then starting any game just to check it, if there's a problem, just reverse it and wait someone to solve this problem with another method o= ! )

My own problem still persists tho : I tried copying/pasting my mod folder from the original steam folder to the steamcmd one, and copying the modoverwrite from a random server on my cluster 1, but when i try launching the server, it loads the mods and then the cmd window closes itself ... I'm kinda lost now ...

Edited by Crysos

Share this post


Link to post
Share on other sites
n0xxx    1
2 minutes ago, Crysos said:



I don't think it will be a problem for your other game ( try moving them then starting any game just to check it, if there's a problem, just reverse it and wait someone to solve this problem with another method o= ! )

Well if I move my Steam folder into C: all of the games installed will be moved since it's inside that folder. Not to mention, i only have 40GB left on C: and my Steam folder is 85GB.... soooo yeah

Share this post


Link to post
Share on other sites
Crysos    1
3 minutes ago, n0xxx said:

Well if I move my Steam folder into C: all of the games installed will be moved since it's inside that folder. Not to mention, i only have 40GB left on C: and my Steam folder is 85GB.... soooo yeah

hmmm ... I don't know then ... I tried changing the bat file myself without being able to make it work so ... sorry but i don't know how to to it ... I'd still love if you were to find a way !

EDIT : Maybe just moving steamcmd would make it work ( just change the path in the .bat file ... ) ?

Edited by Crysos

Share this post


Link to post
Share on other sites
by4udilo    0

start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Master -tick 60
start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Caves -tick 60

This will be work?

Share this post


Link to post
Share on other sites
MrSpock78    1
7 minutes ago, by4udilo said:

start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Master -tick 60
start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Caves -tick 60

This will be work?

Put the following in your cluster.ini under

[NETWORK]

tick_rate = 60

 

also I found out... there you can put in if you want to host a LAN Server

[NETWORK]

lan_only_cluster = true

offline_server = false

 

Share this post


Link to post
Share on other sites
haywardGB    9

Maybe someone can get it working with this guide for linux: 

I tried it, but I get an error telling no valid token was found. No matter where I put the cluster_token.txt file..

This is not looking good for my weekend lol

Share this post


Link to post
Share on other sites
24 minutes ago, n0xxx said:

 

 

Kitten, did you open the server from the .bat file? (i.e. doubleclicking the .bat file), i get that same error when i try to open mine via the Steam tools for the dedicated server.

I am running this in the shell in Red Hat , nothing to double click, I modified the start.sh , as a best guess due to there being nothing for linux this morning.

Share this post


Link to post
Share on other sites
MrSpock78    1
8 minutes ago, haywardGB said:

Maybe someone can get it working with this guide for linux: 

I tried it, but I get an error telling no valid token was found. No matter where I put the cluster_token.txt file..

This is not looking good for my weekend lol

Try to get a new token ingame.

Then put it into \documents\klei\DoNotStarveTogether\YOURSERVERNAME\cluster_token.txt

 

Edit: Sorry, haven´t seen that this is for Linux, but maybe this helps? Had same problem under windows with "old" token.

Edited by MrSpock78
Linux

Share this post


Link to post
Share on other sites
10 minutes ago, MrSpock78 said:

Try to get a new token ingame.

Then put it into \documents\klei\DoNotStarveTogether\YOURSERVERNAME\cluster_token.txt

 

Edit: Sorry, haven´t seen that this is for Linux, but maybe this helps? Had same problem under windows with "old" token.

with the changes the old guide is not going to help sadly. I and a few other bashed at it most of the day. trying to get our server back up.

Share this post


Link to post
Share on other sites
SrJardel    146

Ok, I got it running without any problems, installing mods right now.

Can someone confirm that "lan_only_server = true" is still valid, or it changed to "lan_only_cluster = true"?

Share this post


Link to post
Share on other sites
by4udilo    0
13 minutes ago, MrSpock78 said:
13 minutes ago, MrSpock78 said:

Put the following in your cluster.ini under

[NETWORK]

tick_rate = 60

 

also I found out... there you can put in if you want to host a LAN Server

[NETWORK]

lan_only_cluster = true

offline_server = false

 

Thx

Share this post


Link to post
Share on other sites
haywardGB    9
14 minutes ago, MrSpock78 said:

Try to get a new token ingame.

Then put it into \documents\klei\DoNotStarveTogether\YOURSERVERNAME\cluster_token.txt

 

Edit: Sorry, haven´t seen that this is for Linux, but maybe this helps? Had same problem under windows with "old" token.

Yea, tried that directory and the others. The creator of the tutorial said he's updating it soon.

Soon :D

Share this post


Link to post
Share on other sites
SrJardel    146

Realized this, I believe it is the caves one which refuses to run, but I'm not really sure:

 

Spoiler

[00:00:33]: [Warning] Could not confirm port 10999 is open in the firewall.
[00:00:33]: Shard server mode disabled: missing is_master setting.
[00:00:33]: [Shard] Missing 'is_master' config field.
[00:00:33]: [Error] Server failed to start!
[00:00:33]: Unhandled exception during server startup: RakNet UDP startup failed: SOCKET_PORT_ALREADY_IN_USE (5)
[00:00:33]: PushNetworkDisconnectEvent With Reason: "ID_DST_INITIALIZATION_FAILED", reset: false
[00:00:33]: Details: SOCKET_PORT_ALREADY_IN_USE

 

Also, can I skip this part of the bat file? I can, just figured it out. Still stuck in the issue above tho.

c:\steamcmd\steamcmd.exe +login anonymous +app_update 343050 validate +quit

EDIT: It seems to be working now, but I'm not sure about all those (inactive) and (disabled) lines. What they mean?

Spoiler

[00:00:31]: [Steam] SteamGameServer_Init success
[00:00:32]: Validating portal[1] <-> <nil>[1] (inactive)
[00:00:32]: Validating portal[2] <-> <nil>[2] (inactive)
[00:00:32]: Validating portal[3] <-> <nil>[3] (inactive)
[00:00:32]: Validating portal[4] <-> <nil>[4] (inactive)
[00:00:32]: Validating portal[5] <-> <nil>[5] (inactive)
[00:00:32]: Validating portal[6] <-> <nil>[6] (inactive)
[00:00:32]: Validating portal[7] <-> <nil>[7] (inactive)
[00:00:32]: Validating portal[8] <-> <nil>[8] (inactive)
[00:00:32]: Validating portal[9] <-> <nil>[9] (inactive)
[00:00:32]: Validating portal[10] <-> <nil>[10] (inactive)
[00:00:32]: Sim paused
[00:00:33]: [Shard] Slave Caves(2549893577) connected: [LAN] 127.0.0.1
[00:00:34]: [Shard] Slave Caves(2549893577) ready!
[00:00:34]: World 2549893577 is now connected
[00:00:34]: Validating portal[1] <-> 2549893577[1] (disabled)
[00:00:34]: Validating portal[2] <-> 2549893577[2] (disabled)
[00:00:34]: Validating portal[3] <-> 2549893577[3] (disabled)
[00:00:34]: Validating portal[4] <-> 2549893577[4] (disabled)
[00:00:34]: Validating portal[5] <-> 2549893577[5] (disabled)
[00:00:34]: Validating portal[6] <-> 2549893577[6] (disabled)
[00:00:34]: Validating portal[7] <-> 2549893577[7] (disabled)
[00:00:34]: Validating portal[8] <-> 2549893577[8] (disabled)

 

Edited by SrJardel
Forgot to insert relevant content.

Share this post


Link to post
Share on other sites
ToNiO55    296
14 hours ago, ToNiO55 said:

Hi @V2C

i have just one problem

it's still possible to custom steam ports?

because before this update it's works, but now it's doesn't works

server.ini of Master:


authentication_port = 12367
master_server_port = 12368

server.ini of Caves:


authentication_port = 12369
master_server_port = 12370

log of Master:

  Reveal hidden contents


[Steam] SteamGameServer_Init(8766, 20067, 27016)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20067, 27017)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20067, 27018)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20067, 27019)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20067, 27020)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20067, 27021)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20067, 27022)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20067, 27023)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20067, 27024)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20067, 27025)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Warning] SteamGameServer_Init failed
Your server will still start, but some Steam functionality may be missing.
Steam ports can be configured through command line by adding:
-steam_authentication_port 12345 -steam_master_server_port 12346
or through settings.ini, under the [network] heading
steam_authentication_port = 12345
steam_master_server_port  = 12346

 

log of Cave:

  Reveal hidden contents


[Steam] SteamGameServer_Init(8766, 20068, 27016)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20068, 27017)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20068, 27018)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20068, 27019)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20068, 27020)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20068, 27021)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20068, 27022)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20068, 27023)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20068, 27024)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Steam] SteamGameServer_Init(8766, 20068, 27025)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
[Warning] SteamGameServer_Init failed
Your server will still start, but some Steam functionality may be missing.
Steam ports can be configured through command line by adding:
-steam_authentication_port 12345 -steam_master_server_port 12346
or through settings.ini, under the [network] heading
steam_authentication_port = 12345
steam_master_server_port  = 12346

 

 

guys if you have same problem like me

you need to put steamclient.so here: /home/user/server/bin/lib32/

and your steam port going works again

you can find steamclient.so here: /home/user/server/bin/lib32

thx you very much @Diabu for this tips ;)

of course i think it's going fixed next update, but if you don't want wait, use this tips :)

Edited by ToNiO55
  • Like 1

Share this post


Link to post
Share on other sites
killer7777    0
20 hours ago, V2C said:
20 hours ago, V2C said:

13. Double-click StartDSTServers.bat to start your dedicated servers!

When i click it, it does nothing

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now