Jump to content

Lag when i enable caves in a game...


Recommended Posts

Hi, anybody knows why caves give me about 0,5 seconds of lag in every action ?

this is my computer:

i7 10700k

16GB ram 

2070 RTX SUPER

MSI Z490-A PRO (MS-7C75)

it doesnt let me play this game and it´s driving me crazy...

thank u.

Link to comment
Share on other sites

1 hour ago, ivn said:

Hi, anybody knows why caves give me about 0,5 seconds of lag in every action ?

this is my computer:

i7 10700k

16GB ram 

2070 RTX SUPER

MSI Z490-A PRO (MS-7C75)

it doesnt let me play this game and it´s driving me crazy...

thank u.

Heya, do you have "Movement Prediction" enabled in your settings?

also nice computer :p

Link to comment
Share on other sites

Game's networking model is a full server-enforced on.  When you host without caves your client and server are the same so no networking happens.  Once caverns are on, then it's a full client-server relationship and you'll feel the effects of the added latency.

Link to comment
Share on other sites

1 hour ago, Hornete said:

Heya, do you have "Movement Prediction" enabled in your settings?

also nice computer :p

No im not, do u have this lag too?

32 minutes ago, CarlZalph said:

Game's networking model is a full server-enforced on.  When you host without caves your client and server are the same so no networking happens.  Once caverns are on, then it's a full client-server relationship and you'll feel the effects of the added latency.

So , there is no way to "fix" it? do u have that delay betwen action-response?

Link to comment
Share on other sites

1 hour ago, ivn said:

No im not, do u have this lag too?

So , there is no way to "fix" it? do u have that delay betwen action-response?

No, it is a quirk of the engine.

No matter your settings or your computer specs, the delay will be there.

To avoid the "lag" you must disable caves, I'm afraid there is no other option.

Link to comment
Share on other sites

Which connection do you have?

Are you playing alone? There is a local option

Your specs are more than enough but maybe your connection is slow or has high ping or maybe some mods are messing with it

I dont have a gaming computer but i have good connection. In local only i have 0 ping and when i play with friends i have arround 10 to 30 ms, you seems to have arround 500 which i guess is because a problem with the net, the ports, the firewall or something else

Link to comment
Share on other sites

38 minutes ago, ArubaroBeefalo said:

Which connection do you have?

Are you playing alone? There is a local option

Your specs are more than enough but maybe your connection is slow or has high ping or maybe some mods are messing with it

I dont have a gaming computer but i have good connection. In local only i have 0 ping and when i play with friends i have arround 10 to 30 ms, you seems to have arround 500 which i guess is because a problem with the net, the ports, the firewall or something else

I hv 500Mb of fiber, im playing alone without mods, how can i make a local game?, i tried a local game, but lagg was still there...

wich port may i have to open?

Link to comment
Share on other sites

6 hours ago, ivn said:

I hv 500Mb of fiber, im playing alone without mods, how can i make a local game?, i tried a local game, but lagg was still there...

wich port may i have to open?

With that connection you shouldnt have 500ms. I have fiber and got 30ms when worst

Is this happening with other games?

Yo make a local world just choose the local option in the 1st tab when creating a new world but anyways, you should be able to host online worlds without problems

I dont have much knowledge about this things but you cpuld check if dst is added to the firewall exceptions

Link to comment
Share on other sites

On 2/3/2021 at 12:11 PM, ArubaroBeefalo said:

Yo make a local world just choose the local option in the 1st tab when creating a new world but anyways, you should be able to host online worlds without problems

 

I should, but i have lag... hope someone of Klei could read this and say anything about the problem...

Link to comment
Share on other sites

4 hours ago, ArubaroBeefalo said:

he is having a problem with the game or their network

stop making people believe this is normal

the game does have noticeable delay when you move and do stuff which can't be removed when in caves world (unless you turn on lag compensation) unlike world with no caves

so it is normal bro lol

Link to comment
Share on other sites

5 hours ago, oCrapaCreeper said:

The delay you get in solo play from adding caves is very normal.

 

6 hours ago, --- -.- said:

the game does have noticeable delay when you move and do stuff which can't be removed when in caves world (unless you turn on lag compensation) unlike world with no caves

so it is normal bro lol

Having 0<ping is normal like in every game, what isnt normal is to have 500 like this guy has when he has a good computer and good connection

As i said i have less network speed and a less powerful computer and the higher ping i got is 30 with caves enable and multiple people playing

Link to comment
Share on other sites

34 minutes ago, ArubaroBeefalo said:

snip

I have lagg too, but most noticable is during fights (and I'm talking when I host game - I should have no lagg... guess?). Kind of I get used to that but still I remember how easier for me were fights in DS compared to DST. 

Link to comment
Share on other sites

15 minutes ago, Notecja said:

I have lagg too, but most noticable is during fights (and I'm talking when I host game - I should have no lagg... guess?). Kind of I get used to that but still I remember how easier for me were fights in DS compared to DST. 

Do you host games with other people or alone? With other people is normal to have littlee lag with fiber and some with adsl but nothing that affects the experience and playing alone should be like playing DS

Link to comment
Share on other sites

17 minutes ago, Well-met said:

but it is normal functionality.

do you think somebody like CarlZalph would just spew bs?

Is 500ms normal functionality?

I never experience that much without any external problem even when i had slow adsl and a bad computer. Maybe is a common problem but shouldnt be normal and is better to try to help people instead of just saying "is normal, deal with it" just because is salty because the game isnt build in 64 bits (not Carl, the other user). 

Having latency when caves are on doesnt mean you should have 0,5 secs of latency. If that would be always the case the game would be unplayable. As i said, i always play with <50 latency even with 4 players in the server. Playing alone makes me play with 0ms. When i played with 20mb of adsl connection i had <100ms. Having 500ms (if op isnt exagerating) is a problem, idk if a game, network or computer problem 

 

Link to comment
Share on other sites

On 2/3/2021 at 2:48 AM, CarlZalph said:

Game's networking model is a full server-enforced on.  When you host without caves your client and server are the same so no networking happens.  Once caverns are on, then it's a full client-server relationship and you'll feel the effects of the added latency.

anyways...even being a client server relationship, they r all in LAN when u play alone in your server... so latency should be 0 or practically 0

Link to comment
Share on other sites

2 hours ago, ArubaroBeefalo said:

Do you host games with other people or alone? With other people is normal to have littlee lag with fiber and some with adsl but nothing that affects the experience and playing alone should be like playing DS

No matter which one I got this lagg. No difference.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...