Recommended Posts

Nightinggale    967

The problem is that No Fixed Temperatures replaces the array, which Piped Output alters. If Piped Output is loaded last, it should modify the data inserted by No Fixed Temperatures. Load Piped Output first and whatever it writes will be discarded by No Fixed Temperatures.

Share this post


Link to post
Share on other sites
Guinaro    31

Yes that was indeed the trick.
Moved Piped Output to last position in my mod list for now.
Thanks for the quick replies.

Share this post


Link to post
Share on other sites
Cairath    856
Posted (edited)

@Guinaro The recent patches got rid of most of fixed temperatures anyway, are you sure that mod is still required?

Edited by Cairath

Share this post


Link to post
Share on other sites
Nightinggale    967
6 minutes ago, Cairath said:

@Guinaro The recent patches got rid of most of fixed temperatures anyway, are you sure that mod is still required?

That's another thing I was wondering about, but I didn't mention it because it might still be useful. It looks like it sets all minimum temperatures to 0 K, meaning it won't heat up the output from various buildings. I will however write a bug report on the mod because not only does it cause potential mod conflicts, it also appears to have a bool flipped, meaning now instead of outputting the input temperature, it outputs the building temperature. That's likely not what it intended.

Share this post


Link to post
Share on other sites
Cairath    856
Just now, Nightinggale said:

That's another thing I was wondering about, but I didn't mention it because it might still be useful. It looks like it sets all minimum temperatures to 0 K, meaning it won't heat up the output from various buildings. I will however write a bug report on the mod because not only does it cause potential mod conflicts, it also appears to have a bool flipped, meaning now instead of outputting the input temperature, it outputs the building temperature. That's likely not what it intended.

I don't think Trevice plays anymore, so he probably doesn't even realize there were changes

Share this post


Link to post
Share on other sites
Nightinggale    967
Just now, Cairath said:

I don't think Trevice plays anymore, so he probably doesn't even realize there were changes

Good point. I will however still write what is causing the mod conflict and how to avoid it. It could be a useful template for other modders to follow.

  • Like 1

Share this post


Link to post
Share on other sites
trevice    119
Posted (edited)

Yeah, that's one of my first mod :?. Sorry. I was aware that it could cause conflicts, and planned to do a better job, but, you know... life... Also, as pointed, I didn't realize there were changes. I'll try to fix it asap or even delete the mod, thanks for the tips in the wiki.

Edited by trevice
  • Like 1

Share this post


Link to post
Share on other sites
Nightinggale    967

Released Piped Output 1.2. This fixes a problem with the natural gas generator where the vanilla ConduitDispenser could wake up and output CO2 in the input pipe, which the input will then take in and cause wrong element damage.

Share this post


Link to post
Share on other sites
Mantak    39

Thanks for Piped output & Sensory overload mods, they are really good!

Share this post


Link to post
Share on other sites
Guinaro    31

@Nightinggale Could you have a look at the building temperature sensor from your Sensory Overload mod?
It seems no to toggle the signal upon crossing treshold values.
It only toggle when manually setting different treshold values.

Thank you.

Share this post


Link to post
Share on other sites
Lookwow    0

Anyone else have issues with the Electrolyzer outputting super hot o2? Im inputting 42F water and the O2 out to the pipe is 152F. I tried disabling all other mods and its still the same

Share this post


Link to post
Share on other sites
Cairath    856
2 hours ago, Lookwow said:

Anyone else have issues with the Electrolyzer outputting super hot o2? Im inputting 42F water and the O2 out to the pipe is 152F. I tried disabling all other mods and its still the same

That's how the game works.

70ca9b028f.png

Share this post


Link to post
Share on other sites
snoozer    111
Posted (edited)

The Conveyer Rail Element Sensor seems to have no element list. Or do I miss something?

Spoiler

20190825004734_1.thumb.jpg.9ecef88440c07c596f9c5cfc1f608b34.jpg

 

Edited by snoozer

Share this post


Link to post
Share on other sites
Nightinggale    967

I updated Piped Output to disable gas range and rust deoxidzer because they have issues. They might come back someday, but for the time being not adding output to those is better than conflicting with other building components in those two buildings.

I posted a bug report regarding the crashes on mac and linux.

 

On 8/16/2019 at 2:37 PM, WardenCommander said:

Hello @Nightinggale could you make that machines in your PipedOutput mod connect to lets say cooling loop?

I'm not entirely sure what you want me to do.

14 hours ago, snoozer said:

The Conveyer Rail Element Sensor seems to have no element list. Or do I miss something?

  Reveal hidden contents

20190825004734_1.thumb.jpg.9ecef88440c07c596f9c5cfc1f608b34.jpg

 

Great. Another mod, which decided to break itself :mad:

Share this post


Link to post
Share on other sites
Posted (edited)

@Nightinggale

I was thinking that you cold add cooling input/output similar to Metal Refinery, so that heat is dumped into a coolant liquid.

It could be separate mod, like new research, where new upgraded buildings are added.. or you could include in your PipedOutput mod, your decision.

Would be usefull to have this option for all heat producing building, or at least for most :D

 

Some other ideas:

and if possible for a Gas/Liquid Reservoir, then you could cool/heat air liquid.

Also, could you add water input for Super Computer, so that dups dont need to carry water

And Pitcher Pump that could connect to a water pipe :D

Pretty Please

Pitcher Pump

Edited by WardenCommander

Share this post


Link to post
Share on other sites
snoozer    111

The Conveyer Rail Temperature Sensor seems to have have a problem with empty conveyer rail boxes. The game  throws a "Error Occured. Please restart the game" message and pauses the game.

A bridge in front of the sensor kinda fixes this since it removes empty boxes.

Output_log:

Spoiler

[15:00:31.489] [1] [INFO] Error occurred with mods active. Disabling all mods (unless dev mods active).
NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Component:GetComponentFastPath (System.Type,intptr)
  at UnityEngine.Component.GetComponent[PrimaryElement] () [0x00000] in <filename unknown>:0
  at MoreTemperatureSensors.SolidConduitTemperatureSensor.ConduitUpdate (Single dt) [0x00000] in <filename unknown>:0
  at SolidConduitFlow.Sim200ms (Single dt) [0x00000] in <filename unknown>:0
  at Game.StepTheSim (Single dt) [0x00000] in <filename unknown>:0
  at Game.UnsafeSim200ms (Single dt) [0x00000] in <filename unknown>:0
  at Game.SimEveryTick (Single dt) [0x00000] in <filename unknown>:0
  at Game.Update () [0x00000] in <filename unknown>:0
 
(Filename:  Line: -1)

Screenshot

Spoiler

20190826174106_1.thumb.jpg.eae6eac238febbf183c1b1b63aca9513.jpg

 

Share this post


Link to post
Share on other sites
scitor    0

@Nightinggale

Hey, an awesome mod collection you have there :)

Could I point your attention to the github repository, where there's a certain PR waiting to introduce even more awesomeness into the pack ;) (if you so wish ofc)

Thanks for your work anyway, enjoying many of your mods

Share this post


Link to post
Share on other sites
Nightinggale    967
22 minutes ago, scitor said:

Could I point your attention to the github repository, where there's a certain PR waiting to introduce even more awesomeness into the pack ;) (if you so wish ofc)

I know. I took a brief look and it looks ok. Right now it's waiting for me to have enough time and focus to review it properly. I do plan to do so in the near future.

  • Like 1

Share this post


Link to post
Share on other sites
Nightinggale    967

Updated HalfDoor with @scitor's pull request. It now adds a half version of all 3 types of doors.

Also I added my own addition: a log writer. It now writes the mod and mod version to the output log. This will tell if (once again) some future issue is due to steam not updating correctly.

Share this post


Link to post
Share on other sites
Jespercal    3

@Nightinggale

I was wondering, what type of filter list was the rail element sensor suppose to use? The single choice, like the vanilla filters or the multiple-choice, like storage containers?

Edit:

I just went with the storage bin filter and got it working.

Edited by Jespercal

Share this post


Link to post
Share on other sites

I was just feeling annoyed by the inability to do precisely what pressure valve will allow me to do. I love you for this. And now I have also discovered your automation mod which gave me other things I've been wanting. You're my absolute favorite.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now