Jump to content

[Game Update] - 456020


Recommended Posts

  • Developer

Changes

  • Lord of The Fruit Flies world setting can now be changed in the caves. 

Bug Fixes

  • Fixed a bug causing some mod assets to fail to load.
  • Fixed a bug causing the timers for Ancient Gateway, Antlion Rage, Dragonfly, Grass Gekko Morphing, and Salt Formation Regrowth to reset upon restarting the game.
  • Fixed Lord of The Fruit Flies never spawning.
  • Fixed a bug causing mod configuration overrides from mod overrides to get applied after every single mod info is loaded, instead of just once after all modinfo’s have been loaded.
  • Added logging for when a steam workshop mod fails to download.
  • Added logging for dedicated servers when downloading mods.
  • Fixed a crash on mac and linux when the path length for workshop mods was greater than 256 characters.
  • Fixed the mods downloading notification not going away when mods finished downloading.
  • Fixed a bug causing pigs to respawn immediately upon restarting the game.
     

View full update

  • Like 14
  • Thanks 5
  • GL Happy 2
Link to comment
Share on other sites

Quote

Fixed a bug causing some mod assets to fail to load.

Nice, had to split assets to a different workshop upload recently and it was causing crashes.

 

Is there still a 100mb limit on mod uploads though? I've been getting conflicting info on that point, if anyone happens to know I'd appreciate it.

  • Thanks 2
Link to comment
Share on other sites

48 minutes ago, zarklord_klei said:

 

Bug Fixes

  • Fixed a bug causing some mod assets to fail to load.

 

Where are the mod assets downloaded to/from now?

Quote
  • Added logging for when a steam workshop mod fails to download.
  • Added logging for dedicated servers when downloading mods.

Where are the log files output to? I checked server_log.txt and didn't find much info.

I updated my server & client, but I don't see where the mod files are downloaded. I have read the post about how files should be downloaded to data/steamapps/workshop/content/322330/WORKSHOPID, but don't see anything there.

Do we still have to configure the following to download and set up mods? Or have the set up steps changed?

Change

/mods/dedicated_server_mods_setup.lua

to use

ServerModSetup("WORKSHOP-ID")

and enable mod settings by updating

/mods/modsettings.lua

to use

ForceEnableMod("workshop-WORKSHOP-ID")

Asking bc mod files don't seem to download to that location anymore. Any help is appreciated! We have an eager bunch of folks excited to play again!

Edited by sdfe07
Link to comment
Share on other sites

41 minutes ago, zarklord_klei said:

Changes

  • Lord of The Fruit Flies world setting can now be changed in the caves. 

Bug Fixes

  • Fixed a bug causing some mod assets to fail to load.
  • Fixed a bug causing the timers for Ancient Gateway, Antlion Rage, Dragonfly, Grass Gekko Morphing, and Salt Formation Regrowth to reset upon restarting the game.
  • Fixed Lord of The Fruit Flies never spawning.
  • Fixed a bug causing mod configuration overrides from mod overrides to get applied after every single mod info is loaded, instead of just once after all modinfo’s have been loaded.
  • Added logging for when a steam workshop mod fails to download.
  • Added logging for dedicated servers when downloading mods.
  • Fixed a crash on mac and linux when the path length for workshop mods was greater than 256 characters.
  • Fixed the mods downloading notification not going away when mods finished downloading.
  • Fixed a bug causing pigs to respawn immediately upon restarting the game.
     

 

View full update

 

Don't mean to be a bother after all these fixes just happened but is the merm ai being bugged a known issue atm I know there was a thread on it yesterday but i didn't know if you guys saw it or not thanks in advance.

Link to comment
Share on other sites

26 minutes ago, Scrimbles said:

Is there still a 100mb limit on mod uploads though? I've been getting conflicting info on that point, if anyone happens to know I'd appreciate it.

Quote

Workshop API Upgrade
The Steam Workshop API has been upgraded, this provides the following improvements:

  • Mods will be smaller in file size, along with downloading faster.
  • Updates won’t require redownloading the whole mod, instead only the changes are downloaded.
  • The File limits imposed by the previous API are gone.
  • Mods will be automatically updated by the steam client without the game even needing to be open.
  • The Mods Tab should perform better due to using the faster API for getting mod info.

 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

6 hours ago, Scrimbles said:

Nice, had to split assets to a different workshop upload recently and it was causing crashes.

 

Is there still a 100mb limit on mod uploads though? I've been getting conflicting info on that point, if anyone happens to know I'd appreciate it.

ISteamUGC has no real limitation for any content's total size nor file counts that reside within them.  ISteamRemoteStorage has the 100MB limit and other limits.

Klei is now using the ISteamUGC interface.

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

looks like I'm not the only one encounter with the bug after this update ( in Klei official dedicated server )

1. pigs don't spawn from the house ( including building one new pighouse )

2. rabbit don't spawn ( uncertain )

3. bunnymen don't spawn

Link to comment
Share on other sites

1 hour ago, gghhrr said:

looks like I'm not the only one encounter with the bug after this update ( in Klei official dedicated server )

1. pigs don't spawn from the house ( including building one new pighouse )

2. rabbit don't spawn ( uncertain )

3. bunnymen don't spawn

Also hound are coming out of hound mounds

Link to comment
Share on other sites

12 hours ago, gghhrr said:

looks like I'm not the only one encounter with the bug after this update ( in Klei official dedicated server )

1. pigs don't spawn from the house ( including building one new pighouse )

2. rabbit don't spawn ( uncertain )

3. bunnymen don't spawn

im having the same bug with the last patch

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...