Jump to content

Problems with the latest game update


Recommended Posts

Until the day before Wendy's update I played DST every day, on a "huge" server, with caves and 48 mods. The game slowed me down occasionaly, but most of the time I was able to play very well. I also specify that I don't have a particularly powerful computer.
After the update, the server no longer started in any way. I found myself forced to cancel it, with great regret.
I decided to create a new server, "huge", with caves and 40 mods. It failed to load.
I tried to create another server, "small", with caves and 40 mods.
It failed to load.
I tried to create another server, "huge", with caves and just 20 mods.
It failed to load.
I tried to create a last server with all the default settings, with caves and without mods. It started after a considerable waiting time, when before, without mods, the servers load almost immediately.
What happened to the game? Why does it suddenly seem to have become so heavy and under-optimized? What has changed Wendy's update so drastically? I find it absurd to have had to delete my world and not be able to play for the Wendy update anymore. I am not playing an early access game, these are things that should not happen.

Edit: I know that the archery mod no longer works after the last update, in fact it was the first mod that I removed. But the server was no longer starting anyway. But not because error messages appeared, but precisely because it seemed to suddenly become too heavy for my computer to load.

Link to comment
Share on other sites

Just now, Charlie Dark said:

oh my Maxwell... 48 mods?!?! like server mods? client mods? this is too much! of course there will be conflicts between them, and they may be outdated as well

Before I assure you that everything worked perfectly ... and in any case now I find it hard to start even with 0 mods ...

Link to comment
Share on other sites

Just now, shadowDigga said:

Do you have a backup of your old world? I can try checking it out on my device.

Thank you, unfortunately I don't have an old world backup since I, foolishly, didn't make one. In my defense I can only say that it has always worked well, passing "unscathed" all game updates from Return of Them; except the last one.

Link to comment
Share on other sites

1 hour ago, Pop Guy said:

Thank you, unfortunately I don't have an old world backup since I, foolishly, didn't make one. In my defense I can only say that it has always worked well, passing "unscathed" all game updates from Return of Them; except the last one.

You're probably crashing, with 40 mods especially.

 

When it says "Dedicated server failed to start", that means it crashed.

You can find the crash in the server log. I really dont think you should call this a problem with the game when you have more than 40 mods, I know some mods that broke because they did unoptimised things such as replacing Wendy's and Abigail's prefab causing the game to break.

Link to comment
Share on other sites

3 hours ago, Hornete said:

You're probably crashing, with 40 mods especially.

 

When it says "Dedicated server failed to start", that means it crashed.

You can find the crash in the server log. I really dont think you should call this a problem with the game when you have more than 40 mods, I know some mods that broke because they did unoptimised things such as replacing Wendy's and Abigail's prefab causing the game to break.

I am afraid you have read my message superficially.
My computer before the update correctly loaded servers of up to 50 mods, and has done so for years. Now, suddenly, my computer is unable to load servers with just 20 mods.
But no error message appears. It is only the loading time, which lasts indefinitely. I do not exclude that, if I let the computer work for hours, in the end it would be able to open a server with mods. But I can't wait long just to play.
Also now my computer is struggling to start a server without mod, with abnormally long loading times. It almost seems that the game, after the last update, has become very heavy and sub-optimized. =)

Link to comment
Share on other sites

Just now, Pop Guy said:

I am afraid you have read my message superficially.
My computer before the update correctly loaded servers of up to 50 mods, and has done so for years. Now, suddenly, my computer is unable to load servers with just 20 mods.
But no error message appears. It is only the loading time, which lasts indefinitely. I do not exclude that, if I let the computer work for hours, in the end it would be able to open a server with mods. But I can't wait long just to play.
Also now my computer is struggling to start a server without mod, with abnormally long loading times. It almost seems that the game, after the last update, has become very heavy and sub-optimized. =)

Ah I see, that sucks very much. But,  I don't think its really up to Klei to try and fix and lower loading times of servers with upwards of 50 mods

Link to comment
Share on other sites

1 minute ago, Hornete said:

Ah I see, that sucks very much. But,  I don't think its really up to Klei to try and fix and lower loading times of servers with upwards of 50 mods

Okay, and I understand it. After all, they also warn that "those who use mods do so at their own risk". But look at it this way: I used to play serenely in a game that I thought was complete; the game has been updated with an update that, personally, I didn't consider necessary, and now I find myself unable to play as I had fun before. Not only that, but now I struggle to play even with the base game and, really, all because they have substantially worsened how Abigail works ... I was hoping that some forum users could suggest me some method to make the game lighter :D

3 hours ago, Tosh said:

Without any mods enabled, do you experience a longer load time when loading into a pre-existing world or just on initial world gen?

Both to start a new world and to start an old one I have to wait a lot, I think even up to ten minutes of loading. Before, to load a world without mods, my computer took at most thirty seconds-a minute.

Link to comment
Share on other sites

6 minutes ago, Pop Guy said:

Both to start a new world and to start an old one I have to wait a lot, I think even up to ten minutes of loading. Before, to load a world without mods, my computer took at most thirty seconds-a minute.

Unless your computer is really bad/overworked that shouldn't happen, try checking your file integrity or uninstall the game and install it again.

Also, when an update comes is normal for mods to break, specially those that affected the Abigail and Wendy scripts as those have been significantly altered. Just look into your list of mods and update/remove those that are causing trouble.

Link to comment
Share on other sites

1 minute ago, CremeLover said:

Unless your computer is really bad/overworked that shouldn't happen, try checking your file integrity or uninstall the game and install it again.

Also, when an update comes is normal for mods to break, specially those that affected the Abigail and Wendy scripts as those have been significantly altered. Just look into your list of mods and update/remove those that are causing trouble.

Thank you, I haven't actually tried to uninstall the game and reinstall it yet. I try now.

Link to comment
Share on other sites

I have a question pertaining to Mods, whenever Klei releases a new game update do they also have to account for Mods?? Because it just seems rather unfair for a development company to have to make sure their game works with Unofficial Mod content.

I know that Klei doesn’t mind and sometimes fully supports mods- But for most game companies Mods just become more hassle to deal with making sure their game is compatible with.

As a Console player there are SOME Mods I wish would become officially available on Consoles..

Such as the Cherry Forest Mod, Regorgitated, Re-Forged, Play as Animal Mobs, and whatever this really dang cool looking one seen at about 1:30 in this video link Here that makes the game 3D is..

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...