Jump to content

Well, that's a first


Recommended Posts

Well, this is interesting.

I had subworld files modified to guarantee a few geysers, including an iron volcano and a couple of cool slush vents in the frozen biome. I think there was something wrong with the POI files (they were created in QoL Mk I) which prevented frozen biomes from being generated. Once I took those files out and re-verified game files, the same seed generated normally, frozen stuff and all.

I wish the game would just tell me there was a problem during map generation instead of breaking quietly...

 

Link to comment
Share on other sites

39 minutes ago, M.C. said:

I wish the game would just tell me there was a problem during map generation instead of breaking quietly...

It might not have noticed that anything was wrong.  Computers aren't known for their intuition or intelligence.

Link to comment
Share on other sites

Since he modified the poi files, it can't really be classified as a bug.

Changing the files can have lots of strange effects on the world builder. 

I've taken a seed and then made a very minor change to one of the poi's.  Using the same seed ended up with a completely different map.  Geysers in different regions and even types.  Biomes shifted around.  All kinds of things. 

Link to comment
Share on other sites

 

3 hours ago, Soulwind said:

Since he modified the poi files, it can't really be classified as a bug.

Oh, it can. No doubt about it.

Intended behavior: the world generator reports an error when it encounters bad POI data.

Actual behavior: the world generator fails silently, resulting in a corrupted map.

The "fails silently" is the problematic part. Everything else is as expected.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...