Zillvr

Troubleshooting: Cannot Receive Twitch Drops?

Recommended Posts

Zillvr    1755

@AiurRefugee Have you gone through the TROUBLESHOOTING links above? Normally, if there are internal issues from the game client the client_log.txt would reflect communication issues with Klei Servers with "ERROR" and "FAIL" but I couldn't see any that seems to be going wrong in your log file. Unless the devs have completely removed any indicator for communication failures and such.

For now, I hope you've gone through all the links above AND made sure you've double check the connections between twitch and your klei accounts. We'll have to wait on the other users experiencing issues, that maybe their log files will help shed some more light on what the issue could be.

Share this post


Link to post
Share on other sites
Zillvr    1755

@AiurRefugee after reconnecting, have you rewatched for the accumulated time? At least 30 mins for the first drop. AFAIK, once you reconnect, the previously watched times is are not counted since Twitch has already given a drop. Don't quote me on this since I have not personally tested this.

@YeetusDelitus So you've tried everything above, could you attach a copy of your client_log.txt file? Maybe that would shed some more light and help with figuring out what's going wrong.

  • Like 1

Share this post


Link to post
Share on other sites
Zillvr    1755

Hello @JongIe, welcome to the forums. Have you gone through all the links above? Were you even able to receive your Daily Gift drop when you first logged in DST?

I logged in just now for the first time today and my logs shows the following:

[00:00:18]: [200] Account Communication Success (3)
[00:00:18]: Logging in as KU_FwgOBXDf
[00:00:19]: There is no active event to get the status of.
[00:00:21]: loaded inventory_cache_prod
[00:00:25]: saved APP:Klei//DoNotStarveTogether/190232237/client_save/inventory_cache_prod
[00:00:25]: saved APP:Klei//DoNotStarveTogether/190232237/client_save/inventory_cache_prod_sig
[00:00:28]:    EResult 15, 856850377

Whereas yours and AiurRefugee only shows:

[00:00:50]: [200] Account Communication Success (3)
[00:00:50]: Logging in as KU_#######
[00:00:51]: There is no active event to get the status of.
[00:00:52]: loaded inventory_cache_prod
[00:00:54]: loaded inventory_cache_prod

Now, as a disclaimer. I'm only a forum moderator but from what I know about reading logs. The EResult 15... line is what reflects that I've been gifted my Daily Gift. Although maybe yours doesn't show it since you've already previously received your Daily Gift for the day and that client_log has already be overwritten.

Can you confirm you've already received your Daily Gift? If not. That might be a hint to the issue everyone else is having.

 

Share this post


Link to post
Share on other sites
Zillvr    1755

Thank you to everyone making replies, so far nothing seems to show why people are having issues. If you've all done reconnects and rewatched the time required to accumulate again, but still get no drops. I'm still not sure how to go forward. Logs are all reflecting the same things (thanks btw @YeetusDelitus). And there doesn't seem to be anything wrong with "DST clients receiving gifts" portion of the equation (daily gifts in particular)... just an issue with Twitch Drops. 

Could be on twitch's end? But I personally was able to receive the Twitch Drop the other day so that can't be it.

Have you guys verified your emails for your twitch accounts? If you're using new accounts it could possibly be causing a hiccup from that. Just a thought. On Twitch go to Settings > Security and Privacy Tab > Under Email should show Verified.

Unfortunately, this is all the time I can spare for today. I'll be back again within 24 hours, if any of you discovers any workaround of fix for the issue don't hesitate to share in this thread. Sorry for not having much progress with diagnosing the issue so far.

Share this post


Link to post
Share on other sites

I think I got a Drop, but why hasn’t the item shown up in my game account?

The game developer is responsible for fulfilling the Drop rewards in the game and in some cases, this may take time to process. Please contact the specific game developer directly for any questions. You can do some initial troubleshooting by checking that the item has shown up on your Inventory page and that your game account is linked to the correct Twitch account.
 
This was on their Drops website.
  • Thanks 1

Share this post


Link to post
Share on other sites
BeeboxD    3

I've tried everything you said and nothing worked.client_log.txtand as you asked somebody before I already have today's gift. I watched for about an hour after reconnecting my accounts.

  • Thanks 1

Share this post


Link to post
Share on other sites

I started watching my first stream I guess around 6pm-ish last night and even twitch confirmed that I received all 3 drops, I checked I even verified my emails on twitch and klei as well as the one for the forums (don't know if that matters but....) didn't see it, so I disconnected and reconnected everything and even re-watched another DST live stream with an "official drop" on their stream. It's probably due because its my first time doing this so I'm not very sure. Hopefully this gets sorted out soon. 

I'm also kind of bothered since most of the comments suggest everyone has done and tried the same thing, I wonder if there's another/ different step that we missed or there's some other verification we missed, but pretty much covered it with Zillvr's post.

client_log.txt

  • Thanks 1

Share this post


Link to post
Share on other sites
nome    4945
18 minutes ago, Pumpkin Soda said:

I started watching my first stream I guess around 6pm-ish last night and even twitch confirmed that I received all 3 drops, I checked I even verified my emails on twitch and klei as well as the one for the forums (don't know if that matters but....) didn't see it, so I disconnected and reconnected everything and even re-watched another DST live stream with an "official drop" on their stream. It's probably due because its my first time doing this so I'm not very sure. Hopefully this gets sorted out soon. 

If twitch says you got the drops but you don't see them in your account, probably you linked a different account after the first one? Twitch sends us "ticks" for the account, but they only go to the KU you linked to that twitch account most recently.

  • Like 1
  • Thanks 3

Share this post


Link to post
Share on other sites
sharckgx    4

client_log.txt
 

I did all the processes several times between yesterday and today, I only have one Twitch account and one Steam account, I unlinked and linked several times, I used another account to see if the problem was with the twitch, but even so I didn't gain anything in other. @Zillvr

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Zillvr and Nome

I have done all tasks to link account between Klei and Twitch, doubled checked the linking status.I received the daily gift as usual.Even I disconnected both connection, reconnected and watched streaming again the same,I still cannot achieve drops in the game.

Hopefully this issue take into account soon 

client_log.txt

  • Thanks 1

Share this post


Link to post
Share on other sites
akzakz    1
7 hours ago, Zillvr said:

@AiurRefugee Have you gone through the TROUBLESHOOTING links above? Normally, if there are internal issues from the game client the client_log.txt would reflect communication issues with Klei Servers with "ERROR" and "FAIL" but I couldn't see any that seems to be going wrong in your log file. Unless the devs have completely removed any indicator for communication failures and such.

For now, I hope you've gone through all the links above AND made sure you've double check the connections between twitch and your klei accounts. We'll have to wait on the other users experiencing issues, that maybe their log files will help shed some more light on what the issue could be.

Hey. yes i've tried relinking both accounts multiple times. Still doest work :(

Just now, akzakz said:

Hey. yes i've tried relinking both accounts multiple times. Still doest work :(

@PeterA

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now