Petroleum generator cannot switch material from ethanol to petroleum.


BBream
  • Branch: Preview Branch Version: Windows Pending

Problem:

Petroleum generator have not function if ethanol is shut off and petroleum is put.

Screen shot show petroleum generator is stopped if material is switched.

 

Expected behavior:

If any kind of combustible liquid is put in petroleum  generator, it should function.

 

JvhhFeG.jpg


Steps to Reproduce
1. Build Petroleum generator >> 2. Put ethanol into the generator >> 3. Shut it off and wait out of it >> 4. Put petroleum into the generator
  • Like 3


User Feedback


....

The problem is present in your screenshot. The system still wants to burn ethanol, but there is not enough to run. But because there is a bit leftover, it wont switch to the other fuel. Problem here, there is no clean button to extract the waste...  Only option would be deconstructing, or give it exact the amount of ethanol it needs for one cycle. The latter should prove difficult.

The devs should fix this asap, because it should work, even if the fuel is mixed. It takes 2 kilos of whatever to run the generator. It should not matter it its 2 different fuels.

  • Like 1

Share this comment


Link to comment
Share on other sites
....

what really surprises me is there can be a few mg of fuel left, its consumes 2kg/s is the ticks for consumption really that small so it can leave a few mg of fuel?

Share this comment


Link to comment
Share on other sites
.... .... .... .... .... ....

Bump.

It took me some time to realize what was going on with my generators. Now all my reservoirs have mixed Ethanol and Petroleum. Gotta filter it all out and rebuild them... Please someone at least put a button to empty the generator...

Edited by MrGuga
wrong info

Share this comment


Link to comment
Share on other sites
....

I just ran into this, seems stupid, any fixes out there for this?  Can we get a clarification if this is expected?  I see a lot of bugs in pending state is there a state that represent known bug and fixing in future update or something, so that we at least know you are on it?

Oh this is on the Live Branch as well.  Probably should be changed as such.

Edited by CoyoteWAN

Share this comment


Link to comment
Share on other sites
.... ....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now