Jump to content

why dst cant keep constant 60fps?


Recommended Posts

Hi there. Im experience bad performance since RWYS,i think is caused because for some reason i cant put the game on full screen which causes problems for not being in native resolution (zark thinks that might be cause by my screen but i couldnt test with other screen). Thanks to @Karitha i can put the game in a fake full screen with an app. 

The game is always running between 55 to 60 fps which cause eye fatigue and makes annoying doing fights that needs quick reations

the thing is that maybe isnt caused because of that problem so i prefrer to discard other problems before


these are the specs

Spoiler

 

Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz   3.30 GHz

16.0 GB RAM

win 10 64-bit operating system, x64-based processor

Radeon RX 560 series

screen resolution 1920x1080

 

graphic configuration

Spoiler

image.thumb.png.b95aa5964d830851880a4cb1892ee3d8.png

as i said before, changing the full screen setting does nothing. Diseabling bloom and distorsion improves a little the performance but still being sh*tty

mods

Spoiler

image.thumb.png.00053a51b3487605749087437fdf53be.png

i didnt recall having actionqueue reborn active when i started writting this topic, might be the cause? idk if it consumes, i will diseable it anyways since i only use it for pinecones (pls klei add something to plant pinecones....)

i dont usually use server mods

 

i tried several times to turn on small textures which does nothing (and honestly i wont play with that low quality textures...), verified the files, reinstall, etc

i just want to confirm if my computer can handle the game properly or if something is wrong

Link to comment
Share on other sites

16 minutes ago, ArubaroBeefalo said:

but the fps problem isnt near the new trees :/

being near drops it even more but i have this problem all the time

I know it's the shadows as I was having a simular problem where my game would barely run with them on, and runs decently without them on. It's can't hurt to atleast try them without them on.

Link to comment
Share on other sites

3 minutes ago, Frashaw27 said:

I know it's the shadows as I was having a simular problem where my game would barely run with them on, and runs decently without them on. It's can't hurt to atleast try them without them on.

but it affects the performance even when you dont even sail? because i was playing in a world where i didnt plant any tree, if that is the problem i might drop the game for a while because the shadows is what made me want to keep building

i will try it when i arrive home, thanks

Link to comment
Share on other sites

Just now, ArubaroBeefalo said:

but it affects the performance even when you dont even sail?

Yes, because the game has to render in that shadow even if you aren't doing anything in that area to ensure that it's available if you do. It's can also be seen in how 20,000 entities could be loaded while you're just in a field munching on a few berries. I'm also not saying that you can't also turn them on and off mid game, as that seems to be your best course of action. Have them on while building, but turn them off while you're doing something like getting wood or slaying dragonfly. Take advantage of both ideas of the coin.

Link to comment
Share on other sites

I know on my monitor which's 144hz unless I manually set it to 60hz (changing the refresh rate in game is useless lol) when I go fullscreen the game will be incredibly choppy running at around 10-20 fps. So, it might be a glitch like that idk

Link to comment
Share on other sites

22 minutes ago, Well-met said:

have you checked without geometric mods? I imagine those are expensive

no and i guess i should have tried the game diseabling all the mods before. Is true that the grid consumes a lot but never experienced performance issues with it when i was not using it
tomorrow i will try to play without anything and see

32 minutes ago, . . . said:

I know on my monitor which's 144hz unless I manually set it to 60hz (changing the refresh rate in game is useless lol) when I go fullscreen the game will be incredibly choppy running at around 10-20 fps. So, it might be a glitch like that idk

hmmm mine was at 59 and i changed it to 60 (the max of my screen) just to try something 

Link to comment
Share on other sites

1 hour ago, ArubaroBeefalo said:

no and i guess i should have tried the game diseabling all the mods before. Is true that the grid consumes a lot but never experienced performance issues with it when i was not using it
tomorrow i will try to play without anything and see

hmmm mine was at 59 and i changed it to 60 (the max of my screen) just to try something 

my game lags pretty bad with the geometric mods on. I usually only put them on briefly after playing a world for a while so i can make everything pretty. 

i'm not an expert on PC hardware but isn't the 2500K a pretty old processor? what's your cpu usage when playing?

ur graphics card is fine, i usually play with intel 4000 graphics on a 6GB machine and i rarely get stutters when have no other processes in the background. I do play with small textures since that doesn't bother me and i have limited memory to spare.

Link to comment
Share on other sites

1 hour ago, hhh2 said:

i'm not an expert on PC hardware but isn't the 2500K a pretty old processor? what's your cpu usage when playing?

 

kinda old xD

image.thumb.png.88bc8de19744e0c0677c8754a93eaa81.png

this was with my most demanding world

another user said my computer has bottleneck and is clearly the cause of fps drops in crowded areas but i believe the computer should be able to run the game with stable fps in not crowded areas in new worlds but isnt the case

i might be wrong tho since i dont know much about this kind of things

Link to comment
Share on other sites

8 minutes ago, DajeKotlyar said:

You can try to force game to run in your resolution via Steam config

 

I play on potato pc with wrong resolution and game run... not well, but smooth enough to play. ~45 FPS in old worlds, and stable 60 on the new worlds. I'm not a server by the way

i didnt know you could do it. Can you explain how?

the problem i have is that, even if +55fps sounds good, the FPS are constanly changing which causes eye fatigue after few minutes playing

Link to comment
Share on other sites

8 hours ago, ArubaroBeefalo said:

i didnt know you could do it. Can you explain how?

the problem i have is that, even if +55fps sounds good, the FPS are constanly changing which causes eye fatigue after few minutes playing

 

5 hours ago, DajeKotlyar said:

I mean do something like this:

(Sorry, it's on Russian, but you can find it)

IMG_20211228_075733.jpg

IMG_20211228_075747.jpg

This is using command line options, which some programs support and usually allow setting window width (-w) and height (-h).

You can find the command line options (which are called "launch options" in steam) by clicking on the settings cog on the right hand side of the screen, right bellow the selected game's promotional banner, then navigating and right clicking to the last option in the prompted drop down box: Properties to open the game's properties menu. From there another window will open and you will be shown additional options, among them will be a text box with the label "launch options", where you can add command line arguments and input the resolution to force the game to run at.

If you are going to change the resolution keep the aspect ratio near widescreen (16:9) or the in game menu UI will break. 

11 hours ago, ArubaroBeefalo said:

kinda old xD

image.thumb.png.88bc8de19744e0c0677c8754a93eaa81.png

this was with my most demanding world

another user said my computer has bottleneck and is clearly the cause of fps drops in crowded areas but i believe the computer should be able to run the game with stable fps in not crowded areas in new worlds but isnt the case

i might be wrong tho since i dont know much about this kind of things

can I ask why you are still using the 32 bit version of dst? That will defiantly cause performance issues especially on larger worlds.

Link to comment
Share on other sites

15 minutes ago, hhh2 said:

 

 

can I ask why you are still using the 32 bit version of dst? That will defiantly cause performance issues especially on larger worlds.

i tried the 64bits version (i was hyped when they released it because i though i would be able to run my megabase ) but the performance is slightly worst

also an user that helped me told me that my computer cant run megabases because it has bottleneck so i guess that is a lost war, now i just wanna be able to, atleast, get stable fps outside of crowded areas

Link to comment
Share on other sites

Can not give you any solution about resolution, except which I did before. But I'm sure your computer can run bc my old computer with GT430, 8gbRam and i3 first series can run either. It's not normal that you can not launch game in 64 bit.

Is that possible that you had removed/edited any windows root file? I had a similar problem at my "customized iso" project. I believe you have a corrupted os file. Format your computer if you can backup things, launch dst on a virtual box if you cant format.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...