Jump to content

any chance there is a command to change the "game mode" to survival after creating the world? help!


Recommended Posts

Documents -> Klei -> DoNotStarveTogether -> Cluster<number> -> Master -> save -> shardindex. Open that with a text editor and you should be seeing stuff like this at the top: 

....

  server={
    clan={ admin=false, id="", only=false },
    description="",
    encode_user_path=true,
    game_mode="survival",
    intention="cooperative",
    max_players=6,
    name="Solo(ish)",

......

Here is the game_mode parameter frankwizza is talking about

Link to comment
Share on other sites

11 hours ago, SDavid said:

Documents -> Klei -> DoNotStarveTogether -> Cluster<number> -> Master -> save -> shardindex. Open that with a text editor and you should be seeing stuff like this at the top: 

....

  server={
    clan={ admin=false, id="", only=false },
    description="",
    encode_user_path=true,
    game_mode="survival",
    intention="cooperative",
    max_players=6,
    name="Solo(ish)",

......

Here is the game_mode parameter frankwizza is talking about

I tried this but it didn't work

11 hours ago, frankwizza said:

If you go into your cluster file for that specific shard under gameplay you should be able to change game_mode = survival.

yeap I did that but when I relog the game is still in wilderness

Link to comment
Share on other sites

If I remember correctly, UI doesn't show changes if they are made via game files or something like that.

Try to change your game mode as SDavid said and test your resurrection ability. If it works as you wanted, then your game mode was changed successfully.

P.S.: Remember to backup your world before doing any tests

Link to comment
Share on other sites

On 4/29/2021 at 11:40 PM, SDavid said:

Documents -> Klei -> DoNotStarveTogether -> Cluster<number> -> Master -> save -> shardindex. Open that with a text editor and you should be seeing stuff like this at the top: 

....

  server={
    clan={ admin=false, id="", only=false },
    description="",
    encode_user_path=true,
    game_mode="survival",
    intention="cooperative",
    max_players=6,
    name="Solo(ish)",

......

Here is the game_mode parameter frankwizza is talking about

 

9 hours ago, Duck986 said:

If I remember correctly, UI doesn't show changes if they are made via game files or something like that.

Try to change your game mode as SDavid said and test your resurrection ability. If it works as you wanted, then your game mode was changed successfully.

P.S.: Remember to backup your world before doing any tests

After a couple of tests I was able to make the change to endless but not survival...

dunno maybe there is something in there that allows much more easily to change to endless instead of survival coming from wilderness?

weird... but hey!! ty so much! at least I get to focus on base building

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...