Jump to content

Game freeze - log shows "[INFO] Screenshot!"


Recommended Posts

Hi guys !

I've been coming back to the game recently to celebrate LU, and it's been a blast !

However today I have been experiencing a super weird bug. I don't know if it has anything to do with the update that came out 20hrs ago? I've read they updated the timelapse system, and it *might* be related IMO.

The bug happens out of the blue, I haven't been able to isolate a cause for it.

The game keeps running, although at a much slower framerate, but the camera is frozen. I can't move it with the keyboard, I can't move it with the mouse. I also can't zoom with the mouse wheel. Everything keeps working though, and I can still interact with anything on screen.

The only solution I found is a save/reload, but it happens every 10 to 20 minutes and it's frustrating.

The only thing I was able to track down is that, in both case, "output.log" shows a cryptic "[...] [1] [INFO] Screenshot!" (where "..." is the time). This message comes EXACTLY when the bug happens.

I'm clueless as to what I can do to further investigate, or fix it.

Does anyone have any pointers ?

Link to comment
Share on other sites

I've tried repairing the game files, that did not work either.

When tracing the game process with procmon, I found a few things that might be relevant (picture attached).

 

I don't know what "D65.cam×p" or "Photo.gmmp" are, but apparently they're used to create the pictures for the timelapse.

Also, it appears to be missing something in "HKLM/.../CTF/KnownClasses", but I'm clueless.

Any guru out there who could think of something I could do ?

SnapCrab_NoName_2019-8-9_14-50-44_No-00.png

Link to comment
Share on other sites

No, they're not there. The timelapse is shown as "unavailable".

My hunch about it as of right now is that something hangs when Unity tries to capture the screen.

I do not know what, I know nothing about Unity or those low level spooler Win7 utilizes for screen cap.

What I would very much like to do is simply disable the timelapse feature. I'm no using it, I don't plan on using it, and it makes the game unplayable for me.

 

EDIT: I'm lying, I have 2 valid timelapse pictures for one of my colony, so it worked twice, yesterday morning, just after the latest update.

Link to comment
Share on other sites

5 minutes ago, ueMistakeNot said:

I've sent a mail to Klei live support earlier today, with a link to this thread. Should I do something else ?

Post bug here:
https://forums.kleientertainment.com/klei-bug-tracker/oni/

When it works after that "Screenshot!" next line in log should be directory name where those screen shots are saved. (If not exist that directory should be created)

But between is Unity call to this EncodeToPNG() function where it might hang:

https://docs.unity3d.com/560/Documentation/ScriptReference/Texture2D.EncodeToPNG.html

 

Link to comment
Share on other sites

Klei wasn't able to provide me with a way to disable the timlapse feature for the time being, so I reverted my game to Lu-357226 and it's working fine again. Now I can waste my week-end properly, I'm *very* happy =)

My thanks to everyone here for your help & support !

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...