bzgzd

  • Content Count

    338
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Downloads

Klei Bug Tracker

Game Updates

Hot Lava Bug Reporter

Everything posted by bzgzd

  1. Maybe it is worth mentioning that this behavior was in the game in 2017 when it was changed after reported as bug: But then somehow at some point it came back.
  2. His food is in the fridge (or ration box). As many people do it - have fridges not powered but in sterile atmosphere. When that sterile atmosphere is broken and food is bellow 75% game warns you with this message that has also tooltip "food items are stored but not refrigerated". But instead of targeting that fridge or ration box with bellow 75% food that is still going bad it just opens build menu.
  3. I like that now there is no battery needed between large transformer and 1.2kW consumer like refinery or aquatuner because it was just confusing. But it would be nice to have 2kW transformer now for 2kW wire when they can work as overload protection. Transformer would take care of some rare cases when too many sweepers would like to work at the same time or it could delay some exosuit docks a bit... I have too many 120W stuff that works just few seconds a day. Edit: or maybe putting 2x 1kW transformer on conductive wire might do it...
  4. "Auto-Sweepers outperformed dupes for cycles: {0} / {1}" Is not filled with correct first number. DupesVsSolidTransferArmFetch method Success() checks last 5 cycles going from oldest (-5) to latest cycle (-1), counts max. number of consecutive successful cycles but updates currentCycleCount only when it finds failed cycle. If someone has last 4 cycles successful progress displays 0/5. Also it should display currently active progress for that achievement, so if last cycle was not successful it should be 0/5 regardless what happened 5 cycles ago so check should go from (-1) to (-5), stop on first failed and update currentCycleCount.
  5. Duplicants with trait Gourmet can't have interest in cooking. On other hand "No Taste" duplicant can have cooking interest. Probably that "Cooking" requiredNonPositiveAptitudes should go under "SimpleTastes" trait instead of "Foodie" trait.
  6. I have them also all green but I didn't tame all critter types at all so it seems bug is with that checkboxes progress. But when starting new game they are correctly all unchecked...
  7. Meat from hatch has 2000g which is 3200 kcal.
  8. I tried your save and problem is that when I loaded it, it showed you have 48 dupes alive. But 4 of them are actually dead and stuck behind some objects. Two are behind trees, one body is behind water sieve and one behind wash basin. Click on dupe names under "vitals" list and where you don't see "Move To" button, those 4 are dead but didn't die properly. First two and last two if I remember correctly. Uproot those two trees and deconstruct sieve and basin with yellow alert so it is done before new day and duplicant count should drop to 44. After that I could run your save to cycle 1552+. So maybe some bug when dupe dies while working on something...
  9. There are some dupes with gender M, some with F but those with X are suspicious here.
  10. This also makes warning in output_log.txt: "{0} is getting an abnormal mass set {1}." I believe setting maxStackSize to something other than float.Max also for EntitySplitter, similar to ElementSplitterComponents 25t might be the solution as CanFirstAbsorbSecond() will then return false. EntitySplitter.maxStackSize = 3.40282347E+38f; ElementSplitterComponents.MAX_STACK_SIZE = 25000f; PrimaryElement.MAX_MASS = 100000f;
  11. Are you on windows 10 that was recently updated? If yes check or upload output_log.txt If it contains this error: IndexOutOfRangeException: Array index is out of range. at UnityEngine.Display.RecreateDisplayList (System.IntPtr[] nativeDisplay) [0x00000] in <filename unknown>:0 try starting the game while holding shift and check if in opened dialog you can select Monitor or if that list is empty. If monitor (display) list is empty there might be some problem with scaling setting after windows 10 update. Win10 is doing something with display scaling feature so it can run on all kinds of different display resolutions... If you are using DVI, HDMI or DisplayPort connection to monitor you might try to use GPU scaling instead of Display scaling. Perform scaling on: GPU Or "No scaling" mode instead of "Aspect ratio". Right click on desktop and select "Nvidia control panel" or "AMD Radeon Settings" on nvidia cards it is under "Adjust desktop size and position" https://forums.kleientertainment.com/topic/85690-windowes-update-and-now-issues/ https://forums.kleientertainment.com/klei-bug-tracker/oni/black-screen-of-death-on-w10-1709-r8127/ https://steamcommunity.com/discussions/forum/1/1480982971174752598/ This problem is not specific to ONI and you can find some more info also in other games forums.
  12. This can be reproduced by having open doors in vacuum and then save + load and after load close doors.
  13. Seeds are integers 'int' in code. That means max number is 2147483647 = 7FFFFFFF. Looking at your image it seems like you used 748298374893 which is too big and ends as 0. I tried that and got world seed zero and in log this: [ INFO ] Set world to [worlds/Default] C:/Program Files (x86)/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded_Data/StreamingAssets\worldgen/ [ INFO ] Using player defined seed Seeds are [0/0/0/0] But somewhere that large number survived... (at least in output_log.txt) [ INFO ] Set world to [worlds/Default] C:/Program Files (x86)/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded_Data/StreamingAssets\worldgen/ Shader warmup: 80 shaders 204 combinations 0.001s [ INFO ] Custom Settings: ImmuneSystem=Default,Stress=Default,StressBreaks=Default,WorldgenSeed=748298374893, So maybe bug is that it is possible to enter seed number out of range?
  14. I don't have linux and have no idea how it works, but in some parts of the world (like where I live) is as decimal separator used comma like 1,23 instead of 1.23 So it might be the case that some system "string to number" methods expect comma instead of dot in your cases. ONI should be able to deal with it but maybe you can try to temporary change your system to use dots as decimal separators?
  15. Output coolant, until it is pump out (so while still in the machine) is pickable. Duplicants can pick it from machine output (like from storage) and they do it if you have bottle emptier for that liquid somewhere. (probably not intended behavior) Those unclickable bottles appear when duplicant pick as bottle all available output liquid and 0kg is left. (when you have more bottle emptiers or there was less than 200kg in the machine output at the pickup moment) Those bottles have 0kg and are not on the ground "flying" and also debug tool "clear floor" is not clearing them but they should disappear with save + load.
  16. This is follow up for this bug: Can it be further changed so that ReplaceElement to Vacuum is not called when it is Gas or Liquid instead of just check for Gas? Currently liquids (water) are still being deleted by open doors. (I am using automated door system to compress PH2O.)
  17. "Known issue" Metal Refinery output liquid (coolant) temperature not always calculated correctly.
  18. It is possible to set priorities to deconstruct jobs but duplicants are not considering them and do deconstruct before anything else. Buildings that have their operating priority (like compost for example) are deconstructed in their priority order.
  19. Often temperature of output coolant after refining metal in Metal Refinery is not calculated correctly. On my PC this happens about 20% times. Here in this save are 10 refineries and 10 duplicants making iron. Input is freezing 0C water and buildings are same and bellow 10C. Output water temperature should be 32-33C. (as it is after first refine) Sometimes instead of "averaging" output temperature it is somehow added together with current temperature (even if current mass is 0kg). So if that happens output water is 65+C. (also sometimes it is 0C instead of 32C) If I am "lucky" it can happen 2 times and then output is 98+C and sometimes when it happens 3x water can get to 130C and pipe break. (as at the end of the video) Pit.sav
  20. There was some change related to Popped Eardrums mentioned in "full update list":
  21. I have no idea what is causing this bug but it happens often in my game as well. Problem is it is not easy to reproduce and save+load would fix it so it is hard to report. I made at least some video. In first video Max is idle, not cooking and not delivering mushrooms from fridge to grill. At this moment only he has access to those fridges and to grill but still he is not moving mushrooms from fridge to grill. https://youtu.be/1sT4vtyd7_g In second video (next cycle) I gave access to everyone to that area and still no one was delivering mushrooms to grill. I tried to set fridge priority to 1 and other fridge priority to 9 but no one was picking those mushrooms from prio 1 fridge. Like if content of that fridge was somehow locked or inaccessible... https://youtu.be/AVKKiL5jNLs Only fix I could do (other then save+load) was to drop fridge content on the ground.
  22. I don't "run" doors. They are open. No automation connected to left 3 doors or bottom 10. Just open doors and save + load.
  23. After loading game, everything that is on place where open doors are (mechanized airlock) gets deleted. Immediately after load stuff is there but when unpaused during first second it is changed to vacuum. Save + Load should not change game that much. doors.sav
  24. This small bug is not new and is present also in live version. After loading saved game all bottle emptiers have for short time enabled autobottling. (like if after load first duplicant jobs are assigned and then bottle emptier "no autobottling" setting is set) Here in this cycle 2 save are 3 idle duplicants and bottle emptier with not enabled autobottling. When save is loaded one duplicant gets job to deliver water bottle from pitcher to emptier even it should not happen. Paradise.sav