bzgzd

  • Content count

    338
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Downloads

Klei Bug Tracker

Game Updates

Hot Lava Bug Reporter

Everything posted by bzgzd

  1. This would be uptime since game start. They show uptime for last 600 seconds or 6000 seconds. In such case knowing that something was used 10% during last 10 cycles is not enough information for future calculations. It could have been used evenly 10% each cycle or also it could have been used fully during just one cycle 9 cycles ago or ...
  2. Ehm... MF99K, are you 51% shareholder at Klei Entertainment? Just asking...
  3. Duplicants with trait Gourmet can't have interest in cooking. On other hand "No Taste" duplicant can have cooking interest. Probably that "Cooking" requiredNonPositiveAptitudes should go under "SimpleTastes" trait instead of "Foodie" trait.
  4. I believe there is no specific debris handling in code so this seems to be bug with splitting stacks in general. That means also stuff that is in containers is affected. I put 3100kg hot gold into one container inside cold water. That made it one stack and then I moved 1000kg into one, 2000kg into another, and left just 100kg in original storage. 100kg was loosing temperature slowest at speed of 3100kg. Moving that 100kg into another container fixed it to correct 100kg behavior.
  5. Maybe it is worth mentioning that this behavior was in the game in 2017 when it was changed after reported as bug: But then somehow at some point it came back.
  6. This looks like another buggy behavior. This one is related to conveyor rails. Not only with medical pills or wood or other things in that group. I put 41kg igneus rock in loader and that last 1kg is heating up slower then first two 20kg so probably acts like 41kg. I didn't try what would happen when splitting those packets onto different rails or something like that.
  7. Seems all to be just cause of the same very basic thing. When dupe, or sweeper arm, or conveyor loader creates new chunk by splitting it from bigger chunk. Bigger stack could be 2kg when something takes just 1kg from it... It happens in almost everyone base every cycle. Just watch temperature of food your dupes eat. (after picking from storage or taking it from bigger pile on the ground)
  8. There is no 20kg magic number. Any new stack created from big stack has temperature reset. Like 1kg when picked by dupe to eat -> temperature reset.
  9. I actually used gravestone officially as I killed one of my dupes that I was not satisfied with... And gravestone is not just to put dead dupes inside it but also for removing "Mourning" debuff that lasts 3 cycles when not removed and adds 20% stress per cycle. Dupes go to gravestone and cry a bit and then debuff is removed.
  10. Don't look at videos and forum posts as 100% always correct. Game is changing and also people don't always get everything 100% right even when it might seem so at that moment. You can do your own tests because you found out from video that there is some temperature bug happening and make your own "misleading" results. Like you posted yesterday: When probably in reality this bug is more fundamental and has nothing to do with conveyor belts. Just dupe picking some wood from big pile of wood and same bug happens. I usually put in stuff like "I think" or "I believe" or "probably" but that can be basically always there when you post something so not needed...
  11. Yes default temperature used in code on many locations is 293K. It is used as default when new stuff is created, like when you get things from care package. I think calculations are not failing but just not done for those "entities" like food, medicine or wood. And this temperature issue seems to be happening for the same entities where you can get over 25t stacks and then also get to material loss with 100t+
  12. And also we where spreading "misinformation" even here in this thread... this bug has nothing to do directly with conveyor belts (at least according to my current theory ). --- I was thinking a bit about this bug because as mentioned few posts earlier I noticed this temperature reset first when dupe was picking 1kg vitamin to eat (nothing to do with conveyors). So my suspicious was that this bug is not with conveyors but with splitting existing mass and creating new chunk. (like conveyour loader does when making 20kg packets) To test it I made 20kg hot barbeque and set fridge to limit 19kg and as you can see those 19kg because they where created from original 20kg are now (already in sweeper arm) reset to 19.9C In other words this bug is happening in most people bases every single cycle when dupes are picking their food to eat. No matter if from storage (fridge or ration box) or from food pile on the ground. What they pick to eat has 19.9C
  13. And there are still quite a lot of bugs. And many 100% reproducible and reported months ago. I already stopped reporting new. Next step is change forum name to Fixbugfixbug or something like that...
  14. To me it seems you need to put inside loader more then one packet (usually 20kg) at once and then only last packet has correct temperature. Here I used 41kg hot meat. Result is 2x 20kg reset to 19.9C and only last 1kg had correct original temperature.
  15. You are correct. Fridge doesn't reset temperature to 20. I thought there was maybe some fix since this thread: https://forums.kleientertainment.com/forums/topic/109015-the-chill-pill-3000-aka-the-planet-freezer/ But I didn't play 2 months ago and can't compare source code and see if there was fix for fridges. --- However when I spawned dupe and he was eating one pill I noticed it was reset to 20 before eaten. So I tried sweeper and sweeper to fridge did no reset but sweeper to conveyor belt is where it sets temperature to 20. No fridges needed just conveyors.
  16. I was trying 100 dreckos to see what is the FPS difference on my PC between one tile or 3 tiles I use for them. There was not much (if any) but when I hold mouse over those 100 dreckos... minus 30 FPS despite 97% of those tooltips where off-screen.
  17. I think in 364722 (about a week ago) was added this new "Uptime" information under Properties. That might be the reason for that save file size increase. However it should not be kept in save file backwards for more then 10 cycles and only for buildings where it makes sense.
  18. Because it's show this data is also kept in memory, and I hardly can play anymore, because my game keeps crashing because I'm hitting my system RAM limit. That was a sarcasm, maybe I should use "quick" in quotes...
  19. I really doubt that they could even try to simulate whole game cycle within few seconds because of replays... I think replay feature is just series of png images saved in directory RetiredColonies. First that directory was inside save_files dir and about 3 weeks ago they changed it to get more stable zoom and view and also moved RetiredColonies to same dir level as save_files. Also I checked the code and this feature (saving active/inactive operational times) was added recently in version 364722. Probably something for more detailed graph statistics but a bit overkill? Before it had specifically set [SkipSaveFileSerialization] flag but probably saving is quick enough so why not to add more data...
  20. Can't groom pups?

    Babies can't be groomed. They don't need to be.
  21. [Need Help] automation

    Thanks for that link I didn't know about it so I tried it and it is still true. Both oil and petroleum are colder with stairs going to the right.
  22. Exact time to spawn that monster is 2 cycles = 1200 seconds public float monsterSpawnTime = 1200f;
  23. [Need Help] automation

    That door bellow metal tiles to stop overheating oil/petrol will be surrounded by insulation to make vacuum when open, or not? If you leave it open like on the picture and also those hot diamond tiles it would heat gases around a lot. I think I need less gold for stairs version and it fitted better to my area. I did no calculations and just used what room I had (16 stairs) and yes I think petroleum will be a bit hotter then starting oil at the end.