Jump to content

Consolidation thread for reports relating to performance degradation after launching rockets


Recommended Posts

This will be a thread for players to submit reports and gather evidence relating to the massive performance degradation that typically occurs when players start launching rockets. A number of players have already posted about this issue and one user, u/aresd, surmised that the cause of the problem is the way temperature is calculated, especially since the launch of a rocket creates a lot of changes in temperature due to all of the exhaust. This is his report:

 

Quote

I think I discovered a problem. The bottleneck of the game is the exchange of temperatures. A sharp loss and swallowing of frames occurs after the launch and landing of a rocket. When the steam is still there, but the heat transfer is no longer hyperactive, I see 60 frames again :o

it seems to me that frame loss is higher during volcanic eruptions and lower during sleep. This must be verified empirically.

https://youtu.be/C3-gmkMIkqE

do not pay attention to the initial problems with the frames. I have network storage, the hard drives from all computers are in another room and are connected via fiber optic cable in order to combat noise from HDD. So some initial loading due to the slower network channel is present in all games. Watch from the second minute and you see 60 frames. After the rocket is launched, it takes 9-10 minutes and the game chokes for a very long time.

But haven't the developers announced a couple of months earlier about the change in the temperature calculation?

Another player already submitted a bug report here:

https://forums.kleientertainment.com/klei-bug-tracker/oni/fps-drops-and-stutters-for-no-reason-r21162/

This is a serious and urgent issue as it is currently making the game very stuttery and laggy after reaching the rocket stage, and rockets comprise 25% of the total game. 

 

To quote myself:

 

Quote

This type of performance degradation never occurred before the beta for the launch update. I've been playing the game since rockets came out (and before that as well) and the FPS loss that is happening now when launching rockets was not a thing before launch. 

It's a relatively easy issue to reproduce at least. 

1. Launch a rocket, preferably steam since I think the issue is more apparent with steam rockets.

2. If your game was running at a steady FPS, then expect FPS to drop and performance to become much more stuttery. 

3. Reload the save file after launching the rocket (keep in mind there's currently another bug involving a memory leak where each successive reload will increase the game's RAM usage until you're maxed out and the game crashes, hooray!). Performance will magically rebound and be normal again. That is, until you launch another rocket.

Note how I use the word stuttery. This does not simply equate to a drop in FPS. This equates to a drop in FPS and a jerking in frames. An analogy would be running vs. walking. Running is 60 FPS, walking is 30. Stuttering is when you're running/walking but you trip every now and then. This is not normal performance for the game, and should be treated as a bug until rectified. 

Whatever is causing this performance loss, whether it be temperature calculations or something else, seriously needs to be addressed. I cannot believe the game runs worse in launch than it did in QoL Mk3; that is the antithesis of what a final release should be. 

Link to comment
Share on other sites

1 hour ago, Rebrait said:

A good test is to start a base and launch a rocket in the first cycle(sandbox of course)

You have not met the conditions when the colony develops. By your logic, I adopted a child when he was 18 years old without one day. What is the problem of his upbringing?

Link to comment
Share on other sites

For me, it's only when the rocket lands. When it launches I don't experience much fps drops. 

Also when the rocket lands, waiting for the memory leak to crash the game or reloading the world doesn't fix the fps issue for me. It fixes the fps for like a minute and then it starts stuttering again. Another thing to note is that when paused, the game is completely fine in frames. 

Link to comment
Share on other sites

1 minute ago, Vampenguin said:

I'm curious and can't check myself until later tonight. If you launch in the vacuum of space where the steam is lost to the void, does the stuttering go away?

I launched my rocket in space and it still causes it. Here's what it looks like. 

Screenshot (527).png

Link to comment
Share on other sites

12 minutes ago, Vampenguin said:

I'm curious and can't check myself until later tonight. If you launch in the vacuum of space where the steam is lost to the void, does the stuttering go away?

Nope. I always launch my rockets against the backdrop of space and it stutters. Reloading will cause the stuttering to go away, but only temporarily. 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...