Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Karooni

Shipwrecked bugs this patch - anyone find fixes?

Recommended Posts

Karooni    1

I've crashed probably 20+ times before day 80 on my recently created save (my first time playing SW). I've remade the save a few times at the start, uninstalling mods completely, and it's still crashing constantly.

Has anyone found any temp fixes?

So far the bugs that have been persistent besides the few random crashes have been:

-SGsnake.lua file error when encountering snakes from chopping trees/vines

-Insta crash (lua error) when turning on a boat lantern

-Not able to customize new worlds. You're able to switch the settings when creating a world but they don't register when you're ingame

-Boat repair kit not existing in the crafting menu (TEMP fix!! You can still spawn them in console)

-Just random crashes when sailing (game just instantly closes, no "lua error" screen)

 

Has anyone found any way to get around some of the bugs? perhaps messing with the files and such.. I've tried uninstalling the hamlet DLC and it didn't seem to fix anything.

!!PLEASE NOTE!! that all of these bugs have indeed been listed on the Bug Tracker forum, but what I'm asking in this thread is workarounds for them.

Share this post


Link to post
Share on other sites

Just be patient. Those bugs are almost certainly due to the Hamlet DLC, but the Klei devs seem to be aware of them and are still cultivating fixes.

For instance, the Boat Lantern bug was patched about an hour ago, along with a multitude of other crashes:

 

Share this post


Link to post
Share on other sites