Jump to content

How does the Auto-Wrangling works actually?


Recommended Posts

I am trying in my new base to setup my hatch ranches so I can drown any excess and get some yummy meat. But, to do so, it means that when my other stables are too full that I must move the hatch from stable A to stable B. For that, I though I would use the auto-wrangle option on the drop-off, setting the limit to 8 since 10 is the maximum for a stable of 96 tiles (for hatch at least).

But right now, I have a room with 6 hatch and 4 eggs in it. It register as 10 in the room overlay and on the drop-off but the hatch are not moved. And because I am at 10 with the eggs, the 6 hatch are "expecting", so they will not lay new eggs.

What is wrong there? I have ranchers, the rooms are considered stables in the room overlay and the priority of the drop-off in the butchery is higher than the drop-off from the stable where I grow the hatch.

Any ideas?

Link to comment
Share on other sites

@Yannick Vachon I am pretty sure 8 is the maximum for hatches, unless that was changed. I will go look up the ONI Biology thread after this to confirm.

The room still counts eggs as "Critters" but the drop off does not until they are born. Once there is the limit in living critters they will wrangle them and take them to whichever stable has space and an assigned arrow.

Link to comment
Share on other sites

I'll have to run some tests in debug to see if the numbers have changed there for the max hatch in a stable.

But as for my initial question on auto-wrangling, if I understand you, this means that I should make sure to remove the eggs as they are dropped so they does not stop the hatches from dropping more while they incubate. Is that right?

Link to comment
Share on other sites

2 minutes ago, Yannick Vachon said:

I'll have to run some tests in debug to see if the numbers have changed there for the max hatch in a stable.

But as for my initial question on auto-wrangling, if I understand you, this means that I should make sure to remove the eggs as they are dropped so they does not stop the hatches from dropping more while they incubate. Is that right?

The best technique I've seen yet for any ranch, is to have a 'breeding' ranch set to, say, half population.  That ranch is simply to move your critters between ranches when they hatch to another ranch.  The second (and further) ranches you use as food stables.  Collect eggs from those ranches.  Use your hatchkill room.  Whatever.  Just setup the room so the critters can wander around but your dupes can't get to it, to protect your critter stock eggs from being dragged out of incubating naturally.

Link to comment
Share on other sites

Correct, lets say you have 8 hatches and that is the max the room can hold, if you clear the eggs as they are laid the hatches will continue to lay eggs because they are no longer expecting thus laying more eggs. The problem is that if you constantly do this then the critters will die off because none of those eggs will incubate

Link to comment
Share on other sites

So, I tried a few things and I do not see the behavior that I expect to see. So I turn again toward you all to help me understand, in case I missed something (or that I reached a limit of the game, which is also possible).

I've attached a picture of my current setup. And my current save file in case you want to try by yourself.

A: This is my auto-dropper for hatch eggs as I have found this somewhere else on this forum. Works perfectly and send all hatch eggs below.

B: This is my incubating area. Every night (with the clock sensor), the door open so the hatches can move back and forth while preventing duplicants from grabbing back the eggs.

C: In this zone, the drop-off is set to 0 and I have not checked the hatch in the list (does the same even if I check the option). And the auto-wrangle is selected and the is room in my other stables, not displayed on the picture. I also have plenty of ranchers and the priority of the task is at 6, where it is at 7 for the drop off in my other stables.

What is wrong with my setup? I would expect that when they see a hatch that they would automatically pick them up and either bring them to a stable with some space or to my drowning room (which has a priority of 5). So it should prioritize the stables, then the drowning room. Right now, no hatch is picked from room C at all.

 

Eggs.jpg

The Starving Spacepad.sav

Link to comment
Share on other sites

Actually, I found out what is going on. The auto-wrangling is working on full grown hatch but not on hatchling. Once they are grown, my rangers came to move them directly.

Guess I will go and file a bug report on this as the drop off let us say that we can select hatchling for a stable :)

I'm putting this here in case someone else is asking themselves what is going on with their stable.

Link to comment
Share on other sites

10 minutes ago, KittenIsAGeek said:

You have to chose the hatchlings as well as the hatches for autowrangling to include them. It isn't a bug; its a feature.  Basically you can keep a nursery if you like and remove all adults (or remove all babies).

No, I'm pretty sure its a bug as he said. I'm having the same issue, I saw auto wrangle work when I was using it before, but I designed a similar setup and it suddenly didnt work. Seems the autowrangle doesn't effect hatchlings the same way it does full grown hatches. At least I know whats up now, they won't starve before turning into hatches, so now I can just leave them there and they'll be moved to the drowning pool eventually.

Glad I read this thread to see I'm not the only one experiencing this.

It also means I now have FULLY automated hatcheries. I don't have to watch anything, the fish drop off has a lower priority than the critter drop offs in the stables, so if there is a spot free they fill it, if not.. he goes to Drown City.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...