Jump to content

Can't not display Chinese Characters well!


Recommended Posts

7 minutes ago, BingSlient2018 said:

I didn't use any mod, I just can see the any other language characters correctly except English....

 

16 hours ago, BingSlient2018 said:

 

displayChiChar.png

 

This is a mod, my friend. And if you are not using this mod then why would you put it in your original post?

Link to comment
Share on other sites

21 minutes ago, ItsPizzaTime said:

 

This is a mod, my friend. And if you are not using this mod then why would you put it in your original post?

But I didn't use the mod, I just use it to show that the game just can't show the correct characters of other languages except English. The problem must be with the game itself or something to do with my system setup, but can't figure out a solution...

Link to comment
Share on other sites

On 1/28/2018 at 4:09 AM, ItsPizzaTime said:

 

This is a mod, my friend. And if you are not using this mod then why would you put it in your original post?

He just gave another example with a second picture where the same glitch is occuring. On that picture somebody is using mods. He wrote that he has no mods installed. This is not difficult to understand.

 

Steam comes with its own fonts and libraries on Linux (aside from the system installed binaries, Steam puts everything it uses in the userspace under ~/.local/share/Steam). This is to ensure that when a game is run it will have all its dependencies satisfied. Sometimes this works okay, sometimes not so much. On occasions it's better to make Steam use the system installed libraries.

The problem could be related to Steam using a fonts that are being rendered in a strange way. You could try to make Steam use other fonts (run "Steam (Native)" instead of "Steam (Runtime)" in Arch Linux and it should use the system installed libraries instead).

Here is a good resource: https://wiki.archlinux.org/index.php/Steam/Troubleshooting#Text_is_corrupt_or_missing

(the general idea applies to Ubuntu as well; some font package could be missing, hence Steam uses its own glitchy fonts instead).

Link to comment
Share on other sites

3 hours ago, Captain_Rage said:

He just gave another example with a second picture where the same glitch is occuring. On that picture somebody is using mods. He wrote that he has no mods installed. This is not difficult to understand.

 

Steam comes with its own fonts and libraries on Linux (aside from the system installed binaries, Steam puts everything it uses in the userspace under ~/.local/share/Steam). This is to ensure that when a game is run it will have all its dependencies satisfied. Sometimes this works okay, sometimes not so much. On occasions it's better to make Steam use the system installed libraries.

The problem could be related to Steam using a fonts that are being rendered in a strange way. You could try to make Steam use other fonts (run "Steam (Native)" instead of "Steam (Runtime)" in Arch Linux and it should use the system installed libraries instead).

Here is a good resource: https://wiki.archlinux.org/index.php/Steam/Troubleshooting#Text_is_corrupt_or_missing

(the general idea applies to Ubuntu as well; some font package could be missing, hence Steam uses its own glitchy fonts instead).

I apologize that one of the pictures they had posted that clearly showed a list of mods with one of them being for chinese text had led me to believe he was using those mods, this is totally a mistake no one else would make clearly. (Even though other people had the same thoughts as I did).

 

Also since Ubuntu isn't a widely used operating system its obvious there must be something system side that is causing this discrepancy. "This is not difficult to understand".

I would love to help but I don't use that operating system.

Link to comment
Share on other sites

Can you query your package manager for 'ttf-' and 'fonts' and post the output? It will tell us which font packages you have installed.

On Ubuntu: apt-get --installed | grep -E 'ttf-|fonts'

On Arch Linux: pacman -Qs | grep -E 'ttf-|fonts'

 

I tried running Steam with both the native and runtime option on Arch Linux. Both options gave the same result. For me the Chinese characters show up as '?????', so I have never noticed this render issue.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...