Jump to content

Crashing with mods suddenly


Recommended Posts

This is the very first time I'm on a forum of some sort and I apologize for any trouble or misunderstandings I have or make.

 

I had some problems with mods in Don't Starve Together BETA lately and wanted to ask if anyone could tell me why. I get the feeling it's something very obvious, and tried googling it, but didn't find it. Again my apologies if it DOES exist or it is something real stupid, but I'd love to know what the problem is.

I started modding DST a while ago and played with some friends of mine. Because my computer is the fastest, I hosted the games. All of the mods worked fine together, did not interfere with each other, and I read about the issues each one could have. Smoothly all went like it should.

 

One day, when my friend had to leave, I continued playing to explore the area. I was attacked by Charlie (The one attacking you when you are in complete darkness) once, and since I had no means to survive her second attack, I decided to disconnect before she kills me, to later delete the server and set up a new one.

 

That's when the game crashed for the first time.

 

Ever since then, when I try to host a new server with mods applied, the game crashes right after I choose a character. Still, when I restart the game, a server exists, with the chosen settings, but with Wilson as character despite what character I chose. It crashes if I try to enter it.

 

There are no problems if I disable the mods.

 

I disabled certain mods and it worked again. Still, there were no updates on these mods, and they should work fine.

 

I tried certain things, like subscribing and downloading the mods again, deleting everything and downloading the game again, and other. Still nothing changed. But for my friends, everything works just perfectly fine, with the same combination of mods and same world settings and so on.

 

If you'd take your time helping me out a bit, I'd really appreciate it. I can't stop but thinking it's something really obvious I've messed up. 

Link to comment
Share on other sites

I've never been reading any logs, but I think this might be what happened. Hope I found the right passages. I should definitely learn to read them in future. 
 
It actually works again now. Still, I'd love to know what exactly happened
 
[00:09:06]: [Warning] Could not confirm port 10999 is open in the firewall. 
()
[00:09:06]: Could not load mod_config_data/modconfiguration_workshop-345692228
[00:09:06]: Loading mod: workshop-345692228 (Minimap HUD)
[00:09:06]: Could not load mod_config_data/modconfiguration_workshop-347079953
[00:09:06]: Loading mod: workshop-347079953 (Display food values)
etc. for all mods
 
[00:09:06]: Mod: workshop-347079953 (Display food values) Loading modworldgenmain.lua
[00:09:06]: Mod: workshop-347079953 (Display food values)  Mod had no modworldgenmain.lua. Skipping.
etc... for all mods
 
[00:09:07]: Mod: workshop-365119238 (SmartCrockPot) Loading modworldgenmain.lua
[00:09:07]: Mod: workshop-365119238 (SmartCrockPot)  Mod had no modworldgenmain.lua. Skipping.
[00:09:07]: Mod: workshop-347079953 (Display food values) Loading modworldgenmain.lua
[00:09:07]: Mod: workshop-347079953 (Display food values)  Mod had no modworldgenmain.lua. Skipping.
etc. same again
 
[00:09:08]: scripts/worldgen_main.lua(77,1) running worldgen_main.lua
Link to comment
Share on other sites

Yeah, that could be. Now that everything works fine with me, there are problems with my friend. When he spawns, he has an empty stomach, (said -1) no sanity and so on, and nothing helps even if she eats something. Is that a bug too?

Link to comment
Share on other sites

Yeah, that could be. Now that everything works fine with me, there are problems with my friend. When he spawns, he has an empty stomach, (said -1) no sanity and so on, and nothing helps even if she eats something. Is that a bug too?

Is your friend experiencing something like the image below?

post-474697-0-96207400-1422618595_thumb.

If so, that image I took occurred when my DST mod versions wasn't compatible with the host's DST mod versions. What I did to fix it, was:

  • Close DST
  • Verify Game Cache
  • Open DST
  • Make DST redownload all the mods I have and need that is required by the server host.
  • Rejoin the server.

Another thing could be with the auto-subscribing in the options, that seems to be quite buggy if its turned on. Sadly, I wouldn't know if that's the cause. So tell your friend to toggle it to see if it would help.

If that wasn't what happened to your friend then I'm sorry for not being much help. Good luck.

Link to comment
Share on other sites

  • Developer
Another thing could be with the auto-subscribing in the options, that seems to be quite buggy if its turned on.

 

Hey Zillvr, I'd love to hear more about issues with the auto-subscribe option if you have any more details. 

Link to comment
Share on other sites

Hey Zillvr, I'd love to hear more about issues with the auto-subscribe option if you have any more details.

Hmm, all that happened a month ago. I didn't report it since, I figured it was bugs that were specific to the mods themselves that caused the messed up UI. Oh and some of the servers had UI mods, sadly I forget which kind of UI mods they were. 

 

On one occasion back then was when I joined a server that had DST RoG Characters mod on that added Wigfrid and Webber and a lot of other mods I wasn't subscribed to originally. I had autosubcribe on and this happened. Unfortunately, I wasn't able to take note of the other mods they had active on that server. I could still move around and interact with the world.

post-474697-0-45134500-1422672017_thumb.
 

In another event that (I think) involved the autosubscribe bugging out was during the first week of your The Hunt Mod. I had Auto-Subscribe Mods on, and I saw The Hunt server was active so I jumped in letting the game download the mod for me. I was able to play normally for my first round but when the world regenerated when everyone has died the following graphical bug happened. It seemed like I was always on fire, even if I wasn't. I could move and interact with stuff and people, but all the world textures are messed up. It didn't happen again though, once I verified my game cache and let my mod list be redownloaded(and since joining the server auto subscribed me to The Hunt, that also was corrected.) Image below was what happened after dying for the first time after auto-subscribing to the mod.

post-474697-0-10259900-1422672978_thumb.
 

I just tried to recreate the first time I joined The Hunt Server wherein I completely removed The Hunt Mod (unsubscribing and deleting mod folders) then joining the server with Auto-Subscribed Mods turned on. But the graphical bug didn't happen even after dying multiple times.

Sadly, I cannot give any more details than that. Sorry for not reporting the bug I experienced with The Hunt Mod before, it got fixed as soon as I visited the Mods Page in-game and let the game verify all the mods I'm subscribed to. But if any of these happen again even with other servers, I'll be sure to take note of everything.

  • Like 1
Link to comment
Share on other sites

Is your friend experiencing something like the image below?

attachicon.gif2014-12-07_00004.jpg

If so, that image I took occurred when my DST mod versions wasn't compatible with the host's DST mod versions. What I did to fix it, was:

  • Close DST
  • Verify Game Cache
  • Open DST
  • Make DST redownload all the mods I have and need that is required by the server host.
  • Rejoin the server.

Another thing could be with the auto-subscribing in the options, that seems to be quite buggy if its turned on. Sadly, I wouldn't know if that's the cause. So tell your friend to toggle it to see if it would help.

If that wasn't what happened to your friend then I'm sorry for not being much help. Good luck.

 

Yes, she said this is what it looked like in the beginning. Now she is unable to move/randomly teleported around some places she walked/walking without doing anything, in circles, and she can't pick up stuff. Then, she describes how stuff is "glued" to her cursor.

 

Thank you for your advice) She is trying your suggestion right now.

 

To add, she has the slowest internet connection from us all, but we did not change the amount of mods or anything, and it worked for her as fine as for me.

Link to comment
Share on other sites

Now she is unable to move/randomly teleported around some places she walked/walking without doing anything, in circles, and she can't pick up stuff. Then, she describes how stuff is "glued" to her cursor.
 Those are all symptoms of lag. If she enters this on the console, she can get a more accurate view of what her character is doing on the server (and not get teleported around-- normally called "rubberbanding"), but she'll see the huge delay that the lag is actually causing:
ThePlayer:EnableMovementPrediction(false)
Link to comment
Share on other sites

Zillvr's suggestion did sadly not work. Though my friend says that this is exactly what she experienced at the beginning.

 

If I am right, she tried to install a mod which disables the movement prediction. I will ask her trying it with not the mod, but like you suggested later.

 

But basically, if I understood it right, I think she could check her router and her connection once more. It's shown that she has the same or even a better connection than our other friend, but she lives further away and in addition, her internet has been limited to only 1 hour per day.

 

I'm sorry, since  we are really inexperienced, but I'm interested in what you are saying, eager to solve anything that happens, and actually knowing why it did happen. I try to learn more about everything, not only problems with mods in DST.

I hope you can help me with this one too:

 

The other friend now is not able to connect. Though he is there and can be killed (from my POV) for him, his screen keeps loading. Later there were some crashes. I'll ask for the crash log later, he's at work right now. He thinks it's because 3 spider queens awakened near him, and there is a problem with the Spider blade DST mod. It might be, but I'm not sure. I realized that one tends to think a lot of bull**** that keeps one from seeing the real problem. As usual, I don't have any problems except that it's a pain to fight 3 of them queens at the same time with tons of yellow spiders and hounds coming with a tree guard lurking around.

 

Thank you so much for all your suggestions and explanations so far. This said, since you are rather experienced, maybe there is something very simple behind what we are fabricating? Like, my friend often forgets to update the mods, or to check if one mod has been disabled ore something,I always remind them to. 

Link to comment
Share on other sites

Like, my friend often forgets to update the mods, or to check if one mod has been disabled ore something,I always remind them to. 
 If he's joining you, that shouldn't matter-- it checks for versions when joining a server and downloads the new ones if needed. There might be a bug right now with the connection attempt timing out due to taking too long to download the mods, so if you have a ton of them going then your friend going to the mods menu to get them updated may help.
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...