Moonkis

[HOWTO] Enabling debug-commands

Recommended Posts

Gsom    1

I created a file debug_enable.txt on the root game-folder, but debug still doesn't work. Should this file be at the same folder with OxygenNotIncluded.exe or somewhere else?

UPD: problem solved

Edited by Gsom

Share this post


Link to post
Share on other sites
Mara1681    10

I put it to all sub-folders and it works in someone... I think it's the OxygenNotIncluded_Data, which should contain this file.

EDIT: If I will find out how to open some debug menu, then please write it down... thank you. ^.^

Edited by Mara1681

Share this post


Link to post
Share on other sites
Moonkis    127
2 hours ago, Mara1681 said:

Where do you find control-submenu? O.o

Under controls (Hit ESC in-game) and use the right-arrow at the top of the menu until Debug Controls.

  • Like 1

Share this post


Link to post
Share on other sites
Moonkis    127
2 hours ago, Mara1681 said:

I put it to all sub-folders and it works in someone... I think it's the OxygenNotIncluded_Data, which should contain this file.

EDIT: If I will find out how to open some debug menu, then please write it down... thank you. ^.^

Yes, I was hasty to write this down, but you are right, it's suppose to be placed inside " OxygenNotIncluded_Data" folder. Thanks, I updated the OP.

  • Like 1

Share this post


Link to post
Share on other sites
Mara1681    10

And if you guys find something useful, than say something. I already tried some debug things, but in 80% the game just crashed... xD

Share this post


Link to post
Share on other sites
Moonkis    127
5 hours ago, Mara1681 said:

I put it to all sub-folders and it works in someone... I think it's the OxygenNotIncluded_Data, which should contain this file.

EDIT: If I will find out how to open some debug menu, then please write it down... thank you. ^.^

Yeah, it might be possible to patch it with some IL-magic to make most of them work...maybe... I was quite bummed that removing FogOfWar didn't work :/

Share this post


Link to post
Share on other sites
Radje    21

Does any of you know if it's possible to spawn creatures? I can't seem to find out.

Share this post


Link to post
Share on other sites
dunny    20
13 hours ago, Radje said:

Does any of you know if it's possible to spawn creatures? I can't seem to find out.

I haven't found a way to spawn creatures but in the mobs.yaml you can change the weight with which creatures get spawned in the beginning.

It's somewhere under managed files.

Share this post


Link to post
Share on other sites
zaig    36

Fun stuff, I added "oxygen" and it spawned rocks "oxygen" ... LOL XD

Share this post


Link to post
Share on other sites
Doudomida    1

Doesnt work for me either. I've put the debug_enable.txt in the right folder and restarted the game but backspace still does nothing in-game.

  • Like 1

Share this post


Link to post
Share on other sites
SwagMemes    0
Posted (edited)

@Doudomida @Mr.Mistyi I had this same problem. The way I fixed it was by doing the following:

Delete the current debug_enable.txt you have
Open Notepad

Save-as inside notepad

navigate to where the debug_enable.txt should be (e.g. C:\Program Files (x86)\Steam\steamapps\common\OxygenNotIncluded\OxygenNotIncluded_Data) in the notepad save-as menu

Delete the .txt part off of the save as title, it should read "debug_enable"

Make sure "save as text file" is selected.

Hit save

Should work now!

EDIT:

The problem for me was that I used File Explorer to create the empty .txt file, but for some reason the game doesn't respect it when its made like that. When I made a new text file in notepad it worked.

Edited by SwagMemes

Share this post


Link to post
Share on other sites
AlexRou    183
12 minutes ago, Pandelle said:

The game crashes when I use this ?

When you add the file or do a command?

Share this post


Link to post
Share on other sites
Pandelle    5
14 minutes ago, AlexRou said:

When you add the file or do a command?

When I add the file

Share this post


Link to post
Share on other sites
RazZ.Naix    0

It worked for me...
Make sure you save the in the correct location with the correct name using notepad.

Share this post


Link to post
Share on other sites
Wyrinn    0

Sooo im confused. I have it enabled, says its in debug mode, can edit the buttons for said debug mode, but press them and nothing happens :( any thoughts?

Share this post


Link to post
Share on other sites
Ted n Emily    6
On 2/17/2017 at 1:59 AM, Moonkis said:

I haven't seen anyone post any information about this, so I thought I ought to make a post about it. For some reason the default "Backspace" doesn't enable debug-commands (is it just me?) but you can force the game to make all the commands available. This can easily be done by just creating a simple (empty) text-file inside the " OxygenNotIncluded_Data"-folder which is located at the root of the game-folder. The text-file needs to be named:


debug_enable.txt

Note: The ".txt" is the extension! The filename should be "debug_enable".

This allows you to use Debug-commands (A restart of the game is necessary). This is very useful for screen-shot purposes as you can disable all hud by pressing ALT + F1 in-game or unlock the camera so you can zoom further out. The Control-submenu is full of the commands, but please note that SOME of these commands will crash the game or just not work (Removing FogOfWar for example doesn't seem to work).

 

Thanks for posting that, I was wondering how to do that, I will give it a try !:)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now