Recommended Posts

kraken121    387

Please use this thread to post any bugs you find in the mod, this includes but is not limited too,

 

1. crashes

2. things not working as intended 

3. exploits

4. glitches

5. art problems

 

Please take a screen shot of the bug or crash screen. Please be as detailed as possible and try to explain exactly what happened to better ensure the bug gets fixed as soon as possible.

 

Thanks,

 

Krak

  • Like 1

Share this post


Link to post
Share on other sites
Minik435    49

Grammar error found:

Paladin  when choosing have writed:

1. *Blah blah*

2. Can use shEIlds

3. *Blah blah* 

4. *Blah blah*

Share this post


Link to post
Share on other sites
kraken121    387

Grammar error found:

Paladin  when choosing have writed:

1. *Blah blah*

2. Can use shEIlds

3. *Blah blah* 

4. *Blah blah*

haha will fix that, thanks

Share this post


Link to post
Share on other sites
Minik435    49

I tested in all ways digging hole/grave:

RoG - crash

No RoG - crash

RoG w/o mods - crash

W/o RoG and mods - crash

There is same bug as I reported on thread in mods and tools.

I hope it have been fixed.

Edited by Minik435

Share this post


Link to post
Share on other sites
soul    46

Did any1 else get this?? my file might not be up-to-date ... anyways...having lots of fun playing!!:D

orientation_zps5965a4e9.png

Share this post


Link to post
Share on other sites
DeathDisciple    291

gah, the north one happens because game load no-hat version on north idle animation - it is supposed to load hat-version and but it does just when you're moving. Wonder if spriter one suffers from the same issue... might just scale the 'hat' up a bit tho, being that it's smaller than common full hats.

Share this post


Link to post
Share on other sites

Is there a way to remake the side view so that it doesn't have the notch cut out for the goblins ear? But still have the ear cut out when equipped to the goblin.

 

Maybe it reads that png for the goblin and a different png when on the player?

Edited by Scalepelexis
added question

Share this post


Link to post
Share on other sites
kraken121    387

Did any1 else get this?? my file might not be up-to-date ... anyways...having lots of fun playing!! :grin:

orientation_zps5965a4e9.png

yeah, we will touch this up, glad ur enjoying it ;)

Share this post


Link to post
Share on other sites
soul    46

regarding the bug with graves...culprit can be "Dem Bones" ...it started working fine when i disabled this mod

Share this post


Link to post
Share on other sites
simplex    2,597

regarding the bug with graves...culprit can be "Dem Bones" ...it started working fine when i disabled this mod

Considering Dem Bones was written a long time ago, and the original author vanished, I'd say that's very likely the cause (or at least one of the causes). Especially since his mods did tend to override files, explaining the missing component under RoG :razz:.

Share this post


Link to post
Share on other sites
DeathDisciple    291

Oh, I ended up putting extra checks afterwards, but yeah if that thing is not ROG-compatible using it will cause other issues. Should prob put a warning somewhere about it.

Share this post


Link to post
Share on other sites
Minik435    49

regarding the bug with graves...culprit can be "Dem Bones" ...it started working fine when i disabled this mod

Yeah... I now know what was going on. Dem Bones were automatically on in mods and that was my mod from Hunger DS... BTW I used it only for hair :p

Now I'm only force enabling mods cuz Camp Cuisine does not works if not force enabled :(

Share this post


Link to post
Share on other sites
orian34    382

I was loading my pre0.0.4 save of HitD, all works well, fine! I pass one day, eat some honey nuggets, kill some pigs in my village and i hear hound barking(usual as possible)..so i run to my "eyefield" and wait to the barkings end...And BAM crash...So i think : 

 

1. Saves created before 0.0.4 does not includes the all new system of hound waves( orcs etc) so it creates desync and crash...

2. The whole new system of hound waves just bug...(for now!!!)

Share this post


Link to post
Share on other sites
DeathDisciple    291

I was loading my pre0.0.4 save of HitD, all works well, fine! I pass one day, eat some honey nuggets, kill some pigs in my village and i hear hound barking(usual as possible)..so i run to my "eyefield" and wait to the barkings end...And BAM crash...So i think : 

 

1. Saves created before 0.0.4 does not includes the all new system of hound waves( orcs etc) so it creates desync and crash...

2. The whole new system of hound waves just bug...(for now!!!)

I could use a log or a screenshot of an error, but I think it's 1. the old saves are missing the table I added on 0.04, we'll update with the potential fix in a sec.

Share this post


Link to post
Share on other sites
kraken121    387

I was loading my pre0.0.4 save of HitD, all works well, fine! I pass one day, eat some honey nuggets, kill some pigs in my village and i hear hound barking(usual as possible)..so i run to my "eyefield" and wait to the barkings end...And BAM crash...So i think : 

 

1. Saves created before 0.0.4 does not includes the all new system of hound waves( orcs etc) so it creates desync and crash...

2. The whole new system of hound waves just bug...(for now!!!)

Yeah, always try to provide a screen shot if you can ;)

Share this post


Link to post
Share on other sites
orian34    382

it's easily doable, when it crashes, it reload the day beforethe crash... OMG it's the Groundhog day!!!!

Share this post


Link to post
Share on other sites
soul    46

So I had this problem last time I played..since I don't have access to my comp if some1 can crosscheck it would be great.. In the new version, my game would crash as soon as I tried using pitchfork.

If I remember correctly it said pt/pl/pr nil value (1 of the 3 p's)

Edited by soul
  • Like 1

Share this post


Link to post
Share on other sites
kraken121    387

So I had this problem last time I played..since I don't have access to my comp if some1 can crosscheck it would be great.. In the new version, my game would crash as soon as I tried using pitchfork.

If I remember correctly it said pt/pl/pr nil value (1 of the 3 p's)

good catch, yeah pitchfork is crashing it, we will take a look at it ;)

Share this post


Link to post
Share on other sites
kraken121    387

So I had this problem last time I played..since I don't have access to my comp if some1 can crosscheck it would be great.. In the new version, my game would crash as soon as I tried using pitchfork.

If I remember correctly it said pt/pl/pr nil value (1 of the 3 p's)

seems its a conflict between UnA and HitD , Death is looking into it now.

 

 

seems it was our mistake after all,

Edited by kraken121

Share this post


Link to post
Share on other sites
simplex    2,597

good catch, yeah pitchfork is crashing it, we will take a look at it ;)

That's just a minor lapse, Death forgot to pass the self parameter to old_canterraformpoint in modmain.lua:1351.

@@ -1348,7 +1348,7 @@ AddClassPostConstruct("components/terraformer",function(self) local old_canterraformpoint=self.CanTerraformPoint function self:CanTerraformPoint(pt)-    if(old_canterraformpoint(pt))then+    if(old_canterraformpoint(self, pt))then         -- since it's blocking just hardcoded crap... one day I'll move this         local ground = GetWorld()         if ground then
And oh, HitD is crashing with Always On Status. The issue (which is on Always On Status' end) is that it adds a custom component to characters (the "switcher" component), but it does so by iterating through the character names (including modded ones, but only if they were added to MODCHARACTERLIST by then, i.e. if their mods run before Always On, which is not the case for HitD). This can be fixed on the HitD side (even though it should be fixed within Always On...) by attaching the "switcher" component if Always On is enabled via a player prefab postinit (as in modmain.lua:1365); a sim postinit would probably not work, since the HUD is initialized before it runs, so the crash would likely keep happening.

Two more tiny little details: the "inspectable" component is being added twice to prefabs/fa_bbq.lua, and the "activatable" component is being added twice to prefabs/fa_dungeon_entrance.lua.

  • Like 1

Share this post


Link to post
Share on other sites
DeathDisciple    291

seems its a conflict between UnA and HitD , Death is looking into it now.

 

 

seems it was our mistake after all,

This is what happens when 'someone' gets my first impression based on an error report he made with 100 mods active and hurries up to post it as a fact... His stack trace showed HitD terraformer override calling UA terraformer override calling main function, so the first guess was that perhaps those 2 somehow made a mess before I looked at the code itself.

 

Anyway, yeah, what Simplex said above. I've cleared the extra components warnings earlier too, but they're not on live yet. Never really used Always On tbh, I'll have to look into that, thanks.

  • Like 1

Share this post


Link to post
Share on other sites
simplex    2,597

@DeathDisciple

As it turns out, Always On Status has different implementations for the forum download version and the Steam Workshop one... the switcher component is added (and required) by the Workshop version, but it doesn't even exist in the forum one. And they're both labeled as version 7.74, with no modinfo-based way of distinguishing between the two (except due to their description strings being different, but that's certainly not a reliable check).

So HitD is compatible with the forum version of Always On, and incompatible with the Workshop version. I suggest that, if Always On is enabled, you add the switched component within a pcall. That's what I'm doing in U&A for Winnie.

I don't get why Kiopho feels he has to split every mod he makes into so many different versions. He has 4 versions of Always On Status as a forum download (and the Workshop one is distinct from all 4, totalling 5 versions): one with bars, one with icons, one compatible with RPG HUD 55 and one compatible with RPG HUD 20-25. Something doesn't feel right when a modder has to publish several versions of his mod for compatibility with other mods himself wrote :razz:.

Edited by simplex
  • Like 1

Share this post


Link to post
Share on other sites
kraken121    387

This is what happens when 'someone' gets my first impression based on an error report he made with 100 mods active and hurries up to post it as a fact... His stack trace showed HitD terraformer override calling UA terraformer override calling main function, so the first guess was that perhaps those 2 somehow made a mess before I looked at the code itself.

 

Anyway, yeah, what Simplex said above. I've cleared the extra components warnings earlier too, but they're not on live yet. Never really used Always On tbh, I'll have to look into that, thanks.

love how 4 mods turns into 100 :D

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now