Jump to content

Where is my freaking rocket? (rocket parts missing)

  • Branch: Live Branch Version: Linux Pending

This is my rocket landing (only the capsule module has returned):


It was my first hydrogen rocket. But according to these stats, it couldn't go anywhere:



Thoughts on how it happened: I think it has to do with some rebuilding of pipes that lead to liquid fuel tanks. I did remove some of them and then built new ones and then the game crashed. I reloaded the game and repeated rebuilding without any crashes but after that, only when the rocket returned I saw it missing most of its parts.



Steps to Reproduce
Load the save file and see its landing in about a minute. I'm not sure how to actually repeat this issue. Maybe use a removal tool when the rocket is on its mission. Maybe remove pipes leading to fuel tanks and then rebuild them.

User Feedback

I am not sure, but since I started always deconstructing from the top and never replacing anything in the middle of a rocket, the issue seems to have vanished for me.

Share this comment

Link to comment
Share on other sites

the same issue for me. More, if you load the game when a rocket is on route the engine appears on the ground and only head module returns

Share this comment

Link to comment
Share on other sites

Agree with mpovas. I thought at start that I destroyed it but saw this bug so many times and it's maybe just a case when you delete it manually by mistake when it's out in the space but definitely there is something more problem with it. It makes the game closely unplayable and very annoying after I rebuilt my best base for a week in the night just to get rocketry.

If you reload the game it can lead to missing rocket engine and fuel tanks.
7.sav Load the game and  you will see it is allways failing at landing! Totally annoying. Nothing to do against it. And I did not rebuilt the pipelines around the rocket and did not rebuilt anything around the rockets! I am 100% sure about this.
Also note that this experiment does not repeatable every time. So if you do the same it depends on something else because sometimes after reload I get my rockets and sometimes the saved game end up like this without rocket. But if the reload ends up with missing rocket then it's repeatable from that saved game. (so some saved games allways end up in missing rocket situations others never ends up in missing rocket situation. It depends on the caracteristics of the saved game )

What I did not check yet maybe the rocket overheated during the travel and melted just we cannot see it and we only notice this after landing but I'm not sure just an idea (because I cannot check the heat of the rocket when it's out in the space. In previous releases I could click on the rocket's place when it was out in the space and I saw it was almost at melting point but at this time I cannot check it like this).


Also there is this bug that if you reload a game and after that your rocket lands and the rocket and fuel tanks are not missing then those are filled with the fuel (oxygen,petroleum,steam whatever) is still there after the travel. So something is definitely totally wrong around this.



I noticed earlier what the others are talking about. You could destroy your own rocket when it's out of the space you could destructe it. I don't know is this bug still in the game or it's already fixet.



There was this bug previously (now I did not meet with it but I don't know is it fixed already or not). If your rocket is on travel (out in the space) and you reload the game during the travel than the rocket become touchable. So you still cannot see it but you can click on it and you can destroy it or check the properties (like melting point).



If your duplicant sits into the rocket then you cannot make him leave the rocket! It can be annoying. So for example your rocket went for a travel, then it comes back, lands, everything fine. The dupes jumps out from the rocket but because he is assigned to this rocket he is running back and sits into the rocket again (imidiatly just after landing). And at this time when it's again in the rocket you cannot make him leave. Or actually there is 1 workaround. If you have 1 more astronaut you can assign him to the rocket that will make the other astronaut to fall out from the rocket then you unassign the new astronaut from the rocket and that's how you can get back your workers and emptying the dupes from the rocket.

Edited by CoNq

Share this comment

Link to comment
Share on other sites

For me it happened for the first time when i launched the rocket to the organic planet (with moos) and/or used the bio cargo bay for the first time.

Previously i was rebuilding rocket parts in random order many times and it was fine.

Here's my save before landing, just in case it helps.


Share this comment

Link to comment
Share on other sites

Had the same: Petroleum Engine, 3 Liquid Tanks, 1 Oxidizer Tank, 4 Research Modules and a Command Capsule. Only the Research Modules and the Command Capsule landed, the rest is missing :(

Share this comment

Link to comment
Share on other sites

Just had the same problem.  Only the capsule came down.


It was my first petrol rocket.  Since it was going 30KM I saved the game and quit before it landed.  I also replaced the petrol pipes with insulated pipes while it was gone.


Edit:  Tried reloading the save twice.  Capsule still came down by itself, I even tried deconstructing all the pipe.

Edited by LookingForBaal

Share this comment

Link to comment
Share on other sites

I am more and more sure that this has to do with pipes removal. This third time I have marked some pipes for removal and then cancelled that order. These pipes were behind hydrogen engine and some of them were nearby. None of these pipes were connected to either fuel nor oxidizer tanks. Removal tool were used explicitly on pipes overlay.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...