Jump to content

Random crashes / buggy sounds

  • Branch: Live Branch Version: Windows Pending

Note: this applies to the Linux version as well.

Full story: I was playing the game when I read the announcement for the last update 399948. So I save the game, exit to desktop, restart ONI, Steam applies updates, I load the savefile. I immediately hear glitchy sound effects. I keep playing, after a while the game freezes. I'm unable to switch to desktop, run task manager etc. Power cycle the pc, relaunch game. Still sound problems, this time I can play for longer, but it the end, still freezes. Next boot, I try a local file integrity check on steam. All fine. Launch the game, almost immediate freeze.

I switch to Linux (Fedora 31 w Lutris). I've played in the past, the game works perfectly, just the mouse has a small annoying delay so I prefer to play on Windows. But I know it used to work, I could even copy savefiles back and forth between OSes. So Steam starts, it updates the game, game runs. Same glitchy sounds. And after a bit, it freezes. Frankly I haven't tried connecting via network on my Linux box, so I can't confirm is a solid system freeze or just the graphics. Now, this has to be related to the last patch. Anyway the behavior is exactly the same on Windows and Linux. I can't access the desktop, on Linux not even virtual consoles. I've tried many time, it always happens. Mouse and keyboard completely unresponsive. But, in some cases, I can still hear ONI music playing.

Anyway, I reboot Windows and watch some videos on YT (no sound problems, all is working fine) and call it a night.

This morning I try again. It freezes 5 minutes in the game. So not temperature related even. Then I disable all MODs and try again. Same effect. The attached logfile is from the unmodded session. Needless to say unfortunately the game is unplayable in this state.


Steps to Reproduce
Sound glitches are rather easy... All I have to do is drag a dig command on a large area. Or even, just zoom in on my hatches ranches, and do nothing. I hear metallic sounds, squeaks, and so on. Freezes are completely random. Most of the times happen within 5-10 minutes.

User Feedback

Savefile attached.

A few tests I've run:

- setting master volume to 0 has no effect (still freezes);

- disabling all audio devices in windows has no effect; that makes me think audio problems are more of a symptom than the cause;

- a quite reproduceable way to cause the freeze is to zoom in (yes in) hold the right button and quickly move around; that pointed me towards graphics;

- reducing the resolution and playing in windowed mode (not fullscreen) does reduce the problem a lot: I was able to play fow a while in 1600x900 (down from fullscreen 1920x1080) w/o freezes. I can still hear sound glitches but they are rare (minutes apart) and isolated. AFAIK that could have been present before, it's barely noticeable now.

Tomorrow I'll try other combinations, maybe 1600x900 fullscreen.

No Mealwood Included Cycle 44.sav

Share this comment

Link to comment
Share on other sites


- today I've played a lot 1600x900 windowed, no issues at all. Quite a few hours overall. In the middle of a session, I saved then switched to fullscreen. Almost instant freeze.

- so I also tried your suggestion, 1920x1080 fullscreen with low res textures... well, definitely a lot of sound glitches, but I wasn't able to freeze the game... for 10-15 mins. Then I paused the game, went to grab something to eat, when I was back, say 15 mins later, the PC was frozen.

I know, it froze while paused with me not even looking at the PC. So far my theory was fullscreen mode is more taxing on GPU since the update (well not that it makes 100% sense, but still). This time it wasn't doing anything tho.

- I've tried 1600x900 fullscreen low res texture. Some sound glitches, but it took more than one hour before freezing. Logfile for this session attached. (And thank God this platform saves draft posts 'cause I was writing this when the PC froze)


Share this comment

Link to comment
Share on other sites

Question: is there a way to revert 399948 for my installation? Maybe go back to 399090. I'd like to make sure it's 399948. I'm quite sure nothing happened on my system(s), and definitely not the same thing happened to Windows and Linux at the same time. But still I'd like to be 100% sure it's something in 399948 specifically.

Share this comment

Link to comment
Share on other sites

Update: bad news. Yesterday I wasn't able to play even at 1600x900, windowed, low res. Tried 3 times, I wasn't able to complete a cycle. Even more strangely, the first time I wasn't even going to play I was just checking the ages of the hatches in my stables for a discussion I was having on reddit. I loaded the savefile, and didn't unpause the game. I was looking at critters' age and it froze. I'm back to square zero. Being able to play the game is just a matter of luck, sometimes it freezes, sometimes it doesn't. All I can do is lowering the chances of freezing.

Look guys. I've been a software developer and a system administrator for years. I've processed hundreds of bug reports. I'm 100% aware that this kind of report is a nightmare. I'm fully aware it's close to useless... something clearly you can't reproduce (since I'm doing nothing different from what everybody else is doing).

If it wasn't for the Linux thing, I'd dismiss this as a problem with my OS. Something related to Windows/Nvidia drivers combination. Who knows? But it can't be a coincidence the behaviour is exaclty the same with a completely different OS and drivers.

So far most of the attempts were on Windows. I'll try on Linux and see if I manage to inspect what's going on during a freeze, assuming I can still connect via network.

If I'm unable to solve the issue, I might have to let go of the game, since it's unplayable now. Just let me say that as a customer I'm 100% satisfied, I've put 1700 hours into the game, it's more entertainment/value than I could have ever expected. Good job guys, I'll always be a fan.

Share this comment

Link to comment
Share on other sites

Hey @TheMule, thanks for keeping us updated!

First, some catch-up: both of the sound designers have loaded up the save in case it's a sound issue. We've both been unable to reproduce it in any circumstance, which you've already spoken to! We did some profiling on our audio middleware and tried to identify if there was anything on the sound side which might cause this, and we couldn't find much... however, we did identify some general optimizations that could be made using your save so we've done those. It's unlikely this would help your situation at all, though.

It's extreeeemely bizarre to me that the issue appeared even when unpausing, actually -- that leads me to believe solidly that sound isn't the issue, but just a knock-on symptom.

I'm going to take a look now at our other profiling tool to see if anything obvious jumps out. I just wanted to touch base with you to make sure you knew someone was looking into this and you weren't being left for dead!

I also wanted to explicitly say thank you for being so understanding in your report -- it's extremely appreciated! I would have for you to have to stop playing because of this, though I'm sure I speak for our whole team when I say how glad we are that you've gotten good entertainment and value out of it :)

I'll let you know what I find tomorrow!

  • Thanks 2

Share this comment

Link to comment
Share on other sites

Hi again, a little update. And thank you for your kind words.

Story update:

since I can't play I figured out maybe I can help other people on forums and such.

So I find this guy with a bug, I download the savefile to try it, uh it's a 1700+ cycles base, this is going to insta-crash my game I think. Nope. It runs smoothly. Now I'm moving around with the mouse, trying to crash it. Nothing, no sound glitches, all is fine. Ok, I switch to 1920x1024 fullscreen, the original game killer. Nope. Everything is fine. After 15 minutes I gave up, I wasn't able to crash it.

So, new theory. Something wrong with my savefile. So, I load a very old base of mine: crash.

Ok, let's disable all mods, and create a 'clean' game from the start. And here comes the fun. Sound glitches, game freezes. At the dup selection screen, while I was rerolling them. Yup. But there's more.

I've found that ONI affects sounds in general. Meaning, if I have a youtube video playing in the background, ONI create glitches in its sound too. Also, if I have ONI paused, and Alt-TAB out of it (of course if it's windowed I just click and maximize another window), and watch a youtube video, I hear sound glitches. Once it froze my PC. Yes, just by having the game paused in the background, during the dup reroll phase.

I need to stress that nothing of this happens if ONI is not running.

And all this starts with 399948. Before that I used to have ONI paused in the background almost all day. I used to do something else, and switch to ONI during breaks. I've been doing this for months, perfectly stable.

I also tried with ONI in the main menu screen. That does not seem to create problems. Yesterday I've spent the whole day with ONI in the background in the main menu, w/o problems. Problems start when a map is loaded, or created.

As far as sound glitches, I'm convinced they are just a symptom. Chances are the video card is messing with my system, causing hiccups of some sort. 


Is there any way for me to try build 399090 please? I'd like to make sure this is strictly related to 399948 and nothing else. TIA.

Share this comment

Link to comment
Share on other sites

16 hours ago, TheMule said:


...could just be my tin foil hat acting up, but do you mind running a virus scan? It could just be paranoia, but it does sound like something fishy's going on under the hood. :wilson_curious:

Share this comment

Link to comment
Share on other sites

I do on a regular basis. But as far as I'm concern, the fact it has exactly the same behaviour under Linux, which btw shares no files with Windows (I'm not sharing files between game installations, they're on separate disks) makes it an extremely unlikely explanation.

As for something fishy going on, I totally agree. This looks like more a hardware problem, something that makes the video card go nuts. The drivers of course are completely different, on Linux I have the opensource ones and on Windows the official ones the Nvidia Experience keeps up to date. I believe the game's doing something perfectly fine but my card doesn't like it.

The reason why I asked for the opportunity to run build 399090 is exaclty to rule out a software problem. It might be that some something broke for whatever reason in my hardware (or made it unstable) and update 399948 was released that day by coincidence. If I can try build 399090 which used to run perfectly fine and it has problems now, then I can close this bug report on the spot.

Share this comment

Link to comment
Share on other sites

Hey, sorry for the delayed response -- I came down with some sort of sickness and I was focusing on resting just to be safe!

Separately, Ruby and I both took a look at your save and profiled it last time I spoke with you, and couldn't find anything out of the ordinary.

Would you mind uploading a dxdiag? Particularly I'm interested in what your audio hardware/settings are like... sometimes FMOD has had issues with certain audio devices or audio software, but those issues have never appeared like this. It would be good to rule it out, though. Would you happen to run any 3rd party audio software?

I don't personally know of any way you can try that old build right now but I will poke around.


Okay, I did some Googlin', found this method, and filled in the relevant parameters for ya. If you want to test with an old build and see if it's actually coincidental and is a hardware issue:

1. Open the Steam console: steam://nav/console

2. Type download_depot 457140 457141 2245769287204349857

I would definitely back up any saves that you care about before doing anything here, though. Also, any saves from the current build will, of course, not load in this older build. Proceed with caution and lemme know if you uncover anything!]

Share this comment

Link to comment
Share on other sites

One thought that jumps to mind given the audio involvement you mention is maybe a shared interrupt? Could you send an lspci -vv (from linux)?

  • Thanks 1

Share this comment

Link to comment
Share on other sites

Hi, sorry not keeping you posted... 

tl;dr It was faulty hardware. Case closed.

If you're curious, here's the full story.

I don't have many other games installed, and most of them are rather old. So I did try them and they ran regularly.

One game I tried later is Cities: Skylines. And it did crash (not freeze the PC tho). It reports ram allocation during startup and suspiciouly it crashed exactly at 8GB, always.

Now, I upgrated from 8GB to 24GB some months ago and the modules have slightly different speed. I also remembered the old server room saying, "when in doubt, shuffle RAM modules". Surprisingly, it works. And it worked this time too. Well actually I removed the old 8GB.

Anyway I played ONI successfully for about 3 days and was about to post here when it struck again. Back to square one.

This time I kinda knew it had to do with hardware. I had inspected BIOS settings before but this time I managed to get it (it must be transient). There was a red indicator on my 3.3V line, which was 2.9V only.

So this time it tried and removed one of the extra fans (I have a few). Voltage back to 3.3V.

I've been playing regularly for a week now. Back to 24GB even. So my guess is:
- for some reason, my PC acted strangely when a GPU heavy appilication exceeds 8GB of RAM, possibly due to the PSU not been able to keep up, or other faulty component;

- most of my daily activities don't involve that

- neither do my old games. most of them run confortably under 8GB.

- maybe something changed in ONI that makes it (pre)allocate over 8GB sooner than it used to, before 399948.

Of course the behavior was the same under linux, as it has nothing to do with the OS.

Thank you again guys and sorry for the fuss.

  • Like 1

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...