Issues With Creating A Pre-Configured Dedicated Server


Recommended Posts

I've been trying to create a pre-configured dedicated server for DST so me and my friend could try out caves. However, even after following all the steps that were given, I couldn't get it to properly work. Random people were able to join, yet I couldn't find my own server. If anyone could help, it would be much appreciated.

Link to comment
Share on other sites

Hey @Zillvr, I am hosting on the same computer and network. However, no matter what I've tried to do I haven't even seen anything in the LAN servers. It does appear at http://dstservers.jacklul.com/ and I've talked to people on the server so I know for a fact it's up, yet I can't connect to my own server. Thanks again for your time and a quick reply.

Hey @ProfFarnsworth, thanks for the reply. I am indeed opted into the beta (have checked multiple times), and I have verified the integrity of the game a few times as well so I don't believe I've done anything wrong when following the steps presented by the Klei employee. But thanks again for a quick reply. I appreciate it.

Link to comment
Share on other sites

Hey @Zillvr, I am hosting on the same computer and network. However, no matter what I've tried to do I haven't even seen anything in the LAN servers. It does appear at http://dstservers.jacklul.com/ and I've talked to people on the server so I know for a fact it's up, yet I can't connect to my own server. Thanks again for your time and a quick reply.

Hey @ProfFarnsworth, thanks for the reply. I am indeed opted into the beta (have checked multiple times), and I have verified the integrity of the game a few times as well so I don't believe I've done anything wrong when following the steps presented by the Klei employee. But thanks again for a quick reply. I appreciate it.

 

The only reason I could see that happening is that the version of the server is not compatible with the version of your client. Check in jaklul's server list if your server is opted in the caves beta and what version it is. If you click your server in that list the version will appear or I think you can press one of the options in the popup to see your server version. Then go to your client and press backspace. The client version should appear on the bottom left of the screen. These should be the same.

Link to comment
Share on other sites

Like everyone has already mentioned, it's probably due to incompatible versions of the game client and the game dedicated server tools.

 

If your Don't Starve Together Dedicated Server Tools has the [cavesbeta] tag:

post-474697-0-35074400-1448432251.png

Then so should your Don't Starve Together Game:

post-474697-0-25521200-1448432258.png

 

Make sure these are alike, if your Don't Starve Together Dedicated Server Tools isn't opt into the cavesbeta and has no [cavesbeta] tag then so should your Don't Starve Together Game so the game can find the server. I hope that makes sense, cheers.

Link to comment
Share on other sites

Like everyone has already mentioned, it's probably due to incompatible versions of the game client and the game dedicated server tools.

 

If your Don't Starve Together Dedicated Server Tools has the [cavesbeta] tag:

attachicon.gifcavesbeta2.png

Then so should your Don't Starve Together Game:

attachicon.gifcavesbeta1.png

 

Make sure these are alike, if your Don't Starve Together Dedicated Server Tools isn't opt into the cavesbeta and has no [cavesbeta] tag then so should your Don't Starve Together Game so the game can find the server. I hope that makes sense, cheers.

Thank you everyone so much! I was pulling my hair out for 3 hours last night, and all because I totally forgot to think that maybe the dedicated server also needs to be opted into the beta. I'll tell ya I feel like quite the dunce right now, but oh well! I'm a dunce with a working server so thanks everyone!

Link to comment
Share on other sites

I have a problem as well, mine consists of the server crashing right after booting it up, it gives me an error of several spawns being incorrect or something, it only started happening to me after i tried to implement mods into the server, which is a big let down because installing mods seems to be the problem for my server, and if there are no mods that i usually play with the server will just feel bland, is there a way to make it so that i can play together with caves and friends without having the server crash on boot up? i have read the wiki's guide on starting one up, but the mod implementation part is what causes the crashing, and i followed the instructions perfectly, even played around with some files but that only brought me back to running a server without mods. Can someone explain to me why the wiki gives you a wrong set up? the comment section is full of people with the same issue as me, it only works without mods but with them the instructions only cause crashes.

 

please help me out too, making a dedicated server is a pain with mods.

Link to comment
Share on other sites

Hello @IvesTee, firstly welcome to the forums. Sadly, your issue is not related to this thread. I reckon your game crashes because of the mods you are trying to run may be conflicting with each other or they aren't all updated to work with the current build of DST. If you've seen my posts in this thread, try and toggle your mods one by one. Not all mods are fully updated by their creators so don't expect everything to work perfectly well in one go. If your first mod works, then add another mod to the active mods. Try and figure out which mod is acting up by looking through the log.txt file found under Documents/Klei/Yourservername. Report any errors you find to the mod creator and wait for them to patch their mods. Until then, continue dissecting your mod list and disabling mods that are causing problems.

 

I hope that helps, cheers.

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.