DarkXero

Solutions (host+client in same PC)

Recommended Posts

DarkXero    2,881

P:

"I hosted my server, other people can join it, but I can't see it!"

S:

a) Access your router's page

b) Disable (leave unchecked) any multicast filters you may have

 

e.g. In a WRT54G2 cisco linksys router, it's the -Filter multicast- in the security tab

 

 

P:

"I hosted my server, other people can join it, I can see it, but it gives me 'Try yelling louder?'"

S:

a) Access your router's page

b) Disable (leave unchecked) any NAT redirection filters you may have

 

e.g. In a WRT54G2 cisco linksys router, it's the -Filter NAT internet redirection- in the security tab

 

 

It's all in the routers, people!

 

EDIT:

 

The issue here is that when trying to connect to your external IP from inside your network, some routers won't be able to do this: http://wiki.mikrotik.com/wiki/Hairpin_NAT without help, therefore, you won't be able to see yourself, just as anybody else in your network won't be able to see your ONLINE game.

 

Without a hairpin, information gets lost and the game can't be seen/reached appropriately.

 

However, this can easily be solved by searching for LAN games. After you click Play!, you enter a server list of online games. You have to scroll all the way down the filters list and switch "Show LAN: No" to "Show LAN: Yes". That way, your client will search for local games using the internal IP and will communicate with them accordingly. http://imgur.com/rgYSWbh

Edited by DarkXero
  • Like 2

Share this post


Link to post
Share on other sites
Rayalan    7

I knew it had to do something with the routers, just couldn't put my finger on it! Haven't tried it though.

 

Share this post


Link to post
Share on other sites
mcadjo    3

Well, I can not find that option on either of the two routers i tested. But i managed to find another workaround, at least until guys from Klei mend this.

 

You can add your public address (one you see in http://my.jacklul.com/dstservers) as second address on your server NIC (internal network). But DarkXero is right, it is a router 'problem'.

Share this post


Link to post
Share on other sites
DarkXero    2,881

squisher00, I think checking Access Control in Firewall would do it, but you should try making a Special Application: with name = DST, type = both, trigger port = both on 10999, target port = both on 10999, interval = 50, IP Replacement = 127.0.0.1, 3rd host thing unchecked.

Share this post


Link to post
Share on other sites
Kzisor    1,057

@DarkXero, this doesn't always work for all routers/operating systems. Example: I have 2 computers 1 on Windows 7 and the other on Windows 8.1. The Windows 8.1 machine can connect without lag to their own hosted server as well as the one hosted from the other computer. The Windows 7 can connect to the other computers server, but not the one hosted on the same computer. 

  • Like 1

Share this post


Link to post
Share on other sites
DarkXero    2,881

Kzisor, I have Windows 7.

I think this happens if you have either an old router (I think mine is from 2008 or before), or windows 7 or old.

Share this post


Link to post
Share on other sites
squisher00    2

squisher00, I think checking Access Control in Firewall would do it, but you should try making a Special Application: with name = DST, type = both, trigger port = both on 10999, target port = both on 10999, interval = 50, IP Replacement = 127.0.0.1, 3rd host thing unchecked.

 

How are you getting to whatever screen has this "special application", "interval", and or "IP replacement"?  I'm seeing nothing in Windows Firewall that relates to that. 

Share this post


Link to post
Share on other sites
mcadjo    3

@squisher00 Go to your NIC properties page, Click IPv4 protocol -> Properties. On next page check 'Use the following IP address' then click Advanced. Add your two IP addresses (public and private ones). Add your public IP address with mask 255.255.255.255. That should do it. It's an easy and dirty workaround, i know, but it fools your clinet not to go outside of machine looking for server, and that exactly is a problem.

 

@darkxero I tested with Huawei HG530 and ZTE H367N ADSL/VDSL modems.

  • Like 2

Share this post


Link to post
Share on other sites
devoid    0

@squisher00 Go to your NIC properties page, Click IPv4 protocol -> Properties. On next page check 'Use the following IP address' then click Advanced. Add your two IP addresses (public and private ones). Add your public IP address with mask 255.255.255.255. That should do it. It's an easy and dirty workaround, i know, but it fools your clinet not to go outside of machine looking for server, and that exactly is a problem.

 

@darkxero I tested with Huawei HG530 and ZTE H367N ADSL/VDSL modems.

Just to be clear. This solution will work only if you have your dedi server launched from the same machine as client. If you have separate machine that runs server in that same LAN this solution isn't for you!

Share this post


Link to post
Share on other sites
mcadjo    3

Exactly. But then again probably you could do some with adding appropriate routes to another client. Haven't tested it to be honest.

Share this post


Link to post
Share on other sites
squisher00    2

@squisher00 Go to your NIC properties page, Click IPv4 protocol -> Properties. On next page check 'Use the following IP address' then click Advanced. Add your two IP addresses (public and private ones). Add your public IP address with mask 255.255.255.255. That should do it. It's an easy and dirty workaround, i know, but it fools your clinet not to go outside of machine looking for server, and that exactly is a problem.

 

It works!!!! Thank you thank you!!!

Share this post


Link to post
Share on other sites

@squisher00 Go to your NIC properties page, Click IPv4 protocol -> Properties. On next page check 'Use the following IP address' then click Advanced. Add your two IP addresses (public and private ones). Add your public IP address with mask 255.255.255.255. That should do it. It's an easy and dirty workaround, i know, but it fools your clinet not to go outside of machine looking for server, and that exactly is a problem.

 

@darkxero I tested with Huawei HG530 and ZTE H367N ADSL/VDSL modems.

 

I have done this but at the end windows says the DHCP needs to be enabled and it resets all the settings so that the ip address is retrieved automatically

Share this post


Link to post
Share on other sites
squisher00    2

Exactly. But then again probably you could do some with adding appropriate routes to another client. Haven't tested it to be honest.

 

This works too!  If connecting to another dedicated on your LAN, run cmd as administrator, then run:

 

route -p ADD 1.2.3.4 MASK 255.255.255.255 192.168.1.123

 

replacing 1.2.3.4 with your server's public IP and replacing 192.168.1.123 private IP.

  • Like 1

Share this post


Link to post
Share on other sites
squisher00    2

I have done this but at the end windows says the DHCP needs to be enabled and it resets all the settings so that the ip address is retrieved automatically

 

Don't use DHCP anywhere for your lan, not on your server, client, or router.  Private IPs should be static. 

Share this post


Link to post
Share on other sites
Kzisor    1,057

This works too!  If connecting to another dedicated on your LAN, run cmd as administrator, then run:

 

route -p ADD 1.2.3.4 MASK 255.255.255.255 192.168.1.123

 

replacing 1.2.3.4 with your server's public IP and replacing 192.168.1.123 private IP.

 

 

@squisher00 Go to your NIC properties page, Click IPv4 protocol -> Properties. On next page check 'Use the following IP address' then click Advanced. Add your two IP addresses (public and private ones). Add your public IP address with mask 255.255.255.255. That should do it. It's an easy and dirty workaround, i know, but it fools your clinet not to go outside of machine looking for server, and that exactly is a problem.

 

@darkxero I tested with Huawei HG530 and ZTE H367N ADSL/VDSL modems.

 

We need these added to the wiki for dedicated servers. SethR, maybe this will help you guys understand the issue with lag when connecting to a dedicated server from the same computer. The solution by mcadjo solved my issue completely.

Share this post


Link to post
Share on other sites

@squisher00 Go to your NIC properties page, Click IPv4 protocol -> Properties. On next page check 'Use the following IP address' then click Advanced. Add your two IP addresses (public and private ones). Add your public IP address with mask 255.255.255.255. That should do it. It's an easy and dirty workaround, i know, but it fools your clinet not to go outside of machine looking for server, and that exactly is a problem.

 

@darkxero I tested with Huawei HG530 and ZTE H367N ADSL/VDSL modems.

 

Awesome, it works for me too. I had checked the validate upon exit and the troubleshooter popped up saying the DHCP needed to be enabled but all is well after pressing skip instead of fix.

Share this post


Link to post
Share on other sites
DarkXero    2,881

These solutions are great. Better than tinkering with the router and its security.

 

In my router, disabling multicast and that nat redirection filtering allowed the client to reach the server instead of getting blocked by the router because it apparently gets pissy with that type of communications. I tried using similar commands to make my computer do the same but they didn't work because I'm too much of a dunce regarding networks, I have no idea what a net mask is.

 

I'm glad somebody with more advanced ideas showed up. :highly_amused:

 

 

Share this post


Link to post
Share on other sites
dungdodger    1

@squisher00 Go to your NIC properties page, Click IPv4 protocol -> Properties. On next page check 'Use the following IP address' then click Advanced. Add your two IP addresses (public and private ones). Add your public IP address with mask 255.255.255.255. That should do it. It's an easy and dirty workaround, i know, but it fools your clinet not to go outside of machine looking for server, and that exactly is a problem.

 

@darkxero I tested with Huawei HG530 and ZTE H367N ADSL/VDSL modems.

 

 

This works too!  If connecting to another dedicated on your LAN, run cmd as administrator, then run:

 

route -p ADD 1.2.3.4 MASK 255.255.255.255 192.168.1.123

 

replacing 1.2.3.4 with your server's public IP and replacing 192.168.1.123 private IP.

 Okay i'm  confused now last night i used the top fix quoted and it work right away now at home on my network the server isn't showing for me. the main thing that i remember was when i started the server it was on port 10998. I thought i ran it from the folder not steam. i read somewhere that if u run the server from steam and the client from steam it will not show up in the server list but every time i try to run from the folder it will only load in the default location with port 10999 is this correct???  and somehow last night when i ran both from steam it let me see it???   I have also tried to change the Client to launch from another folder and use port 10998 so when i run the server from the folder it will use 10999 and default folder, and the game runs on 10998 with custom folder. iv ran it on laptop just like i did last night and on desktop cant seem to get it to show again.    

  

Is there a way to run the server from the folders exe and have it use the custom folder like it does when u use the launch options in steam????

Share this post


Link to post
Share on other sites
Ryuzo    0

@squisher00 Go to your NIC properties page, Click IPv4 protocol -> Properties. On next page check 'Use the following IP address' then click Advanced. Add your two IP addresses (public and private ones). Add your public IP address with mask 255.255.255.255. That should do it. It's an easy and dirty workaround, i know, but it fools your clinet not to go outside of machine looking for server, and that exactly is a problem.

 

@darkxero I tested with Huawei HG530 and ZTE H367N ADSL/VDSL modems.

when i do this, i lose access to internet  :frown-new: any solution to that?

Share this post


Link to post
Share on other sites
dungdodger    1

@Ryuzo, Try to use 8.8.8.8 for the DNS  thats what i had to do after turning off DHCP on router   Server is up seems to work fine with mods But i still cant see it on laptop win 7  or Desktop Win8.1   

 

 Question: IF this is working for Yall  Client And server on same PC are u running the Server from Steam and the Game or Server from Folder and Game from Steam???   

Share this post


Link to post
Share on other sites
Ryuzo    0

@Ryuzo, Try to use 8.8.8.8 for the DNS  thats what i had to do after turning off DHCP on router   Server is up seems to work fine with mods But i still cant see it on laptop win 7  or Desktop Win8.1   

 

 Question: IF this is working for Yall  Client And server on same PC are u running the Server from Steam and the Game or Server from Folder and Game from Steam???   

dosent work still not access to internet when i do that

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now