Jump to content

Change world settings after the world is already generated?


Recommended Posts

Let's say that right now I'm not liking being visited by 10 hounds every 3 days (world was created with hounds on default setting, so it escalates to crazy after 100 days).


There is any way to change the setting without directly editing components/hounded.lua?


I saw that the custom world settings are applied here (gamelogic.lua):

		if ground.topology.overrides ~= nil and ground.topology.overrides ~= nil and GetTableSize(ground.topology.overrides) > 0 then						for area, overrides in pairs(ground.topology.overrides) do					for i,override in ipairs(overrides) do						if retune.OVERRIDES[override[1]] ~= nil then						retune.OVERRIDES[override[1]].doit(override[2])					end				end			end		end

How to add the hounds setting to it?

Link to comment
Share on other sites

I don't think you can without screwing up the game.

If you're on day 100, you should have a bunch of hounds teeth. Go a little ways away from your base and build a firepit (both if your on RoG) and surround it with tooth traps. Once you have a bunch, place more near areas you go to most. If your close to Beefalo, lure them over there. I know it gets annoying constantly having to deal with hounds, but there are ways to deal with them.

This is probably not the answer you were looking for, so sorry about that!

Link to comment
Share on other sites

Let me know if it worked for you.


Worked perfectly! Thank you.


Any way to make this work only on a given saved game?


I will check the scripting tutorials to see how to build an UI, probably having these options inside the game would be interesting.


Link to comment
Share on other sites

Hey there, i'm having a similar problem with wildfires (RoG DLC).

I don't want my base spontaniously combusting. I've had it once, fortunately immediately after i made a backup, and i dont want it to happen again.

Is there any way to disable them mid-game, maybe with a modification similar to_Q_'s?


Link to comment
Share on other sites

The only thing that controls the wildfires is the variable: TUNING.WILDFIRE_THRESHOLD, which, when the option is set to never, is equals to -1.



So if you can change the code @_Q_ posted to change the variable value to -1 it should work, but I cannot test it right now.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...