Are the Lightning Rods working? Adventure Mode o.O


Recommended Posts

Kind of an odd observation I made yesterday while playing Adventure Mode -> A Cold Reception.

 

It rains all the time on this map and as a precaution I always build a Lightning Rod as soon as I get my base set up.   Despite playing for over 4 hours yesterday, there wasn't a single bolt of lightning that hit the rod the entire time.  I'd even hear the lightning striking somewhere very close by, but whereas before installing RoG it would pretty much was always guaranteed to hit the Lightning Rod, yesterday it never hit it not even once. 

It's not really an obvious thing to notice, since I tend to usually just forget about lightning once I build a rod, but I noticed it never getting hit last night and didn't stop paying attention to it the entire time I played.

 

Anyways, just wondering if it's just a weird streak of luck or if thunder strikes are disabled on this map or is there some kind of new bug where Lightning Rods aren't getting struck anymore (at least in adventure mode)?   o.O

Link to comment
Share on other sites

Well that's what I mean. I would hear the sound of lightning striking, but it wouldnt hit the rod even though I'm literally standing next to it. The rod would not be activated afterwards either. 

I'm gonna record some footage when I get home today if it keeps happening :p

Link to comment
Share on other sites

Actually I'm 100% positive now my game must be bugged for some reason.

A Cold Reception is supposed to have raining frogs. It hasn't rained frogs once and it's Day 32. On top of that, lightning simply isn't striking the lightning rod or anywhere near me, even though I hear the sound.


I have two mods turned on, the rocklobster fix and the one that adds icons to my map.  I have a feeling the rocklobster fix is what is causing the problems since it limits the spawning of stuff, so maybe it's having a weird effect in adventure mode? I don't know but it's really odd. o.O   Also I never had summer heat happen to me and I started in Archipelago for the first world, and reading the wiki tells me that's what I should have had to deal with 60 days of summer on that map. Haven't experienced a single Giant attack either. So odd.

Turning off the rock lobster fix mod for now....

Link to comment
Share on other sites

Actually I'm 100% positive now my game must be bugged for some reason.

A Cold Reception is supposed to have raining frogs. It hasn't rained frogs once and it's Day 32. On top of that, lightning simply isn't striking the lightning rod or anywhere near me, even though I hear the sound.

I have two mods turned on, the rocklobster fix and the one that adds icons to my map.  I have a feeling the rocklobster fix is what is causing the problems since it limits the spawning of stuff, so maybe it's having a weird effect in adventure mode? I don't know but it's really odd. o.O   Also I never had summer heat happen to me and I started in Archipelago for the first world, and reading the wiki tells me that's what I should have had to deal with 60 days of summer on that map. Haven't experienced a single Giant attack either. So odd.

Turning off the rock lobster fix mod for now....

I've also been told the Mini-map mod messes up the advancement too. it seems for you though only the former one is causing problems. 

Link to comment
Share on other sites

Hey @Renz004, my RockyFix is affecting only Rock Lobsters, it isn't modifying anything other than that... Maybe it's just a bad luck ?

 

 

I don't know. I already finished beating Adventure mode and I'm 100% sure it was a bugged run for various reasons. No idea what caused it! lol. 

...thanks for making that mod tho! :D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.