Jump to content

40-50 FPS Lock


Recommended Posts

Hi guys.

I have a problem. FPS in my game jumps from 40-50 but the laptop may well give a stable 60. Netbook mode is disabled and enabling/disabling vertical sync does not help. Has anyone ever encountered such a problem?

Specifications:

AMD Ryzen 3200U With Vega 3

AMD Radeon 540X

RAM 6 GB DDR4

Wrote in the bugtracker. nothing yet.

P.S. Thanks to Google translate :p

Link to comment
Share on other sites

You need to be more specific

Which mods are you using ?(some like show me gives a lot of fps drop)

Do it always happens or only in certain areas?

background process?

Did you try to enable notebook mode and small textures to check if still hapening?

Did you tried with other games?

Do you updated you drivers?

You can try to verify local files via steam or complete reinstall the game

Link to comment
Share on other sites

2 hours ago, ArubaroBeefalo said:

You need to be more specific

Which mods are you using ?(some like show me gives a lot of fps drop)

Do it always happens or only in certain areas?

background process?

Did you try to enable notebook mode and small textures to check if still hapening?

Did you tried with other games?

Do you updated you drivers?

You can try to verify local files via steam or complete reinstall the game

It is unlikely that this is due to mods, since I observe similar problems in other games.  The latest recommended driver.  Rearranging the game did not help and all files are intact. 

The texture settings do not change the situation in any way. Netbook mode is always off, but with it there are drawdowns of up to 20 fps

Link to comment
Share on other sites

Tips:

Try to leave stuff off the ground.

Stay away from hoardes of mobs.

Lag compensation can make FPS better, but can mess up positioning.

Stay away from killer bees.

Set DST to high priority in task manager.

Go to run, then %temp%, then delete all of the temporary files.

Go to advanced settings, then set performance to prioritized.

Try to minimize mods and play by yourself, or with caves disabled.

Close everything else in task manager.

I don't know if this does anything, but put the tick rate higher in Steam.

 

Link to comment
Share on other sites

I will give a list of mods later, now there is no possibility.  But turning them off doesn't help either.

3 minutes ago, TheGoldenDonut_ said:

Tips:

Try to leave stuff off the ground.

Stay away from hoardes of mobs.

Lag compensation can make FPS better, but can mess up positioning.

Stay away from killer bees.

Set DST to high priority in task manager.

Go to run, then %temp%, then delete all of the temporary files.

Go to advanced settings, then set performance to prioritized.

Try to minimize mods and play by yourself, or with caves disabled.

Close everything else in task manager.

I don't know if this does anything, but put the tick rate higher in Steam.

 

Such actions are useless. A laptop can produce 60 fps without it. I think that's not the problem

Link to comment
Share on other sites

8 hours ago, TheGoldenDonut_ said:

Try minimizing the screen?

When the game is minimized, 60 fps appears in it.

8 hours ago, Minitte said:

Maybe it's AMD's super resolution thing where it lets you pick a higher game resolution than your monitor's resolution.

No, it's off.  Changing the resolution in the game doesn't change anything either

4 hours ago, Daniel86268 said:

If similar things happen in other games as well, I highly doubt DST has something to do with it.

Maybe it's the nvidia optimus stuff screwing up stuff again?

In other games, I can somehow fix it.  Nothing helps me in dst.  And where does nvidia have if I have the entire assembly on amd?

Link to comment
Share on other sites

5 hours ago, Minitte said:

One more thing I can think about.

DST is rendering using your integrated graphics instead of your Radeon 540X..

It annoys me too, since in this software you cannot change the video card for the game

Link to comment
Share on other sites

If such actions above, as you said, don't change or do anything, than you're problem is the not game you are playing, but rather the device you are using to run it. I have had experience with low FPS and lag, and it drives me insane. Playing in a minimized screen or changing the graphics card are really the only two things I can think of, but laptops can't take advantage of different graphics cards, unfortunately.

Link to comment
Share on other sites

image.png.1aa981d3e6170d05d68a857e4710dc0c.png

okay guy. I solved the problem with blocking fps. As soon as I caught this error, dst immediately earned 60 fps (with small drawdowns up to 57-59, but still). To do this, I just sat and did not update the driver for about a month XD

Thank you all for your advice and help, thank you very much :)

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
  • Create New...