Jump to content

Disconnected from the server when entering a Cave (Sinkhole)

  • Pending

game was fine for about a month, suddenly in the middle of the game, after trying to enter a cave, got stuck in a white screen and got disconnected from that server: "the server you were playing on is unavailable.please try again later"


after that tried to log back in into that server, got the same error with the same context. i'm gonna explain everything cause i already tried everything and this post is my last hope of fixing my favorite game :(

i purchased the game and played the game with no problems. installed mods and used them in every game and used caves with no problem. then i watched a video on youtube about some useful mods and installed them (Actionqueue Reborn - Camera Tweaks - Geometric Placement - Minimap HUD - Skins extender). after using this mod, still no problem, but after 2-3 days, i encountered that error when i tried to enter a cave which i thought that could be the issue. the thing is, after about 2 weeks that i got this error, to this day i still can join servers and play with no probelm for some days, i can even use the caves with no problem but after like 10-20 of in-game days, i get the cave bug again and drops me out. just note that i was the only one with that problem in the server. nobody had the same issue. everyone entered and exited caves with no problem. i tested other dedicated and private servers. same thing happened. the other weird thing is, after i get this error, i cant join that same server again for some time, but sometimes after like 10-30 minutes (sometimes even more, like a day), i try to join the same server and i go back in with no problem and im inside the cave, and again i can play with no problem for some in-game days and use the caves and suddenly the same error comes back and drops me out!!!!

i asked one of those dedicated server's admins about my issue. this was his response: "Caves server log simply says migration failed, not why so that ain’t helping. Error code 178". he tried resetting my character so that i could join the server again, i logged in and tried a cave, got the error again. the server does not use any mods, even though i joined both servers with mods and with no mods, that did not matter. same error.

i researched a lot about this issue on the internet and found some ways that seemed helpful. this is the list of things that i did:

1- disabled all the mods. 2-redownloaded all the mods and "clean"ed them. 3-unsubscribed them all. 4-verified integrity of game files. 5-reinstalled the game from steam. 6-restarted my computer. 7-made sure im not using any VPN of any sort on background (never did while playing games online) 8-made sure game is whitelisted on my antivirus (i dont have an AV, it's just windows defender and it's been completely disabled from the start thats why theres nothing to whitelist). 9-i made the game to start as administrator. 10-made sure my connection was stable by using a ping command on cmd 24/7 and my internet is wired.11-contacted klei support that wasn't able to solve this issue and told me to post a bug report so that DEVs could come to rescue.

and this is the list of all my client mods i was using aside from the 5 new ones that i mention on top: Finder - gesture wheel - show nicknames - skin queue - status announcements - combined status.

all that, didn't help. then i tried to get some fresh logs by playing and getting the error again to post here. first log happened to me last night when i used only 5 mods( camera tweaks - actionqueue reborn - combined status - minimap hud - status announcement)

second log is when i unsubscribed and disabled and deleted all mod files and restarted the game and started clean.

in both of them i tried different dedicated servers ( 4 servers ) and in all of them, like after 1 hour of gameplay, got the same error. i hope the logs help to solve this issue for good.

@Zillvr you mentioned in one of the bug reports to tag you if we need your help. please if you or any of the DEVs available could help me, i'd really appreciate it.

if theres any more details you need to fix this issue, i will most definitely reply asap. ( i might have missed some stuff because it's been more than a week or two that this happened to me and i tried to fix it )

also forgive me if my english is not good enough. i tried my best to explain everything clearly.

client_log1.txt client_log2.txt

Steps to Reproduce

everything worked fine, and i think after installing some mods like 2-3 days, started getting disconnected from server when trying to enter a cave. i can't say for sure mods are the issue, but thats my best guess because i did not do anything other than casually playing the game like always.

User Feedback

Hello @DiviVine, welcome to the forums.

Sorry for the late response, and thank you for going through all the details you've tried while trying to fix the issue. Seems like you've really gone through everything I could possibly think of to fix the issue. Except one, but I cannot guarantee that it would fix it for you. Sometimes, when mods have been used, they could really be the possible cause of the issue, I would recommend the following:

  • Close DST
  • Unsubscribe to subscribed mods just to be sure
  • Make sure mods are gone from system, right click DST on Steam Game Library
  • Manage > Browse Local Files
  • Open Mods folder
  • Delete all workshop-### folders OR move to a different location (for safe keeping)
  • Go to Documents\Klei\DoNotStarveTogether\
  • Rename client_save folder to client_save_original folder.
  • Open DST

Some changes made by mods could have had lasting effect on the client_save settings. Hopefully you can quickly test out if you're still having issues. In the mean time, I'll try and think of other possible workarounds.

Share this comment

Link to comment
Share on other sites

 hi @Zillvr . i went through all those steps and played for about 2 hours and got the same error again. i tried entering caves 2-3 times in the first hour of the game, didnt have problems, and then suddenly it happened again. here are the client logs and server logs:

this is also the relevant part of the server logs that the admin sent me:

[05:50:32]: [Shard] Migration request: (KU_xb1Lj0VD) to [SHDMASTER](1)

[05:50:32]: [Shard] #4 <- session/5E8B415F82BB5522/A7NEA1AR81UD/0000000010

[05:50:32]: CloseConnectionWithReason: ID_DST_SHARD_SILENT_DISCONNECT

[05:50:32]: [Steam] SendUserDisconnect for '76561198101659504'

[05:55:19]: Registering secondary shard in EU lobby

[05:55:46]: Available disk space for save files: 112447 MB

[05:55:47]: Serializing world: session/5E8B415F82BB5522/0000000010

[05:59:39]: Cluster player to remove not found in ID_SHD_M2S_PLAYER_LIST packet

client_log.txt server_log_Caves.txt server_log_Overworld.txt

Share this comment

Link to comment
Share on other sites

@DiviVine I'm really stumped on what could be causing this issue for you. With everything else rechecked and double checked, I'm not really sure how to proceed. I am only a forum moderator on here so I have limited know-how with the inner workings of the game behind the scene. Since you already posted this in the bug tracker, the devs will get to it eventually. That is all I can guarantee right now. Terribly sorry.

Could you provide a DxDiag? DiviVine, I have a hunch that it could be system related.

@SereneSky Sorry to ping you without an proper results, but if you are also experiencing the same thing could you also provide the same if not more details on how it's like on your end with logs and etc. That may help narrow down the the specific cause of the issue if we have more details around it. Have you tried the methods that DiviVine mentioned in the post? If not, I hope you can try it and see if it really is the same issue.

Could you also provide a DxDiag? SereneSky , so we can compare it with DiviVine.

Share this comment

Link to comment
Share on other sites

I have the same problem.

I didn't play DST for about 5-6 months, Before that i didn't have this issue, I decided to play DST after all this time, i created a dedicated server to play with my friends and I saw I get doomed when I connect to the cave and I can't connect to my server anymore unless I completely disable the Caves.


Also tried in another server and I saw I got doomed there too. All errors are the same as @DiviVine. In my server's console I can see migration by user '...' failed (178). 


What I tried:

First thing I've tried was disabling my custom VPN, cause I saw it's only happening to me, so i guessed it's something about my network. But it wasn't.

Second thing I've tried was disabling and unsubscribing all my mods and also disabling server's mods. Still didn't work

Third thing I've tried was verifying the game files via Steam, same results.


I really don't know what should I do, Nothing has changed from 5-6 months ago (when i didn't have this issue)


My current DST Version: 467172


Some *client* logs that may be useful


[00:00:48]: Connection accepted to|13000 <6343344388988527992>
[00:00:48]: Network external address discovered:|24805
[00:00:48]: SendClientHandShakePacket to <6343344388988527992>
[00:00:49]: DeserializeHandShakeServerListing
[00:00:49]: Network tick rate: U=10(3), D=20
[00:00:49]: Platform: 1
[00:00:49]: Version: 467172
[00:00:49]: [Steam] Game Connection initiated
[00:00:49]: SendClientInventoryHandShakePacket to <6343344388988527992>
[00:00:50]: [Shard] Starting connection to destination server...
[00:00:50]: [Shard] Getting info of destination server...
[00:00:50]: Overriding region to EU
[00:00:58]: Connection lost to|13000 <6343344388988527992>
[00:01:51]: [Shard] OnDestinationInfoResponse Connecting to master=(N)
[00:01:51]: [Shard] Error requesting destination server info failed, .
[00:01:51]: [Connect] PendingConnection::Reset(true)
[00:01:51]: PushNetworkDisconnectEvent With Reason: "ID_DST_DESTINATION_SERVER_NOT_AVAILABLE", reset: true
[00:01:51]: [Steam] Game Connection terminated (3160297361|13000)
[00:01:51]: [Shard] Stopping shard mode

Share this comment

Link to comment
Share on other sites

hello, @Zillvr
this still seems to be an issue.
I'm the one hosting the server the OP got the logs from, today i got another player with the same issue.
the servers i run have no mods installed or ever had, so server side mods shouldn't be an issue.
I'm not expecting a server side issue since most players have no problems, but anything I can help with?

Share this comment

Link to comment
Share on other sites

@Moonshade based on all the previous reports of this issue where people could not connect to the caves, it's usually caused by antivirus on host side blocking users to connect to the caves server OR on the client's sides' antivirus doing the same thing. Try and have both players host and client to whitelist DST or disable antivirus during game play. Also try the methods mentioned the others have tried in here, especially the ones listed in the original post. One of those methods COULD help fix your issue, but not a guarantee.

Worse case scenario, create a new bug report with all your details and server settings and logs including the things you've done to try and fix it. Also add the log file of the user that has been having issues. Make sure it's the correct log file, by having them get the disconnect prompt again and then getting the log file upon closing the disconnect prompt.

The cases of this issue are really difficult to pin down since there is a lot of variables involved.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...