Sign in to follow this  
MrDoge124

Lua error help!

Recommended Posts

MrDoge124    3

My mod was working fine and then it wouldn't load! Here is part of the error log:

error loading module 'speech_green' from file '../mods/Green\scripts\speech_green.lua':
    [string "cannot OLDFILEACCESSMETHOD @../mods/Green\scripts\speech_green...."]:1567: unexpected symbol near '<eof>'
LUA ERROR stack traceback:

Share this post


Link to post
Share on other sites
Lumina    2149

Sure you didn't change anything ?
Could you paste line 1566 to line 1568 of your speech_green.lua and attach your mod ?

Share this post


Link to post
Share on other sites
MrDoge124    3

I have changed what he says that's it.

It's given me an error again:

error loading module 'speech_green' from file '../mods/Green\scripts\speech_green.lua':
    [string "cannot OLDFILEACCESSMETHOD @../mods/Green\scripts\speech_green...."]:1568: unexpected symbol near '<eof>'
LUA ERROR stack traceback:

Should I send something for you to look at? Like some of the code I'm having problems with?

Share this post


Link to post
Share on other sites
CarlZalph    4137

Speech files are finicky in that one small error in any part of it can generate errors on the other side of the file.

It'd be best to just upload what you have for a full analysis on the file.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this