Jump to content

Last update broke crock pot food mods


Recommended Posts

Ok - so it wasnt just mine - yeah this is wierd.


Log File:



D:/Steam/steamapps/common/dont_starve/data/scripts/saveindex.lua:177 in (upvalue) cb (Lua) <158-180>
   status = table: 0EED5A90
D:/Steam/steamapps/common/dont_starve/data/scripts/fileutil.lua:75 in (upvalue) onchecked (Lua) <69-78>
   success = true
   file = survival_5

scripts/mainfunctions.lua(849,1) .../common/dont_starve/data/scripts/prefabs/cookpot.lua:3: loop or previous error loading module 'cooking'
LUA ERROR stack traceback:
    =[C]:-1 in (global) require (C) <-1--1>
    D:/Steam/steamapps/common/dont_starve/data/scripts/prefabs/cookpot.lua:3 in (local) fn (main) <0-0>
    D:/Steam/steamapps/common/dont_starve/data/scripts/mainfunctions.lua:76 in (global) LoadPrefabFile (Lua) <68-88>
    D:/Steam/steamapps/common/dont_starve/data/scripts/gamelogic.lua:123 in (upvalue) LoadAssets (Lua) <94-188>
    D:/Steam/steamapps/common/dont_starve/data/scripts/gamelogic.lua:1225 in (upvalue) DoResetAction (Lua) <1168-1229>
    D:/Steam/steamapps/common/dont_starve/data/scripts/gamelogic.lua:1240 in (local) complete_callback (Lua) <1232-1241>
    D:/Steam/steamapps/common/dont_starve/data/scripts/upsell.lua:27 in (global) UpdateGamePurchasedState (Lua) <11-30>
    D:/Steam/steamapps/common/dont_starve/data/scripts/gamelogic.lua:1245 in () ? (Lua) <1243-1246>
    =[C]:-1 in (method) SetPersistentString (C) <-1--1>
    D:/Steam/steamapps/common/dont_starve/data/scripts/saveindex.lua:104 in (method) Save (Lua) <94-106>
    D:/Steam/steamapps/common/dont_starve/data/scripts/saveindex.lua:177 in (upvalue) cb (Lua) <158-180>
    D:/Steam/steamapps/common/dont_starve/data/scripts/fileutil.lua:75 in (upvalue) onchecked (Lua) <69-78>
scripts/frontend.lua(723,1) SCRIPT ERROR! Showing error screen    
scripts/mods.lua(253,1) Disabling waiter (Waiter 101 v3.9) because it had an error.    
scripts/modindex.lua(85,1) ModIndex: Load sequence finished successfully.



Link to comment
Share on other sites

10 hours ago, ImpactedTooth said:

I had the same error. I was able to get around it by putting my AddCookerRecipe in a GamePostInit in my modmain.

function gamepostinit()
	AddCookerRecipe("cookpot", berryjuice)




Thanks - this worked perfectly.

Also for anyone else out there - If you add ingredients or ingredient values - those need to be added PostInit as well.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...