Worldgenoverride not taking effect on server


Recommended Posts

Is the below correct for a caves-beta overworld? Thank you.

return 

{

        override_enabled = true,
        unprepared = { -- "never", "rare", "default", "often", "always"
                berrybush = "always",
                cactus = "default",
                carrot = "always",
                mushroom = "default",
        },
        misc = {
                autumn = "verylongseason", -- "noseason", "veryshortseason", "shortseason", "default", "longseason", "verylongseason", "random"
                boons = "default", -- "never", "rare", "default", "often", "always"
                branching = "default", -- "never", "least", "default", "most"
                day = "default", -- "default", "longday", "longdusk", "longnight", "noday", "nodusk", "nonight", "onlyday", "onlydusk", "onlynight"
                frograin = "default", -- "never", "rare", "default", "often", "always"
                lightning = "default", -- "never", "rare", "default", "often", "always"
                loop = "default", -- "never", "default", "always"
                season_start = "default", -- "default", "winter", "spring", "summer", "random"
                spring = "default", -- "noseason", "veryshortseason", "shortseason", "default", "longseason", "verylongseason", "random"
                summer = "default", -- "noseason", "veryshortseason", "shortseason", "default", "longseason", "verylongseason", "random"
                touchstone = "default", -- "never", "rare", "default", "often", "always"
                weather = "default", -- "never", "rare", "default", "often", "always"
                wildfires = "default", -- "never", "rare", "default", "often", "always"
                winter = "default", -- "noseason", "veryshortseason", "shortseason", "default", "longseason", "verylongseason", "random"
                world_size = "huge", -- "default", "medium", "large", "huge"
        },
        animals = { -- "never", "rare", "default", "often", "always"
                alternatehunt = "default",
                angrybees = "default",
                beefalo = "default",
                beefaloheat = "default",
                bees = "default",
                birds = "default",
                butterfly = "default",
                buzzard = "default",
                catcoon = "default",
                frogs = "default",
                hunt = "default",
                lightninggoat = "default",
                moles = "default",
                penguins = "default",
                perd = "default",
                pigs = "default",
                rabbits = "default",
                tallbirds = "default",
        },
        monsters = { -- "never", "rare", "default", "often", "always"
                bearger = "default",
                chess = "default",
                deciduousmonster = "never",
                deerclops = "never",
                dragonfly = "never",
                goosemoose = "never",
                houndmound = "default",
                hounds = "never",
                krampus = "default",
                liefs = "default",
                lureplants = "never",
                merm = "default",
                spiders = "default",
                tentacles = "default",
                walrus = "default",
        },
        resources = { -- "never", "rare", "default", "often", "always"
                flint = "default",
                flowers = "default",
                grass = "default",
                marshbush = "default",
                meteorshowers = "default",
                meteorspawner = "default",
                reeds = "default",
                rock = "default",
                rock_ice = "default",
                sapling = "default",
                trees = "default",
                tumbleweed = "default",
        },
}

 

Link to comment
Share on other sites

Well that's the settings of your custom overworld map not the default. Since you're making a multilevel server, does your slave server generate a proper caves world? Because if both the master and slave server aren't generating the proper world then your .lua file isn't being read. Most likely because your .lua file is still a .txt file. Activate the show file extensions and make sure its just .lua and not .lua.txt

Link to comment
Share on other sites

I'm using Citadel Servers for hosting and copying the above into the worldgenoveride.lua file, so the file extension isn't .txt

 

Both the over and cave world servers generate fine, but I haven't been able to figure out how to configure the above world.

Link to comment
Share on other sites

I had similar issues when trying to create new world on same preset number after changing worldgenoverride.lua, seems like save/saveindex file contains world settings for preset numbers and they are not always getting overwritten by worldgenoverride.lua, just delete it or changed preset number in settings.ini.

 

Alternatively if you don't plan on changing anything and leaving everything on default use this:

return {override_enabled = true,preset = "SURVIVAL_TOGETHER",}
Link to comment
Share on other sites

I'm having a similar problem where my slave server isn't reading the worldgenoverride.lua to make the caves.  It's just another over-world.  How do I fix this?  I know it's a .lua file, and not a .lua.txt file.

1
2
3
4
return {
override_enabled = true,
preset = "DST_CAVE",
}

 

Link to comment
Share on other sites

I'm using Citadel Servers for hosting and copying the above into the worldgenoveride.lua file, so the file extension isn't .txt

 

Both the over and cave world servers generate fine, but I haven't been able to figure out how to configure the above world.

 

I assume that you've already tried deleting the save folder of the master (overworld) server to regenerate a new world. Since your caves world is working properly, then your overworld should have loaded the settings you inputted into the worldgenoverride.lua. Are you sure the settings weren't loaded properly? Like have you seen Deerclops or the Dragonfly or is Autumn lasting more than 20 days? If you think the settings aren't loaded properly because of the server info before joining the game, that info doesn't reflect worldgenoverride even though the server properly generated the world. There's more information on this on another thread somewhere in the forums if I'm not mistaken.

Link to comment
Share on other sites

Just checked it all over again (more thoroughly this time). It looks like everything is being applied fine, but the world status window ingame is reporting incorrectly.

 

For instance, carrots are set to ALWAYS, but when I check in the server preview window, they are showing as default.

 

Thank you for the help.

Link to comment
Share on other sites

Just checked it all over again (more thoroughly this time). It looks like everything is being applied fine, but the world status window ingame is reporting incorrectly.

 

For instance, carrots are set to ALWAYS, but when I check in the server preview window, they are showing as default.

 

Thank you for the help.

 

This is something I noticed when working on my web server list, not all servers return valid world overrides data from Klei's lobby server, and some return preset name and overrides in different format. Probably server status ingame is not able to parse it properly yet...

You could try checking if same things happens on my list, if it does then well, it's issue on game end.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.