Sign in to follow this  
taz

Shank 2 Linux ERROR: Missing required OpenGL extensions.

Recommended Posts

taz    10

I get the same error messages and a segmentation fault afterwards. I have a radeon HD4850, which is no longer supported by the proprietary drivers.Is there a way to run the game with the open-source drivers?

Share this post


Link to post
Share on other sites
Wade    293

The latest update should now log OpenGL extensions.Can we ask you to please download it and send in the <username>/Library/Klei/Shank2/rendering.log file?It will hopefully help us to track down what the issue is.Thanks!

Share this post


Link to post
Share on other sites

Yeah I get that error too and a segmentation fault http://pastebin.com/3vFsWG4b

And my graphics card info

Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller            X.Org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz            GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 8.0.5

Share this post


Link to post
Share on other sites
Tuomas    10

Yeah I get that error too and a segmentation fault http://pastebin.com/3vFsWG4bAnd my graphics card info

Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller            X.Org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz            GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 8.0.5
The output says "EXT_texture_compression_s3tc required". As you seem to have an integrated graphics card you need to install the S3TC library for your distro. Edited by Tuomas

Share this post


Link to post
Share on other sites
taz    10

Thank you for the hint. Installing the S3TC lib worked for me. With the open-source drivers. :)For the gentoo users, it is called media-libs/libtxc_dxtn there.

Share this post


Link to post
Share on other sites

The output says "EXT_texture_compression_s3tc required". As you seem to have an integrated graphics card you need to install the S3TC library for your distro.

Yes thanks that worked, that could've been on the readme or humble bundle page...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this