Recommended Posts

This may sound rather stupid, but where's the settings.ini file exactly?

 

The wiki says ~/.klei/DoNotStarveTogether/settings.ini for Linux, but I can't find no file under that name in that folder. All I got are save folder and a log.txt file..

 

The screen -S "DST Server" ./dontstarve_dedicated_server_nullrenderer executes just fine with no error whatsoever.. What am I missing?

 

Edit: I left the screen active for a while and noticed this:

[200] Account Failed (6): ""!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Your Server Will Not Start !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!If you wish to run your server without authenticationOr if you wish to use your server for a LAN gameYou must run it in 'lan mode'. In settings.ini add:[account]server_lan_mode = trueOr add the command line argument -lanTo generate a server_token from a game client, open consoleopen consle with the tilda key (~)Type: TheNet:GenerateServerToken()

 

I must edit a settings file but if there isn't any should I make one or what? Mind shading some light on this? Thanks.

Link to comment
Share on other sites

I created the settings.ini in ~/.klei/DoNotStarveTogether/ and so far got the following in it:

[network]default_server_name = Cez's Test Serverdefault_server_description = Testing dedicated server...server_port = 10999server_password = passwordmax_players = 6pvp = falsegame_mode = endlessenable_snapshots = trueenable_autosaver = truetick_rate = 30connection_timeout = 8000server_save_slot = 1enable_vote_kick = truepause_when_empty = true[account]dedicated_lan_server = falsetoken = *my real server token*[STEAM]DISABLECLOUD = true[MISC]CONSOLE_ENABLED = true

saved, closed the previous screen and restarted via the same command and get the same result as in first post.

 

Yours doesn't make any sense and there's no [account[ section..

 

Edit: Apparently I'm a blind idiot that can't properly read the line that says to add the generated file to the same location I made the settings.ini file. *Facepalm*

 

Second edit: Apparently it doesn't like a copy/paste of the content of file, so had to put it on the server and copy there. Now apparently it's working. :-)

 

The bad news is that even with added port forward from router to the server and a line in firewall to allow udp on that port can't see the server on the list... Yet. :(

Link to comment
Share on other sites

Any idea on why it doesn't show up in servers list?

 

I've triple-checked that there's a forward route to the server in router's settings, went a step further have a

iptables -A INPUT -p udp -m state --state NEW -m udp --dport 10999 -j ACCEPT

in my firewall script and still doesn't seem to show up. :(

 

Edit: Got Portqry from Microsoft and tested the 10999 UDP port via the LAN IP and the WAN one and I get a result as:

UDP port 10999 (unknown service): LISTENING or FILTEREDportqry.exe -n xx.xx.xx.xx -e 10999 -p UDP exits with return code 0x00000002.

and on a non open port that I know for a fact:

UDP port 12345 (unknown service): NOT LISTENINGportqry.exe -n xx.xx.xx.xx -e 12345 -p UDP exits with return code 0x00000001.

so the routing seems be be working..

 

The server is running and has a map generated. here's last few lines from the screen:

Done forest map gen!scripts/worldgen_main.lua(245,1) Checking map...scripts/worldgen_main.lua(599,1) Generation completeWorldSim::SimThread::Main() complete

What am I missing? :(

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.