Jump to content

[Support] Game crash? Post here for help

Recommended Posts

I just started doing a mod, to adding a new Character. At first I had a lot of crashes, but were able to fix them by myself.

I'm finally able to see the character in the selection screen, but if I select him the game don't really connect me to the created world.

I'm hearing sounds from the birds and the sound of the fire from the character selection, while having a black screen.




Link to comment
Share on other sites

So it is not the missing comma that makes that problem?

Probably not. Though I'm not sure what's causing it. Is that still happening with the version you posted?


And for the second one, in the file called "anim" for my mod I have the animation for the character, and the file for its special item. And in the subfolder for my item I have a media file called "anim," and one called "build." Isn't that all I need?
I'm not sure I understood correctly. As previously mentioned, if you don't have the file swap_hunting_dart.zip inside "..\YourModFolder\anim" then it won't work.
Alternately, you can also change "anim/swap_hunting_dart.zip" in your code to the correct relative path. Ex, "ItemSubFolder/anim/swap_hunting_dart.zip".
Link to comment
Share on other sites

Same problem here. Personally I think text uploads should always be one at  gist.github.com an file uploads at mega.co.nz to avoid problems like this

I agree with the text uploads, especially since it's easier to see them directly without downloading.

As for file uploads on other sites, I feel less inclined to download something if I have to keep another tab open, navigate through multiple pages, or complete a captcha. Since everyone has their own favorite upload site and won't stick to just one, I think it would be best to keep uploads right here on the forum.


Is there any place to report forum bugs?



@DarkFenikkusu Please paste your log at github or pastebin.



Link to comment
Share on other sites

Dang, I fixed the missing asset problem, I think (I added the swap animation and the inventory image.) Yet now when I enable the mod, the game just closes. So I checked my log so I could fix the problem, yet it doesn't show a problem in the log, the log just ends abruptly. What sort of problem causes this? The log tells me nothing.

I will attach the log so you can look at it if you are interested (in pastebin, as it seems that that is what you prefer, downloading it is definitely  annoying.)



Link to comment
Share on other sites

@Dwim Yeah, it was probably an error from a previous attempt at using the mod during the same game instance. The log resets only when you restart the game completely (close and open it).


Hmm. Interesting. Never seen that before. Disable all other mods and try running it again? Wait a few seconds after it crashes before opening the log.


Thanks for using pastebin btw, I appreciate the accommodation.

Link to comment
Share on other sites

Still isn't working. It probably is due to my most probably horribly incorrect coding for my item (I just copied the code for the blow dart, deleted all the stuff about fire and sleeping, and added some of my own code.) Can broken .luas cause silent crashes? My .lua is definitely full of problems.

Link to comment
Share on other sites

@Dwim Hmm. Would you happen to have rog compatibility set to false in your modinfo?


Please follow these steps for further debugging.


Remove all mods from your mods folder (you can keep them in another folder temporarily), leave only your mod in there.


Ensure the game is completely closed.


Add this line to the bottom of your modmain:

print("Mod execution complete")

Run the game and test the mod.


Then post your log again.

Link to comment
Share on other sites

I tried what you suggested, yet I cannot seem to get rid of the mods. I delete the folders, yet as soon as I start up the game, they come back... I feel violated haha.


Edit: Unsubscribed and deleted each one... what a drag. Tried starting it up again after doing what you suggested, still did not work, same problem. This is very frustrating, as it isn't showing any problem in the logs, it still just cuts off.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...