Jump to content

My mod can't be downloaded from steam?


Recommended Posts

I just recently uploaded a mod, 100% tested working, uploaded with zero issues, but whenever anyone subscribes to it, it simply doesn't download into their mod folder.

 

Has anyone ever experienced this before?

Edited by Nyogtha
Link to comment
Share on other sites

Just tried a very alpha version of another mod I have been working on, and it is having the same problem.

 

Had a conspirator who has been working with me on the mods upload the mod from their computer and steam account, only to experience the exact same problem.

 

You can subscribe, but it simply never downloads when you go to "Mods".

 

edit : Should note, older mods can be downloaded. It appears to be specific to any mod I or my partner have uploaded today.

Edited by Nyogtha
Link to comment
Share on other sites

  • Developer

@Nyogtha, I just uploaded a new mod and was able to subscribe to it, so it appears that things are working fine on Steam's end of things. Have you uploaded mods in the past that are still subscribe-able? There is also a user agreement that you have to accept on Steam before your mods will be visible. Try this link http://steamcommunity.com/workshop/workshoplegalagreement


I've noticed from time to time that when we request the list of subscribed mods, sometimes the list isn't complete, or is entirely empty. This is something I'm still investigating, but I haven't been able to narrow down a good repro case yet.

Link to comment
Share on other sites

@PeterA,

 

Thanks for the help!

1: I have a mod that's currently up and running and subscribe-able : 
http://steamcommunity.com/sharedfiles/filedetails/?id=365749321

2: I have accepted the agreement, yes.

 

The two mods I have uploaded are currently switched to private, because I didn't want any more comments on how they didn't work :razz:

I can set them to public if you want to take a look.

 

Thanks again!

 

edit: While I think it's unlikely, it may be something specific to the mods I have been creating. In case you want to take a look at my horrifyingly bad code, here's the character file.

nyo.zip

Edited by Nyogtha
Link to comment
Share on other sites

UPDATE!

 

Welp, I figured out a work around that may be related to why it wasn't working.

 

I was thinking about my working mod, and my new mods, and what the difference was, and I realized I had started using custom sounds.

 

When I went ahead and deleted the custom sounds and commented out the lines of text for enabling the custom sounds, the mod downloaded 100% no problems and appears to be working (albeit without sound).

 

Any idea why that might be happening?

 

EDIT: Okay, so I went ahead and tried updating the working version with the sound files, and miraculously, it now updates without issue.

 

 

TL;DR of entire issue:

 

Mods uploaded with sound seem to not work with subscribe.

If mod is upload without sound, but sound is added later, they work.

 

It's a Christmas miracle!

Edited by Nyogtha
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...