Jump to content

Krane is not working....

Recommended Posts



So, I know the ktools should work, and when I tried using ktech, it worked fine!

So I tried using krane to turn an animation zip file into a spriter project.That didn't work. So I extracted the zip, and came up with a folder with the atlas_0.tex, anim.bin, and build.bin in it.

So, I went into that directory in Terminal, and I did the command : krane anim.bin build.bin output

where output was the name of the out put directory.

But Terminal keeps spitting this out:


admins-imac:gear_armor aidan$ krane anim.bin build.bin output
Loading anims from `anim.bin'...
Loading build from `build.bin'...
ERROR: Missing hash table at the end of the build file.Skipping build file.
ERROR: No build found in the input files.


What am I doing wrong? It can't read any build file I've tried with it!

EDIT: What is this "hash table?"

Link to comment
Share on other sites

What @DeathDisciple said.

But note that, if you did use Matt's build renamer, you can just replace that build.bin being decompiled with the original one (or take the original zip altogether and replace the atlas-0.tex). When decompiled, the build name is simply the name of the .scml file, so renaming the build back again amounts to renaming the file.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...