Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Castellan

[Mac Os X] Graphics Bug - Menus Are Wrong Scale Or Position Depending On Resolution

Recommended Posts

Castellan    0

I'm running Mark of the Ninja on a 2012 Retina MBP. It ran fine on the first launch, as well as immediately after changing the resolution to the maximum 2880x1800.

 

Since the third launch onwards the menu's have been either massively off scale (leaving only a small area visible), or offset from the screen (leaving half the menu displayed, and half the screen black).

 

I've changed the resolution be editing the graphics.ini file in order to set the resolution back to 1440x900, and done some experimenting. It seems that the scaling happens at any resolution above 1440x900, while the offsets happen at anything 1440x900 or below. If also seems that both issues get worse the further the resolution gets from 1440x900.

 

If it's any help, I remember there being a similar scaling issue in Don't Starve, though that could be resolved by resetting the resolution.

 

Edit: Correction, the issue is still present in don't starve. It can still be fixed by changing the resolution after starting the game, but this doesn't do anything for Mark of the Ninja.

Share this post


Link to post
Share on other sites
JanH    5,421

Hey @reversed_cliche, are you playing the game on Steam or the Standalone?

 

Could I get you to delete your "graphics.ini" file in your Mark of the Ninja folder? Deleting that file will reset your settings to their default values and allow you to set your resolution to your liking the next time you run the game.

 

Folder location: ~/Documents/Klei/Ninja - graphics.ini

Share this post


Link to post
Share on other sites
Naliba    0

I'm also having this issue on my rMBP. Additionally, the game thinks the mouse pointer is about 3 inches higher than it actually is. I've tried a bunch of different resolutions and I've deleted my ~/Documents/Klei/Ninja/users/graphics.ini a couple times, but nothing fixes the problem.

Share this post


Link to post
Share on other sites
millon    0

I'm having exactly the same problem as Naliba.  To click on menu options the mouse pointer has to be about 1/4 of the way down the screen.  The very top of the game is off-screen, even during game play.

Share this post


Link to post
Share on other sites
matt1319    0

I'm not being able to set a resolution which actually works in full screen. I have a retina 15" Macbook pro. All full screen resolutions just stretch larger than my screen size so i can only see a small amount of the action

Share this post


Link to post
Share on other sites
oschrenk    0

I also have this problem. The workaround is to play in windowed (not fullscreen) mode.

 

Resolution on "click" map weren't matching on the very first start of the game, clicking on buttons didn't work, the click areas of the menu options were down to the actual button. Very annoying if the area is below the actual screen. Luckily I managed to get into the main menu at some point and deactivated Full Screen. 

Share this post


Link to post
Share on other sites
panpipe    0

I'm also having this same problem with my 2012 MBP retina, using the Steam version.

 

If you set the resolution to 2880x1800 you only get to see a tiny portion of the bottom left part of the screen. Luckily I could roughly remember how to navigate the settings and managed to reset back to the almost working default.

Share this post


Link to post
Share on other sites
Wade    297

We're making some tweaks to the code to try to figure out why this is happening. We're not experiencing this issue on our machines, so it may be something that is hardware specific.

 

We're hoping to release a new version later today with the tweaks, and it will also have logging of the size of the actual video surface the game is getting, and the maximum texture size. If the User is still occurring, we will need some of you to post these logs so we can see where the size mismatch or insufficient texture size is occurring.

Share this post


Link to post
Share on other sites
Castellan    0

For me at least, this seems to be resolved now. I don't think anything has been changed my end since my original post, so I presume this was an update from you guys? If so, thanks!

Share this post


Link to post
Share on other sites
NdAlpha    0

This is still happening to me. Runing Mac OSX latest version on Macbook pro retina, I have to set it up on window mode so I can actually play, high resolutions go off screen and lower resolution take only a portion of it

 

Tried deleting the graphics.ini file but the bug remains

Share this post


Link to post
Share on other sites
Tuomas    10

If you are having this issue please download the latest OSX version from Humble. Then start the game with the "-enablelog" command line parameter. Presuming you have placed ninja.app to Applications folder you can do this by issuing the command

/Applications/ninja.app/Contents/MacOS/ninja -enablelog

in the terminal. If you have ninja.app elsewhere adjust the path accordingly. After you have run the game go to /Documents/Klei/Ninja/log/ and post the contents of "aggregate.log" here.

Share this post


Link to post
Share on other sites
FooLord    0

I have a 15" Retina MacBook Pro, too. Latest OS X Version (10.8.5)
The interesting part is, that it worked the 3-5 first times i started the game and out of the blue there was this bug. (Other games, programmes suffer from this kind of bug, too)

 

And i think it is interesting, that the bug still exists when i run the game in native resolution (2880x1800), and maybe interesting is, that also on native resolution or the optimal resolution of 1440x900, the screen will be resized by the OS.

 

So here is the what the log file says:

 

 

[16:16.32] (2888653352) db::LogSystem::Initialize took 0.001000 seconds
[16:16.32] (2888653352) KGraphics::Initialize - Fullscreen
[16:16.32] (2888653352) Trying to set video mode 1440x900 fullscreen
[16:16.34] (2888653352) Set video mode width 1440, height 900
[16:16.34] (2888653352) mode set success
[16:16.34] (2888653352) OpenGL vendor: "NVIDIA Corporation"
[16:16.34] (2888653352) OpenGL renderer: "NVIDIA GeForce GT 650M OpenGL Engine"
[16:16.34] (2888653352) OpenGL version: "2.1 NVIDIA-8.16.74 310.40.00.10f02"
[16:16.34] (2888653352) OpenGL shading language version: "1.20"
[16:16.34] (2888653352) OpenGL extensions: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture
[16:16.34] (2888653352) 5 mojoshader profiles:
[16:16.34] (2888653352) 0: "glsl120"
[16:16.34] (2888653352) 1: "glsl"
[16:16.34] (2888653352) 2: "nv3"
[16:16.34] (2888653352) 3: "nv2"
[16:16.34] (2888653352) 4: "arb1"
[16:16.34] (2888653352) best profile: glsl120
[16:16.34] (2888653352) Max texture size: 16384
[16:16.34] (2888653352) Max renderbuffer size: 16384
[16:16.34] (2888653352) texture image unit count = 16
[16:16.34] (2888653352) KGraphics::Initialize took 3465678.991000 seconds
[16:16.34] (2888653352) KleiSound::Initialize took 0.028000 seconds
[16:16.34] (2888653352) ### Ninja started ###
[16:16.34] (2888653352) Command-line: -enablelog 
[16:16.34] (2888653352) Configuration: Production
Build: -1
Date Built:Sep 17 2013 15:45:25
 
[16:16.34] (2888653352) Locale set to: german
[16:16.34] (2888653352) ThreadManager::Initialize took 0.000000 seconds
[16:16.34] (2888653352) Lua Initialization took 0.000000 seconds
[16:16.34] (2957103104) THREAD - started 'WorkerThread' (0xb041d000)
[16:16.34] (2888653352) TextureManager Initialization took 0.000000 seconds
[16:16.34] (2957635584) THREAD - started 'WorkerThread' (0xb049f000)
[16:16.34] (2888653352) AnimationManager Initialization took 0.000000 seconds
[16:16.34] (2888653352) Network Initialization took 0.000000 seconds
[16:16.34] (2888653352) ProfileManagerInterface::LoadSettings -- loading settings from 'users/settings.sav'
[16:16.34] (2888653352) Success.
[16:16.34] (2888653352) ProfileManager Initialization took 0.000000 seconds
[16:16.34] (2958168064) THREAD - started 'cInputThreadPC' (0xb0521000)
[16:16.34] (2888653352) Locale set to: german
[16:16.34] (2888653352) ProfileManagerInterface::LoadSettings -- loading settings from 'users/settings.sav'
[16:16.34] (2888653352) Success.
[16:16.34] (2888653352) Locale set to: german
[16:16.34] (2888653352) Controllers changed: new mask: 16 -> 16
[16:16.34] (2888653352) Locale set to: german
[16:16.34] (2888653352) KleiSound::SetFMODReverb('Default')
[16:16.34] (2888653352) Language Option: English
[16:16.34] (2888653352) Language Option: FranÁais
[16:16.34] (2888653352) Language Option: Italiano
[16:16.34] (2888653352) Language Option: Deutsch
[16:16.34] (2888653352) Language Option: EspaÒol
[16:16.34] (2888653352) [16:16.34] (2888653352) LocString() -- missing string!
[16:16.34] (2888653352) LocString() -- missing string!
[16:16.42] (2888653352) Locale set to: german
[16:16.44] (2888653352) Locale set to: german
[16:16.59] (2888653352) Locale set to: german
[16:16.59] (2888653352) Locale set to: german
[16:17.00] (2888653352) Locale set to: german
[16:17.01] (2888653352) Locale set to: german
[16:17.01] (2888653352) Locale set to: german
[16:17.07] (2888653352) ProfileManagerInterface::SaveSettings -- saving settings to 'users/settings.sav' (166 bytes)
[16:17.07] (2888653352) Success.
[16:17.07] (2888653352) Locale set to: german
[16:17.15] (2888653352) ProfileManagerInterface::SaveSettings -- saving settings to 'users/settings.sav' (166 bytes)
[16:17.15] (2888653352) Success.
[16:17.15] (2888653352) Locale set to: german
[16:17.38] (2888653352) Locale set to: german

Share this post


Link to post
Share on other sites
Azrach    0

I had the same issue, however I think I've tracked down the cause. This is most likely caused by the Mac switching from integrated to discreet graphics after the game launches. Since the launch time is so quick, it may not have enough time to switch correctly hence the rendering bugs.

 

The simplest solution is to turn off Automatic Graphics Switching in the Energy Saver preference pane. My solution is to use an app called gfxCardStatus which will let you know if discreet graphics are in use and additionally allow you to lock to either integrated of discreet. Just choose "Discreet Only" and then launch this awesomely awesome game as normal.

 

Due to the nature of the bug I wouldn't be surprised if this affected any Mac with dynamic graphics switching enabled. For reference I'm on a 15" RMBP running 10.9 DP8.

 

Now if only I could solve the slow down issues I would be the happiest little ninja alive.

Share this post


Link to post
Share on other sites
kharms    0

Azrach, you probably tracked issue correctly. Turning 'switching' off, and at least my full res setting now works fine   AspectRatio=8:5 Height=1800 Width=2880

 

Using the latest ninja.app download version from today.

 

edit:

 

rmbp, 2,6 GHz Intel Core i7, OS X 10.8.4,  Height=1050 Width=1680 e.g. works too

Share this post


Link to post
Share on other sites
Azrach    0

Glad to be of service! Should be an easy fix to force the app to start with discreet graphics in the future. It's not often you see any kind of app start too fast. Hope the team keeps up the great work!

Share this post


Link to post
Share on other sites
FooLord    0

Thank you Azrach! Fixed the problem also for me.

I used gfxCardStatus at the beginning but i found a bug, which was a deal breaker. (When i set my macBook to sleep mode, connected to an external monitor, the macbook wouldn't wake up later)

Share this post


Link to post
Share on other sites
firesand    0

yes that's workaround can fix resolution problem but still I prefer a patch for this problem on MBP retina from official support

Share this post


Link to post
Share on other sites
Azrach    0

Good news, looks like they've fixed it in the latest patch. Performance in general seems to be much better so big thanks to Klei!

Share this post


Link to post
Share on other sites
Wade    297

Yes, we made some rendering tweaks to fix some issues and improve performance.

Share this post


Link to post
Share on other sites
etherealg    0

I'm afraid I'm still having this problem, on both the current version on steam and the separate download version from humble bundle. Still need logs to help debug?

Share this post


Link to post
Share on other sites