Jump to content

Trying to generate same world


Recommended Posts

Hi, I've been playing on a world I really like, it's got terrain i like, and everything about it is nice. However I have not played in a while, I'm way past the early days, and cannot simply roll back to day 1, so I tried using the 'seed' generation method, both with api-gem core and without. The world.. I guess you can say generates fine, However it never actually launches, It's missing the hermit hutch prefab or moonquay Queen.


Checking Required Prefab hermithouse_construction1 has at least 1 instances (1 found).

[00:12:41]: Checking Required Prefab monkeyqueen has at least 1 instances (0 found).    
[00:12:41]: PANIC: missing required prefab [monkeyqueen]! Expected 1, got 0    
[00:12:41]: An error occured during world gen we will retry! [was     4     of     5    ]

It goes on forever I can't actually get in game to see if my terrain is the same, my other world where I would like to start over on, runs fine, all the prefabs are there (I checked) and they function fine, I can only assume it was because of the like.. I don't know what you call them, the "sit in's" until the stuff is ready to be used? were there.. I'm not sure, is there anything I can do to somehow force them to spawn so I can load in or something? If i alter anything in the generation, the world won't be the same, and while I could regenerate over and over to get my desired result that will take forever. is there an alternative to maybe just rolling back the entire world to day 1? I've researched that but nothing seems to come up that will actually provide me the results I seek.

Link to comment
Share on other sites

Oh I had that happen to me, and it took me quite some time to figure out why:D Seeds only generate the same worlds between the same versions of the game. So a seed that works for an older world might not even be compatible with the current version of DST (which I think is the case for you), since, roughly speaking, that seed fundamentally decides for the randomness factor of world generation, which is then "processed" by the current rules of the game. I see that the world can't fit the Moon Quay Island, violating the game's rules and (most likely) making the seed invalid.

As for the endless loading message: try clicking cancel after waiting for 2 minutes or so, and restart your game and try loading that save again. This will most likely change your seed, verifying it being invalid, but at least you will be able to load that game and see everything for yourself. If you still can't solve your issues let us know!

Link to comment
Share on other sites

12 hours ago, Lokoluna said:

Ah darn, so there's no way for me to be able to keep my world? I don't really wanna generate another, I really like it's terrain haha- Thanks!

That's why I started backing up world files instead of world seeds:P And something else you might find useful for later: if you are using world generation mods (Triple Mactusk, Setpiece Config, etc.) their updates can make a difference too, although some on a smaller scale. For example I noticed that updates on setpiece mods tend to change the locations of the setpieces, Crab King, Pearl's Island etc. but not the shape of the mainland.

Link to comment
Share on other sites

20 hours ago, GodIess said:

there is a mod that allows you to generate a world seed, and configure it when creating a world, plus a world seed is written in the game files. That is, it is quite possible

Yeah i've done this, it gives the same error as above.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
  • Create New...