Jump to content

Odd electrolyzer behavior


Recommended Posts

I just noticed that my electrolyzers weren't working.  I did something weird with my piping that only gave the electrolyzers a packet every other second (i.e. there were gaps in the packets).  This led to them not working despite having water, as they were reporting an empty pipe every other second.  Is this a known behavior?

Link to comment
Share on other sites

10 hours ago, Gurgel said:

Are they really not producing anything or just alternating on/off? Also, what kind of packets are you sending? Full packets every other second would fill the pipe immediately.

 

It was alternating packets of water.  Some packets are full, some were not.  The electrolyzers were toggling on and off, but not producing any oxygen.

EDIT:  To be clear, this was caused by a water source running out of water.  Once I got more water, it worked properly again, but the problem reemerged when I ran out of water again.

Link to comment
Share on other sites

1 hour ago, Mikekl said:

you've placed a bridge somewhere with normal pipe under it, which will create 1 gap between each blob of water.

saw it in one of the youtubers(francis john or gtg)

 

I do know what caused the alternating packets, and that actually wasn't it.  I accidentally had a t-junction from my electrolyzer to another water consumer.  When the other water dried up, the t-junction was sending every other packet the other way.

My concern isn't how the packets ended up that way, it was the electrolyzers not operating with alternating packets moving past it.  I believe it is a bug.

Link to comment
Share on other sites

6 hours ago, Zarquan said:

packets moving past it.

If you have the packets of water moving past the electrolyzers rather than a dead end on the electrolyzer (even if it's just one pipe segment) then the electrolyzers might not be able to pull in water unless it backs up.

Post a picture already.

Link to comment
Share on other sites

While I've not confirmed it with Electrolyzers, I believe it's the same issue as the Oil Well: some of the check it does before running is "is there any liquid on the pipe input port". It should really check the internal storage (or in the case of the Oil Well, allow relieving pressure without anything on the pipe input port), but that's an oddity that works well in 99% of the cases.

Obviously it breaks down if you do funky things with it, like running super-heated water in it and have an overflow to avoid packets merging (which I've explored when building the Petroleum Well). The fix is simple: ensure there is always water flowing on the pipe input port. In the case of super-heated water, that involves an 10% injector like that: https://forums.kleientertainment.com/forums/topic/130977-the-10-liquidgas-injector/

But for a "normal" use without super-heated water, the fix is even simpler: remove the overflow so that water is blocked on the pipe input port.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...