Jump to content

What the fudge is going on right here


Recommended Posts

Ok, so I never saw this before, I'm playing in my solo world, local only, and my character looks like a rubberband, it goes back and forth a lit bit when my my compesation is set to none. But when I set it to pretictable, the "lag" is gone. I'm currently playing with no mods, only the client geo placement. My graphics card's drivers are on date. Does someone know what might be the problem here?

Link to comment
Share on other sites

When lag compensation is set to none, there is a delay between the button pressing, and the action actually getting performed, this is lag. When lag compensation is set to predictive the lag seems to be gone, but not really, as your character might not actually be where it seems. With it set to predictive you might find enemies hitting you from really far away, because your character is still actually near them. The Lag is always there, and I prefer to see where my character is actually at, so I set to lag compensation to none.

That is, if there is lag at all, or rather how big it is. And lag depends on the server and your connection to it

Link to comment
Share on other sites

29 minutes ago, DaZoul said:

When lag compensation is set to none, there is a delay between the button pressing, and the action actually getting performed, this is lag. When lag compensation is set to predictive the lag seems to be gone, but not really, as your character might not actually be where it seems. With it set to predictive you might find enemies hitting you from really far away, because your character is still actually near them. The Lag is always there, and I prefer to see where my character is actually at, so I set to lag compensation to none.

That is, if there is lag at all, or rather how big it is. And lag depends on the server and your connection to it

Thanks for the reply. I know that, but I never experencied something like this, like I mentioned before. I used to have lag compesation off all the time, and indeed theres is input delay, but never rubberbanding. I don't have much time RN, but I recorded a short video, I really don't know if you can see it because this problem do not accour all the time, sometimes you can't even notice but sometimes is pretty noticeable.

Link to comment
Share on other sites

12 hours ago, Spearowgilly said:

Thanks for the reply. I know that, but I never experencied something like this, like I mentioned before. I used to have lag compesation off all the time, and indeed theres is input delay, but never rubberbanding. I don't have much time RN, but I recorded a short video, I really don't know if you can see it because this problem do not accour all the time, sometimes you can't even notice but sometimes is pretty noticeable.

That is lag.  The predictive is doing its job smoothing it over.  Even if you're playing on a pc alone your pc is still running a server.  There are a lot of things that can effect your server performance like running other programs.

Link to comment
Share on other sites

10 hours ago, Shosuko said:

That is lag.  The predictive is doing its job smoothing it over.  Even if you're playing on a pc alone your pc is still running a server.  There are a lot of things that can effect your server performance like running other programs.

Ty for the reply. I'm pretty sure its not my pc or programs running in parallel. However my internet oscillates all the time, not that bad but instable. Can internet be related to this issues other than my pc? I kinda have high end pc and I'm monitoring the CPU usage, it doesnt passes 35% at the high peaks.

Link to comment
Share on other sites

5 hours ago, Spearowgilly said:

Ty for the reply. I'm pretty sure its not my pc or programs running in parallel. However my internet oscillates all the time, not that bad but instable. Can internet be related to this issues other than my pc? I kinda have high end pc and I'm monitoring the CPU usage, it doesnt passes 35% at the high peaks.

If you click the host game button or whatever it's called I don't think internet would be an issue. Steam's new dumbstuff could be causing it, I've seen it cause other similar things. It's unlikely to work in this situation, but if you want you could try switching the Steam client view off of library (such as by viewing your own profile) and closing both the out-of-game friends list & chat and the in-game friends list & chat.

Doing so has fixed various issues with various people, and it could fix this issue, but I don't think it will. But you could try.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...