Jump to content

Lightly modded colony from December 2019 - is it salvageable? Why are mods deactivating? Also, why is my FPS like +30 more?!


Recommended Posts

Last December I stopped playing my ONI colony due to massive FPS issues. I was getting like 15 FPS on speed 3 which basically played like jaggedy speed 1 and was pretty much no fun, especially due to upcoming projects all being rather big and long-term. So I let it be to wait for a new PC.

I don't have a new PC yet but my mom does and I wanted to get my save there to check it out. I opened it on my PC and I got mods crying murder at me. I restarted the game and about half of them were deactivated - including very simple stuff like decorative tiles. I generally had a very light mod loadout but something must've changed and that's my question here - what has changed that seems to have murdered so many tiny mods for an old save? Was there some huge update? And if so, can I save the colony somehow or is it done for since the game refuses to launch with those mods on?

I'm not a 100% on how the mod system works here. Usually games allow me to launch with any mods I got, only later stuff goes to hell :D

And on a much more positive note - what's up with the FPS? I left strugging due to getting 15FPS and now I let the colony go for like 5 minutes to test and it was staying at 40-45 FPS. Any huge updates to that over the past months? If so then good job Klei cause it sure did make a difference :)

Man, dare I get hyped for the DLC?!

Link to comment
Share on other sites

Hi and WB ellilea!

I never played with mods so I can't help you on the mod subject 

Game had major performance updates and much more and DLC was confirmed but no real ETA... if you are interested in details I recommend you read the last couple patch notes on the forum. 

Link to comment
Share on other sites

Some months ago there was a "major" performance patch that had no effect on my games. On the other hand, the third last and second last minor patches gained me a net 20-25 FPS. So yeah, there were major performance improvements scattered over the last patches! Very well done by klei

Link to comment
Share on other sites

3 hours ago, Ellilea said:

And on a much more positive note - what's up with the FPS? I left strugging due to getting 15FPS and now I let the colony go for like 5 minutes to test and it was staying at 40-45 FPS. Any huge updates to that over the past months? If so then good job Klei cause it sure did make a difference :)

There was a lot of performance work done. Even the preview versions with all the debug code are now playable. 

3 hours ago, Ellilea said:

Man, dare I get hyped for the DLC?!

Definitely!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...