Jump to content

Why won't my music mod upload? [MUSIC MOD HELP] [SOLVED]

Recommended Posts

Hello, I'm making another thread but this time it's something hopefully simple to fix; my mod works fine and I go to upload it using Mod Tools but it tells me either "Error uploading preview image" (I've since made it a proper 268 x 268 PNG image) or just simply "Error uploading mod". I've included a .ZIP with all my mod files. If that is not enough, PLEASE let me know. I've had to figure all this mod stuff out by myself pretty much and it's been quite frustrating to say the least. This is the image I tried to use.


Thank you!

Melee Music.zip

Edited by Mighty Jetters
Added preview image.
Link to comment
Share on other sites

6 hours ago, Mr. Tiddles said:

My first thought is maybe the file size. You can check the uploader log via C:/ Users/ USERNAME/ AppData/ Local/ Don't Starve Mod Uploader / ModUploader.log

Thanks for your reply! My .FSB  included in the archive is actually only 54.9 MB (the limit's 100, right?).

I should've mentioned that the modmain.lua and other such things are in there too. Here's also my log.


By the way, I should have also mentioned that I used Cagealicous' new guide along with Cheerio's music mod tutorial files. Also used DST Mod Tools' built-in FMOD Designer.

EDIT: Adding another version of the uploader log after once again attempting to upload my Melee mod with a working preview image (it worked for my Deltarune mod I just uploaded so it's not the image):


Edited by Mighty Jetters
Link to comment
Share on other sites

Is the size limit actually 50 MB? Nothing I try to make the sound files smaller seems to work, and not all of them will loop properly so it's not a good idea to just cut them at the halfway point. I also uploaded my two most recent mod tools upload logs above.

Link to comment
Share on other sites

Well, the preview image error is fixed, but now it's just saying "Error publishing mod!" all over again. I checked the uploader log but it seems to imply it was successfully uploaded when it wasn't. I included the mod files in the OP above if anybody wants to have a look to see if they can spot what might've went wrong? Thanks for the current replies though!


EDIT: Whoops, I forgot the project file. No wonder nobody knows what to do.


Edited by Mighty Jetters
Added the project file like I should've done in the beginning.
Link to comment
Share on other sites

2 minutes ago, Mighty Jetters said:

I changed the version number as well as the full stop in the title of the mod in case that did anything as well as the preview image by a couple pixels. Still no dice. :[ Here's the modinfo.lua and the newest log. Sorry for the trouble, I really appreciate it.



icon_atlas = ""
icon = ""

These shouldn't be empty, it should be something like

icon_atlas = "modicon.xml"
icon = "modicon.tex"

(I think that's the error? Try fixing that and then uploading the mod)

  • Thanks 1
Link to comment
Share on other sites

20 hours ago, Mighty Jetters said:

Funny thing is they were empty when I uploaded my Kirby 64 and Deltarune mods.

Where do I get an XML for the atlas?


This one just says "Show the whole image". Make the image power-of-two (128x128, 256x256, 512x512, no larger) and convert it to tex-format. Then name the xml file the same as the tex-file, e.g. modicon.xml and place the tex and xml files next to your modinfo.lua file. Then put in the filenames in your modinfo.lua file.

About your bigger problem

21 hours ago, Mighty Jetters said:

I changed the version number as well as the full stop in the title of the mod in case that did anything as well as the preview image by a couple pixels. Still no dice.

You fixed it. You got a new error. This new error is EResult 9, which means your preview image cannot be identical to the last preview image you uploaded. Yes, failed publishes count, so your EResult 8 has probably landed you here. Try using the original image again.


Edited by Ultroman
  • Thanks 1
Link to comment
Share on other sites

I put the .XML and .TEX in the same folder as the modinfo.lua, and yet... "Error: Failed sharing mod data file". /:


I was supposed to leave the TEX conversion on default settings, right? DTX5 or something like that? I used Handsome Matt's TEX Creator.

Edited by Mighty Jetters
Added information.
Link to comment
Share on other sites

5 hours ago, Mighty Jetters said:

I was supposed to leave the TEX conversion on default settings, right? DTX5 or something like that? I used Handsome Matt's TEX Creator.

I don't know that one. Probably. I use TEXTool, but I'm told it's old (but it works with standard settings).

Now it's saying "EResult 16". You're collecting the set :D This one means "Timeout" while uploading a file. You can look up the errors yourself in the list below. When looking for the error in your ModUploader.log, scroll to the bottom, and then keep scrolling upwards until you see the first EResult that isn't 1.

List of all the EResult errors and their meaning


EResult 0   = EResult_Invalid
EResult 1   = EResult_OK
EResult 2   = EResult_Fail
EResult 3   = EResult_NoConnection
EResult 5   = EResult_InvalidPassword
EResult 6   = EResult_LoggedInElsewhere
EResult 7   = EResult_InvalidProtocolVer
EResult 8   = EResult_InvalidParam
EResult 9   = EResult_FileNotFound
EResult 10  = EResult_Busy
EResult 11  = EResult_InvalidState
EResult 12  = EResult_InvalidName
EResult 13  = EResult_InvalidEmail
EResult 14  = EResult_DuplicateName
EResult 15  = EResult_AccessDenied
EResult 16  = EResult_Timeout
EResult 17  = EResult_Banned
EResult 18  = EResult_AccountNotFound
EResult 19  = EResult_InvalidSteamID
EResult 20  = EResult_ServiceUnavailable
EResult 21  = EResult_NotLoggedOn
EResult 22  = EResult_Pending
EResult 23  = EResult_EncryptionFailure
EResult 24  = EResult_InsufficientPrivilege
EResult 25  = EResult_LimitExceeded
EResult 26  = EResult_Revoked
EResult 27  = EResult_Expired
EResult 28  = EResult_AlreadyRedeemed
EResult 29  = EResult_DuplicateRequest
EResult 30  = EResult_AlreadyOwned
EResult 31  = EResult_IPNotFound
EResult 32  = EResult_PersistFailed
EResult 33  = EResult_LockingFailed
EResult 34  = EResult_LogonSessionReplaced
EResult 35  = EResult_ConnectFailed
EResult 36  = EResult_HandshakeFailed
EResult 37  = EResult_IOFailure
EResult 38  = EResult_RemoteDisconnect
EResult 39  = EResult_ShoppingCartNotFound
EResult 40  = EResult_Blocked
EResult 41  = EResult_Ignored
EResult 42  = EResult_NoMatch
EResult 43  = EResult_AccountDisabled
EResult 44  = EResult_ServiceReadOnly
EResult 45  = EResult_AccountNotFeatured
EResult 46  = EResult_AdministratorOK
EResult 47  = EResult_ContentVersion
EResult 48  = EResult_TryAnotherCM
EResult 49  = EResult_PasswordRequiredToKickSession
EResult 50  = EResult_AlreadyLoggedInElsewhere
EResult 51  = EResult_Suspended
EResult 52  = EResult_Cancelled
EResult 53  = EResult_DataCorruption
EResult 54  = EResult_DiskFull
EResult 55  = EResult_RemoteCallFailed
EResult 56  = EResult_PasswordUnset
EResult 57  = EResult_ExternalAccountUnlinked
EResult 58  = EResult_PSNTicketInvalid
EResult 59  = EResult_ExternalAccountAlreadyLinked
EResult 60  = EResult_RemoteFileConflict
EResult 61  = EResult_IllegalPassword
EResult 62  = EResult_SameAsPreviousValue
EResult 63  = EResult_AccountLogonDenied
EResult 64  = EResult_CannotUseOldPassword
EResult 65  = EResult_InvalidLoginAuthCode
EResult 66  = EResult_AccountLogonDeniedNoMail
EResult 67  = EResult_HardwareNotCapableOfIPT
EResult 68  = EResult_IPTInitError
EResult 69  = EResult_ParentalControlRestricted
EResult 70  = EResult_FacebookQueryError
EResult 71  = EResult_ExpiredLoginAuthCode
EResult 72  = EResult_IPLoginRestrictionFailed
EResult 73  = EResult_AccountLockedDown
EResult 74  = EResult_AccountLogonDeniedVerifiedEmailRequired
EResult 75  = EResult_NoMatchingURL
EResult 76  = EResult_BadResponse
EResult 77  = EResult_RequirePasswordReEntry
EResult 78  = EResult_ValueOutOfRange
EResult 79  = EResult_UnexpectedError
EResult 80  = EResult_Disabled
EResult 81  = EResult_InvalidCEGSubmission
EResult 82  = EResult_RestrictedDevice
EResult 83  = EResult_RegionLocked
EResult 84  = EResult_RateLimitExceeded
EResult 85  = EResult_AccountLoginDeniedNeedTwoFactor
EResult 86  = EResult_ItemDeleted
EResult 87  = EResult_AccountLoginDeniedThrottle
EResult 88  = EResult_TwoFactorCodeMismatch
EResult 89  = EResult_TwoFactorActivationCodeMismatch
EResult 90  = EResult_AccountAssociatedToMultiplePartners
EResult 91  = EResult_NotModified
EResult 92  = EResult_NoMobileDevice
EResult 93  = EResult_TimeNotSynced
EResult 94  = EResult_SMSCodeFailed
EResult 95  = EResult_AccountLimitExceeded
EResult 96  = EResult_AccountActivityLimitExceeded
EResult 97  = EResult_PhoneActivityLimitExceeded
EResult 98  = EResult_RefundToWallet
EResult 99  = EResult_EmailSendFailure
EResult 100 = EResult_NotSettled
EResult 101 = EResult_NeedCaptcha
EResult 102 = EResult_GSLTDenied
EResult 103 = EResult_GSOwnerDenied
EResult 104 = EResult_InvalidItemType
EResult 105 = EResult_IPBanned
EResult 106 = EResult_GSLTExpired
EResult 107 = EResult_InsufficientFunds
EResult 108 = EResult_TooManyPending
EResult 109 = EResult_NoSiteLicensesFound
EResult 110 = EResult_WGNetworkSendExceeded
EResult 111 = EResult_AccountNotFriends
EResult 112 = EResult_LimitedUserAccount
EResult 113 = EResult_CantRemoveItem


Edited by Ultroman
  • Thanks 1
Link to comment
Share on other sites

Maybe I'm dumb but I'm not finding anything on Google when looking for EResult 16. I can infer what "timeout" means, but not how to fix that or why I'm even getting so many errors on this one specific mod. Maybe I built it incorrectly? Maybe it's the sound files?

Sorry, I'm just a complete noob at these things and literally have no idea what I'm doing but I really appreciate someone actually replying. :?

Link to comment
Share on other sites

No, m8. It's telling you exactly what's wrong. Now you've fixed 3 errors, and are left with either a network/server error, or the server is rejecting the file for some reason.

A "timeout" while uploading means that it took longer for your connection to upload the file than the server permitted, so the server cut you off when it timed out.

  • Thanks 1
Link to comment
Share on other sites

So, it finally uploaded. I'm beyond confused but I'll take it.

Only problem now is the image is broken LMFAO

That, and I have to redo the entire thing because the music sounds atrocious. But I know how to do that at least.

EDIT: All I had to do was edit the mod and upload the original .PNG file. I knew it wasn't the image... weird freaky mod tools and its weird freaky errors lol.

Thank you so much for your help!

Edited by Mighty Jetters
Link to comment
Share on other sites

14 hours ago, Mighty Jetters said:

weird freaky mod tools and its weird freaky errors lol.

It is finicky, but it's not actually the DS Mod Tools that's the problem. It's the Steam API. DS Mod Tools just relays the error it receives when trying to upload the files to the workshop. Could the DS Mod Tools perhaps do many of these checks for you? Sure, but that would also require more maintenance for the DS Mod Tools whenever Steam changes things in the API. Could they give better reports about what the EResult errors mean? Definitely, but again, if Steam changes something about when which EResult is returned, then DS Mod Tools would have to be changed, as well.

Does Steam change these things a lot? No, but it is an unnecessary complexity resulting in an unpredictable extra cost in maintenance.

Good thing we have had a bunch of these, so we can refer to old posts where someone dug up a solution :)

14 hours ago, Mighty Jetters said:

Thank you so much for your help!

You are very welcome, m8 :) Glad it worked out.

  • Like 1
Link to comment
Share on other sites


Whoops, it's been a while and things have been going fine, but now I ran into a brand new problem: I needed to update ALL of my mods as none of the Woodie music was working because the filenames within the modmain.lua I was using didn't match the names in the actual project file. Example: the modmain.lua had "hoedown" when the project file had "music_hoedown".

Anyway, the problem is that when trying to upload the edited files, it gives me "Error: Failed sharing mod data file." What does this mean? Here it is and the log (because I can't find anything) if needed. Sorry to come back with more!



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...