Sign in to follow this  
Tegila

Mods worked fine, then not, errors after disabling

Recommended Posts

Tegila    0

Never tried using mods in a game before though many friends do a ton, but I do do my own .Kia programming etc for my eqemu server so I am familiar. I downloaded and added a bunch of mods this morning, some wouldn't work but most did just fine all together, for 50 game days. Saved and exited to run errands, came back and with no updates or other changes whatsoever, game crashed upon loading the save. Plenty of lines, have log on computer, but through that and all following crashes color cubes or color blocks was always one of the error strings. 

I tried making a new game with only a few of the mods, same crash. Disabled all mods, created new world but with presets...same crash. Mods disabled yet crash says to disable mods. Removed the mods from the mod folder as well as disabled, still crashed no matter what...except once it let me load the game without any mods that had previously had about 10, and I suicides a few times to get the xp for new chars (this was a new install after old install began crashing at different time and for different reasons) So, once accomplished began new world with all mods removed from folder and of course disabled, and still got the same crashes. Tried running the installer hoping it would repair things but no dice until full uninstall and reinstall. I understand mods having issues though the work fine til save and reenter is a little wonky, but then disabling and removing and even fresh games and worlds would crash before fully launching, that I don't understand. After full removal and reinstall everything is again fine, but now I'm afraid to do anything if using mods can permanently screw up the game files, how is that possible?

Share this post


Link to post
Share on other sites
phasic    1

Interesting, I was having a lot of the same problems over the weekend. Is this with DLC like Shipwrecked or Hamlet? I traced back the issue to mods having incompatible api_versions. Not sure how it all works but my suspicion is that game files will be changed to accommodate api_versions and create conflicts that way. You can check the mod_info files in all of your mods, or older mods will show that they are out of date in-game. The solution of course would be to use mods that only use api_version = 6.

Share this post


Link to post
Share on other sites
bizziboi    835

Some mods can be quite aggressive and overwrite game files. The way to resolve that is to verify your game files in steam.

Share this post


Link to post
Share on other sites
phasic    1
5 minutes ago, bizziboi said:

Some mods can be quite aggressive and overwrite game files. The way to resolve that is to verify your game files in steam.

Can they be so aggressive that the game needs a full reinstall, because he said he verified game files first before reinstalling?

Share this post


Link to post
Share on other sites
bizziboi    835

No it shouldn't, unsubscribing, emptying the mod folder and verifying should do the trick - as far as I know.

I don't see where he says he verified game files though?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this