Overlays cause framerate drop


Aru3
  • Known Issue

When I turn on the "power grid" overlay, there is a large frame rate drop which is proportionate to the amount of electrical things (wires, presumably) on the screen at the moment. So, zooming out allows more wires, which drops it the most. None of the other overlays do this, only power grid.

IGNORING COAL GENERATOR (ARU).sav

edit: Framerate seems to drop with all of the overlays, actually. It only runs at about 50 fps normally when zoomed out, but the wire overlay drops it to about 18. The overlays all hurt significantly, but not nearly as much (as the power grid overlay).


Steps to Reproduce
Lay a large number of wires, nothing ridiculous, similar to what you'd expect in a medium to large sized colony. Then zoom all the way out and try to pan the camera, and the reduced frame rate is significant. Do the same with any other overlay, such as gas or liquid, and it's fine, no decrease at all.

Status: Known Issue

We are aware of this issue and have it logged internally but either we do not have a fix ready yet or we are not planning on addressing the issue in the immediate future.


  Report Bug


User Feedback


....

I think this is what is causing my computer to slowly become slowly slower until the game finally locks up.

Edited by vonVile

Share this comment


Link to comment
Share on other sites
....

This issue might have to do with the type of computer you're running 'Oxygen Not Included' on. It does specify that you will need a pretty decent comp. to run the game. Which is problem I saw while purchasing this game.

The warning about the need of a fast computer is only seen after you've purchased and downloaded the game. Which may cause some people to buy the game, without being able to even play it...

Share this comment


Link to comment
Share on other sites
....
3 hours ago, vonVile said:

I think this is what is causing my computer to slowly become slowly slower until the game finally locks up.

I doubt it, that's probably the memory leak, hah. (edit: There is also a performance leak, now that I specifically looked for it. But the memory leak is probably what causes it to eventually freeze.)

3 hours ago, SirKarma_ said:

This issue might have to do with the type of computer you're running 'Oxygen Not Included' on. It does specify that you will need a pretty decent comp. to run the game. Which is problem I saw while purchasing this game.

The warning about the need of a fast computer is only seen after you've purchased and downloaded the game. Which may cause some people to buy the game, without being able to even play it...

RX 470 graphics, FX-6300 at 4.6 GHz, the game should be trivial to run. It makes sense that a pre-alpha will perform badly, but something is very wrong with the overlays, especially the power grid one. Even when the game is paused, it runs 3 CPU cores at ~50% and frame rate is about one-third of what it usually is. (No physics calculations are being done when paused.) Of course, it runs the CPU like that even without the overlays, but then the frame rate is higher.

Edited by Aru3

Share this comment


Link to comment
Share on other sites
....

In one gaming session my RAM usage grew up to 5.5 GB. After restarting the game it was 1 GB and the game ran normally.

As for the FPS drops, I also get them in the overlay view, but when I'm scrolling the map.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now