Bugged Mod List


TrashLord
  • Known Issue

For about a week, I've been having a problem with my in-game mod list - a lot of my mods haven't been being labeled properly, only displaying their workshop filenames.

bugged modlist.PNG

I wouldn't mind too much, but it's kind of difficult to track down broken mods if you can't tell which is which, I'm 100% sure many of the bugged mods are client-only mods since many of my client mods aren't listed anymore despite still being subscribed to them, and I'm about 86% sure that this is the reason I'm having a hard time connecting to friends' servers.

I've tried updating everything with the in-game updater, unsubscribing and resubscribing, uninstalling and reinstalling the game, switching between the main game and beta branch, and even manually deleting all the workshop files from my mods folder(though some of them needed administrator permission to delete and I couldn't remove them even though I am the administrator), but my mods still won't load in properly. Is anyone else having this problem? If you have, can you tell me how you fixed it?


Steps to Reproduce
IDK it's not technically a gameplay bug so i don't think there's a way to "reproduce" it.
  • Like 1


User Feedback




Are you able to see the mod folder in either of these locations? And in the folder matching the mod id, are there any files?

C:\Program Files (x86)\Steam\steamapps\workshop\content\322330
or in
C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\mods

  • Like 1
  • Thanks 1

Share this comment


Link to comment
Share on other sites
17 hours ago, PeterA said:

What are the contents of that folder?

I assume you're talking about the 2172351538 folder inside the 322330.

The normal mod files,

All of them seem to be complete and normal to me (i used to make some mods myself)

image.thumb.png.7f71ba17ea792785d8daa368efe7a1e2.png

This is the folder with the mod i used to test before, the Edward Elric one

 

Edited by Super_Xayah
Correcting the folder number

Share this comment


Link to comment
Share on other sites
On 4/29/2022 at 11:41 AM, Super_Xayah said:

is there something else i can do?

You might want to try deleting that mod's folder, and also try running Steam as an administrator. 

If you could also show us the folder permissions as described here, that might be helpful.

 

  • Like 1
  • Thanks 1

Share this comment


Link to comment
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now