Jump to content

[Solved] Custom Recipe Invisible on Crock Pot


Recommended Posts

I've added a custom item and a recipe for it.
The item works fine, shows up in the inventory and on the ground, and it gets cooked in the crock pot correctly as well, but when the cooking is finished the pot looks empty. Still harvestable and gives the item, but the item is invisible on it.

I've searched for this issue and seen quite a bit about it, and the most current solution seems to be found in this tutorial:

Unfortunately, I've followed it meticulously and it still doesn't work.
I have the following folder structure:

  • Mod directory
    • anim
      • macncheese.zip
    • exported
      • macncheese
        • macncheese.scml
        • macncheese.zip (created when the autocompiler was run)
        • macncheese
          • macncheese-0.png

I used the meat stew image with altered colors for now.
I've attached an image of the Spriter project, and here are its contents:

Spoiler

<?xml version="1.0" encoding="UTF-8"?>
<spriter_data scml_version="1.0" generator="BrashMonkey Spriter" generator_version="b5">
    <folder id="0" name="macncheese">
        <file id="0" name="macncheese/macncheese-0.png" width="192" height="192" pivot_x="0.494819" pivot_y="0.380829"/>
    </folder>
    <entity id="0" name="macncheese">
        <animation id="0" name="idle" length="1000">
            <mainline>
                <key id="0">
                    <object_ref id="0" name="macncheese" folder="0" file="0" abs_x="1.005181" abs_y="0.119171" abs_pivot_x="0.494819" abs_pivot_y="0.380829" abs_angle="360" abs_scale_x="1" abs_scale_y="1" abs_a="1" timeline="0" key="0" z_index="0"/>
                </key>
            </mainline>
            <timeline id="0" name="macncheese">
                <key id="0" spin="0">
                    <object folder="0" file="0" x="1.005181" y="0.119171"/>
                </key>
            </timeline>
        </animation>
    </entity>
</spriter_data>

 

I've attached the exported/ folder with all the relevant files.
If anyone has any idea what I'm doing wrong, I'd really appreciate some help.

Thanks in advance.

Spriter.png

exported.zip

Edited by Clopen
  • Like 1
Link to comment
Share on other sites

Problem solved.

I defined the recipe and called AddCookerRecipe inside a character prefab rather than in modmain.
This caused the game to add the recipe as a regular one instead of one from a mod, so it looked for the graphics in the cook_pot_food anim instead of mine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...