Jump to content

Corrupt Spriter project after decompiling


Recommended Posts

I am using Krane (from ktools) to decompile projects. This has always been fine, until recently.

I tried to decompile the pigking with the command krane anim.bin build.bin pigking_project. See the attachment for the result.

Has something changed in Spriter or the way DST compiles Spriter projects internally? Because the tools I have always used, do not seem to work anymore for certain animations. Note that I have decompiled the pigking in the past and that this worked fine before.

Could anyone else try to do the same to see if they get similar results with the pigking? Or does someone have ideas how to fix this?

- Jochem

Screenshot from 2018-06-24 13-30-17.png

Edited by Joachim
Link to comment
Share on other sites

I has the same problem on both Windows 7 and Ubuntu 18.04.
The problem arises in some of games' animation files and all of MODs' animation files. But even more bizarre, some of games' animation files are right.
English is not my native language. Please forgive me for some of my mistakes. Thanks.

Link to comment
Share on other sites

Hello, I had the same problem. I recently de compiled warg animations and everything was fine till I recompile to DS anim.bin. Then, the death animation got buggy and discovered that is because it creates new objects in spriter (rather than use the original). For example, eat_90s it's same length but doesn't bug, and I saw that eat has warg-mouth and death has warg-mouth_0 and progresses to warg-mouth_3 in the next frames... this causes in-game to be extra created rather than deleted (the old ones). Don't know if I expressed well, I'll try post an example if needed

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...